Cannot boot from SD cards any longer.
#1
Not sure what I'm doing wrong here but I cannot boot from the SD Card any longer.  I tried multiple cards and multiple images.  I can't even boot off of jumpdrive installed on SD cards to reflash eMMC.  So now I'm stuck with a dud.  My unlock password is not working and I can't reload a new image on the eMMC or boot to an alternate image from SD.  Anyone else run in to this problem or have any ideas on how to get it working again?

More info: I can get it to boot in to the default OS and access it BEFORE the screenlock kicks on.  While in this mode, when I run lsblk from terminal, I CAN indeed see the SD Storage card here so I's not like it's dead.....it's just that I can't boot off of any images any longer.
  Reply
#2
(04-15-2021, 03:24 PM)MadHopsMan Wrote: Not sure what I'm doing wrong here but I cannot boot from the SD Card any longer.  I tried multiple cards and multiple images.  I can't even boot off of jumpdrive installed on SD cards to reflash eMMC.  So now I'm stuck with a dud.  My unlock password is not working and I can't reload a new image on the eMMC or boot to an alternate image from SD.  Anyone else run in to this problem or have any ideas on how to get it working again?

More info: I can get it to boot in to the default OS and access it BEFORE the screenlock kicks on.  While in this mode, when I run lsblk from terminal, I CAN indeed see the SD Storage card here so I's not like it's dead.....it's just that I can't boot off of any images any longer.
Are you sure you're using the correct jumpdrive? There are three of them - 2g, 3g pinephone, and pinetab version. Maybe you have a model with the dram clockspeed issue? Lower it, and you may get a boot. It's in the forum.
  Reply
#3
(04-15-2021, 11:53 PM)rocket2nfinity Wrote: Are you sure you're using the correct jumpdrive? There are three of them - 2g, 3g pinephone, and pinetab version. Maybe you have a model with the dram clockspeed issue? Lower it, and you may get a boot. It's in the forum.

Well, there's appears to only be one now for all PinePhone's so yes, I assume so.  I downloaded from here: https://github.com/dreemurrs-embedded/Ju...e/releases

Regarding the DRAM clock speed, I don't see how that would help and I don't have any way to install...I don't know my user password and I can't reset.  Sad   As I mentioned, It WAS booting from SD card until recently so I'm not even sure it would apply.
  Reply
#4
(04-15-2021, 03:24 PM)MadHopsMan Wrote: Not sure what I'm doing wrong here but I cannot boot from the SD Card any longer.  I tried multiple cards and multiple images.  I can't even boot off of jumpdrive installed on SD cards to reflash eMMC. 

Really odd.

Have you tried a thorough wipe of one of the MicroSDs before flashing an image?

Mounted in linux you can run:
sudo dd if=/dev/zero of=/dev/sdX
(where sdX is the device of the drive to delete)

In windows (cmd) you can run diskpart, select the drive, then "clean all".

What method/tool are you using for the flash?

Are you using your Pinephone without a sim currently? If so, are you possibly putting the microsd in the sim slot by accident? Easily done, it does fit a little to nicely in the sim slot and you wouldn't be the first... I'm guilty of that silly error myself! (unlikely as you said you can see the card via lsblk... but throwing it out there)
  Reply
#5
(04-16-2021, 11:12 AM)neil_swann80 Wrote: Really odd.

Have you tried a thorough wipe of one of the MicroSDs before flashing an image?

Mounted in linux you can run:
sudo dd if=/dev/zero of=/dev/sdX
(where sdX is the device of the drive to delete)

In windows (cmd) you can run diskpart, select the drive, then "clean all".

What method/tool are you using for the flash?

Are you using your Pinephone without a sim currently?  If so, are you possibly putting the microsd in the sim slot by accident?  Easily done, it does fit a little to nicely in the sim slot and you wouldn't be the first... I'm guilty of that silly error myself!  (unlikely as you said you can see the card via lsblk... but throwing it out there)

Thanks for the suggestions.  Unfortunately they don't make a difference.  I'm positive the SD is in the correct slot .  As I mentioned above, I can see it in the terminal on the device when I run lsblk.  Regarding flashing, I normally use balenaEtcher as it's been foolproof but I've tried with dd and doing a full zeroing of the card.  All the same problem: no attempt to boot from the SD card. Sad
  Reply
#6
Do you have the serial cable for the device? If so can you get the console output when you try booting into Jumpdrive? I've been having a similar problem where the boot process would hang before getting to the Linux init.rd. So far the only image I have found that will boot from an SD card is the latest beta for Manjaro with Plasma Mobile. I suspect that there is some boot firmware that is not configuring the power management IC correctly (the AXP803). On occasion the image flashed to the eMMC will hang trying to probe this part.

Having the console output during the boot would be helpful in diagnosing the problem. If you are able capture it while trying to boot several different images, the outputs can be compared to try and isolate the problem.
  Reply
#7
So..apparently I can only make 3 post per day before I get blocked/throttled. How fun!!! Seriously, wtf is up with that?

Anyhow, I guess I better make my words here very succinct.

So no, I don't have a serial cable but I might be able to make one if necessary...maybe. If not, I see I can easily purchase the necessary items online. By the sounds of things I will need to buy one but I'm still somewhat flumoxed...this was working great for months, I was testing out Ubuntu Touch, KDE Plasma, Sailfish and newer PostMarketOS builds via SD cards...then nothing. It this point I suspect hardware problems...

I was hoping someone here had the same issue and had a fix, but it appears that is not the case at all. I'm going to open a support ticket with them and hope for the best...though my hopes aren't that high at this point.

On the bright side, I did finally figure out my lockscreen password but that really doesn't help with the main problem here Sad

Thanks everyone for the suggestions thus far and any others would be appreciated.
  Reply
#8
Try booting from the modified version of JumpDrive linked in this post https://forum.pine64.org/showthread.php?...2#pid94502
If it works, then the card detect switch is damaged in the SD socket. The modified JumpDrive image ignores the state of the switch.
  Reply
#9
Mainboards are $20, the usbcport replacement even less I imagine. Also try the "usb-c fix for pinephones" on youtube video. Less than 6min video, very detailed and simple to do. I haven't even tested my convergence dongle yet. I hope I'm in for a good surprise. I didn't test squat. I've only installed mobian phosh and that's it. Manjaro kde plasma can kma. No offense

My dock is detected (Ican dock and undock from the notification area as well) but monitor detects nothing. The phone very briefly tried to go into the splitscreen mode it's supposed to when connected but the monitor remained blank. I'm not giving the dock any power but that from the phone so maybe it needs more power. I suspect i will have to do the usbc mod. The mouse was detected via the usb2.4 dongle and that's as far as I got. I definitely need the pine64 power supply. I'll probably do the mod beforehand in any case unless it's just a power issue. I don't know. NBD. It still boots and acts as a phone which is all that matters.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  SD slot damaged, can't boot from SD, what to do? nelstomlinson 6 144 07-31-2021, 03:46 PM
Last Post: nelstomlinson
  Won't boot - Failed to read Who-Am-I register nocargo 3 599 07-09-2021, 05:34 PM
Last Post: ewPine
  UPDATED (June 2021): 17-distro multi-boot image for Pinephone (incl. 3GiB variant) megous 155 105,214 07-07-2021, 12:18 PM
Last Post: calinb
  Sim cards and carriers, discussion bcnaz 72 24,258 07-04-2021, 11:16 AM
Last Post: calinb
  Can't boot from eMMC or SD card... Nibel 1 344 06-03-2021, 08:41 PM
Last Post: ppafin
  how to boot pinephone over USB with sunxi-fel? bobwidlefish 0 465 03-18-2021, 11:49 AM
Last Post: bobwidlefish
  PinePhone postmarketOS edition does not boot up properly anymore, black screen loops MrSaudade 3 977 03-07-2021, 06:11 AM
Last Post: Veraendert
  Initial boot failure bvansteen 1 466 03-04-2021, 12:39 AM
Last Post: tllim
  Cannot boot to SD card - Completely locked out of my phone the day I got it Giddyup 5 960 02-15-2021, 11:45 AM
Last Post: Giddyup
  How to boot from SD TheBoneJarmer 4 1,269 12-19-2020, 05:23 AM
Last Post: ryo

Forum Jump:


Users browsing this thread: 1 Guest(s)