Gimp makes stock Manjaro KDE/X11 crash
#1
I can open Gimp, but as soon as I open any image in it, KDE or X11 (don't know) starts blacking out, screen goes black, parts of screen go black, cursor does whatever it wants... Basically have to hard restart.

Is there a package missing or something? Thanks!!
  Reply
#2
(04-10-2021, 03:19 AM)stozi Wrote: I can open Gimp, but as soon as I open any image in it, KDE or X11 (don't know) starts blacking out, screen goes black, parts of screen go black, cursor does whatever it wants... Basically have to hard restart.

Is there a package missing or something? Thanks!!

It looks like you are hitting https://gitlab.freedesktop.org/mesa/mesa/-/issues/4389.

Until the fix to Mesa is merged and makes its way to an update (which might take a couple of weeks), you can try the workaround, which is to set the environment variable PAN_MESA_DEBUG=noafbc for X. Depending on how launch X, it might be enough to just put it in /etc/environment.

Alternatively, you can also try using GIMP from a Wayland compositor or Xephyr window. Even a Wayland compositor running nested inside the X session should work.
  Reply
#3
(04-10-2021, 04:39 AM)icecream95 Wrote: Alternatively, you can also try using GIMP from a Wayland compositor or Xephyr window. Even a Wayland compositor running nested inside the X session should work.

I have the same issue with GIMP so (based on your suggestion) I used:
Code:
GDK_BACKEND=wayland gimp
and it seems to work fine now. Better than ever in fact! Big Grin  Thanks!
  Reply
#4
(04-16-2021, 10:46 PM)MtnSk8 Wrote:
(04-10-2021, 04:39 AM)icecream95 Wrote: Alternatively, you can also try using GIMP from a Wayland compositor or Xephyr window. Even a Wayland compositor running nested inside the X session should work.

I have the same issue with GIMP so (based on your suggestion) I used:
Code:
GDK_BACKEND=wayland gimp
and it seems to work fine now. Better than ever in fact! Big Grin  Thanks!
I just switched to KDE wayland, which is all good, just the copy function (in general) is now strangely unreliable
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Manjaro versions bad and good gilwood 0 488 02-12-2024, 05:03 PM
Last Post: gilwood
  Brand new Pinebook Pro doesn't boot after Manjaro update johnboiles 8 2,984 12-15-2023, 02:11 PM
Last Post: wdt
  PBP won't boot after trying to reinstall Manjaro ARM soupgirl 3 1,096 12-13-2023, 08:17 PM
Last Post: trillobite
  Games compilation howto on the Pinebook-pro (Manjaro Linux and Debian native) astr0baby 201 333,445 05-12-2023, 06:09 AM
Last Post: korreckj328
  Manjaro Plasma blinking cursor jcun4128 4 1,756 05-08-2023, 11:17 AM
Last Post: korreckj328
  PBP blank screen after updating Manjaro Franko 6 2,417 04-01-2023, 07:55 AM
Last Post: hacknix
  Manjaro - which libdrm? hacknix 0 681 04-01-2023, 03:21 AM
Last Post: hacknix
  Partial boot after installing Manjaro on emmc regivanx 11 3,840 02-06-2023, 09:11 AM
Last Post: wdt
  Manjaro pinebookpro images with kernel 5.7.19 rfm83 11 5,474 01-22-2023, 10:05 PM
Last Post: rfm83
  No boot after Manjaro flash PBcurry 14 6,310 10-03-2022, 08:33 PM
Last Post: wdt

Forum Jump:


Users browsing this thread: 1 Guest(s)