auto-brightness problem phone screen going to completely dim
#1
Hi, I've applied all recent updates but my Pine Phone KDE Plasma (community edition) keeps automatically going auto-brightness to completely dim. 
Is anybody else having this problem and what is the solution?  
Settings Slider keeps scooting to the left and the phone screen goes completely dark. 
thanks 
Don
  Reply
#2
(03-23-2021, 09:53 PM)DonF22 Wrote: Hi, I've applied all recent updates but my Pine Phone KDE Plasma (community edition) keeps automatically going auto-brightness to completely dim. 
Is anybody else having this problem and what is the solution?  
Settings Slider keeps scooting to the left and the phone screen goes completely dark. 
thanks 
Don
Yup, seems to me a phosh feature. Only option at present us to do brightness manually.
  • ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Arch (5.16 kernel, Openbox desktop) for general purpose daily PC.
  • PinePhone Pro Explorer Edittion, Tow-boot on SPI, Arch/phosh on eMMC
  • PinePhone BraveHeart now v1.2b 3/32Gb, daily driver: Tow-boot with Arch/Phosh on eMMC
  Reply
#3
(03-23-2021, 09:53 PM)DonF22 Wrote: Hi, I've applied all recent updates but my Pine Phone KDE Plasma (community edition) keeps automatically going auto-brightness to completely dim. 
Is anybody else having this problem and what is the solution? 

Did you try to adjust display timeout setting using Settings -> Screen?
I did and got the same situation as you did.
I solved that to manually editing the file /.config/powermanagementprofilesrc
It seems that the Screen settings app inserted there [BrightnessControl] value 0.5, which is not 50 % but 0.5 in a scale of hundred or 0.5% Big Grin. Also needed to edit the screen timeout values to reasonable ones.
  Reply
#4
Editing the file worked, I figured out nano.
I didn't see the screen timeout values tho, what are they called?  
Thanks very much


(03-23-2021, 09:53 PM)DonF22 Wrote: Hi, I've applied all recent updates but my Pine Phone KDE Plasma (community edition) keeps automatically going auto-brightness to completely dim. 
Is anybody else having this problem and what is the solution? 

Did you try to adjust display timeout setting using Settings -> Screen?
I did and got the same situation as you did.
I solved that to manually editing the file /.config/powermanagementprofilesrc
It seems that the Screen settings app inserted there [BrightnessControl] value 0.5, which is not 50 % but 0.5 in a scale of hundred or 0.5% Big Grin. Also needed to edit the screen timeout values to reasonable ones.
  Reply
#5
(03-29-2021, 03:53 PM)DonF22 Wrote: Editing the file worked, I figured out nano.
I didn't see the screen timeout values tho, what are they called?  

They are in different [DimDisplay] sections and called "idleTime"
  Reply
#6
(03-24-2021, 05:13 AM)acrux Wrote:
(03-23-2021, 09:53 PM)DonF22 Wrote: Hi, I've applied all recent updates but my Pine Phone KDE Plasma (community edition) keeps automatically going auto-brightness to completely dim. 
Is anybody else having this problem and what is the solution? 

Did you try to adjust display timeout setting using Settings -> Screen?
I did and got the same situation as you did.
I solved that to manually editing the file /.config/powermanagementprofilesrc
It seems that the Screen settings app inserted there [BrightnessControl] value 0.5, which is not 50 % but 0.5 in a scale of hundred or 0.5% Big Grin. Also needed to edit the screen timeout values to reasonable ones.
how do you open /.config/powermanagementprofilesrc ? can I do it on the phone itself? or do I need to plug it into the dock? I found the .config folder, but it is greyed out and says "nothing here" when I open it. do I need to use terminal and sudo commands?
  Reply
#7
(05-09-2021, 03:37 PM)mudflap Wrote:
(03-24-2021, 05:13 AM)acrux Wrote:
(03-23-2021, 09:53 PM)DonF22 Wrote: Hi, I've applied all recent updates but my Pine Phone KDE Plasma (community edition) keeps automatically going auto-brightness to completely dim. 
Is anybody else having this problem and what is the solution? 

Did you try to adjust display timeout setting using Settings -> Screen?
I did and got the same situation as you did.
I solved that to manually editing the file /.config/powermanagementprofilesrc
It seems that the Screen settings app inserted there [BrightnessControl] value 0.5, which is not 50 % but 0.5 in a scale of hundred or 0.5% Big Grin. Also needed to edit the screen timeout values to reasonable ones.
how do you open /.config/powermanagementprofilesrc ? can I do it on the phone itself? or do I need to plug it into the dock? I found the .config folder, but it is greyed out and says "nothing here" when I open it. do I need to use terminal and sudo commands?

Just replied to you on the other thread: https://forum.pine64.org/showthread.php?tid=13690&page=2
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  archplasma: phone et discover broken? oihantto64 3 234 05-14-2022, 03:38 PM
Last Post: oihantto64
  Screen rotation lordearl 4 2,196 03-13-2022, 11:28 PM
Last Post: neil_swann80
  Last update bricked my pine phone :( lacriz 6 977 01-25-2022, 07:52 AM
Last Post: kqlnut
  Incoming calls only vibrate, phone is not ringing lacriz 3 837 12-20-2021, 05:01 AM
Last Post: wibble
  "file too short" problem causing many sofware dependencies to fail pineuser0 2 1,052 10-31-2021, 09:57 AM
Last Post: pineuser0
  alarm-sxmo brightness ryo 7 2,302 10-25-2021, 02:44 PM
Last Post: Skylead
  Arch auto mount usb example Lazy_one 1 1,361 06-13-2021, 05:10 PM
Last Post: Lazy_one
  phone shutts down and/or automatic suspend 112113101098101077 7 4,092 04-17-2021, 01:01 AM
Last Post: 112113101098101077
Big Grin phone app covers unlock screen when trying to access during a call quantumphone 1 1,501 01-28-2021, 11:54 PM
Last Post: Danct12

Forum Jump:


Users browsing this thread: 1 Guest(s)