Booting official Debian on RP64
Hi, I'm trying to get the new Debian installer RC3 to give me a working Debian server on the RockPRO64, but I'm stuck. I'd like to know if I'm missing anything. The steps I followed are:

  • Got testing/unstable daily builds from:
  • Squashed the images together as instructed
  • Flashed to a USB with Balena Etcher (A few months ago I flashed a U-Boot image from Ayufan to get USB boot working)
  • Put USB into the USB 3 port (No SD or eMMC inserted)
  • Installer starts successfully, run until partitioning
At the partitioning section, I created the following partitions:

On my USB:
  • 500MB ext2 mounted to /boot, bootable flag enabled (Boot from USB because U-Boot doesn't seem to support SSD's yet)
On my SSD (SATA):
  • 56GB ext4 mounted to /
  • 2gb swap at the end
On my HDD (SATA):
  • 2TB ext mounted to /hdd
Then I ran the rest of the installer till the end and rebooted.

It then starts, shows some info on the screen and then either gets stuck or throws a kernel panic. The info on the screen doesn't give me any pointers on what to do and it doesn't respond to anything I type, so I can't do shift+pgUp to see the rest of the kernel panic or ctrl+alt+f2 for other potential tty's. 

I don't want Armbian because it installs a bunch of things I don't want (plus the option to switch to SSD in armbian-config is missing), and Ayufan and Mrfixit's images seem outdated. Is there anything I can do to get this working? Or is Debian 11 on the RP64 just not ready yet?
Okay, I just got it to work almost perfectly. I grabbed flash_spi.img.gz from the latest pre-release of, put it on an SD card and ran it. It eventually showed an output to my HDMI saying it installed U-Boot correctly. Then I removed the SD card, flashed the assembled Debian installer to my USB again, and ran through the installation exactly as I described. When I booted, i got the following error: Booting using the fdt blob at 0x1f00000

I restarted, got the same error, then restarted again and suddenly it worked and booted successfully. This is a known issue (see:, that Sigmaris has already worked around, but the version installed by the Debian installer maybe hasn't. For now, I just reboot till it works.

there is nothing wrong with the ayufan images, I have it running since several month. Of course with unattended updates.

I had problems while testing kernel 5.9 since it crashes all the time I connect a USB-stick. but kernel 5.6 is working fine.

Also I would still stick to debian buster 10.

No real need to test the un-released debian 11 yet.

Unless you like hunting down kernel patches and tinkering, you will be much better off with Armbian, at least on SBCs.

What "extra" stuff is installed that you don't like?
Afaik, the official installer still has issues with installing the bootloader.

You could try the method I describe in my blog to get the official Debian installed with an alternative approach. I didn't test it with Debian 11 (yet!), but with Debian 10 it works quite well on the RP64:

Possibly Related Threads…
Thread Author Replies Views Last Post
  Booting from NVME ilovegentoo 11 3,014 05-10-2021, 02:06 PM
Last Post: rrowles2000
  Booting Linux/Debian from the eMMC linuxha 4 482 03-02-2021, 07:01 PM
Last Post: linuxha
Question My Rockpro64 stopped booting with these error messages please help seaurchin 4 477 02-18-2021, 04:27 PM
Last Post: TRS-80
Question Mainline Debian Buster on RockPro64 ? chrestomanci 36 12,778 02-14-2021, 02:37 PM
Last Post: foresto
  How To Lay Hands on a True 64-bit Debian Install? vandys 4 1,030 12-01-2020, 06:12 AM
Last Post: as365n4
Big Grin Feature Complete Debian Desktop Release Mrfixit2001 157 63,095 10-09-2020, 09:29 AM
Last Post: LMM
  Bringing up a fresh Debian install (or trying) foresto 2 1,511 08-09-2020, 01:57 PM
Last Post: foresto
  Official Debian release won't boot!?! Faradn 4 2,191 07-06-2020, 09:29 AM
Last Post: Bullet64
  UART4 in Debian Desktop Release of Mrfixit2001 Gienek 1 973 05-19-2020, 02:47 AM
Last Post: Gienek
  RockPro64 getting started - non-booting images [solved] new-rockpro-user 3 1,875 03-06-2020, 06:31 AM
Last Post: new-rockpro-user

Forum Jump:

Users browsing this thread: 1 Guest(s)