Installing Mobian --> "Resizing file system" forever
#11
(03-22-2021, 03:42 PM)Anna Wrote: To install Mobian on an SD card I, all I theoretically have to do is to download mobian-pinephone-phosh-20210314.img.gz, write it to the card, put the card into the phone and start it, right?

However, when I do that, the "resizing file system during initial boot" screen is there for quite a long time (30 minutes maybe) and afterwards the screen turns black (not pitch black though, the display remains switched on) and that's it.

I have used two different 64 GB cards  (a new Sandisk Extreme and and old Sandisk Ultra). I used BalenaEtcher and I tried
Code:
sudo zcat mobian-pinephone-phosh-20210314.img.gz | sudo dd of=/dev/mmcblk0 bs=1M

What am I doing wrong? Huh

If you are using Balena Etcher :
      You do not SUDO  anything.

You simply download Mobian,  then use Balena Etcher to flash your sd card.

<(You Can prep your sd card,   IF   you so desire,  format or zero wipe or whatever)>

I have been using Balena Etcher and Mobian since the first release of Mobian.  

   * (actually that's all I have ever used,  -  since I purchased my first Pinebook Pro, from the first public sales,  second batch I think, Sept. 2019)
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
  Reply
#12
(08-31-2021, 11:59 PM)bcnaz Wrote: If you are using Balena Etcher :
      You do not SUDO  anything.

Thanks! Sorry if I did not express myself clearly: I had tried "sudo zcat..." and, after that attempt failed, I tried Balena Etcher, both several times.

The solution was @dukla2000 's answer.
  Reply
#13
Hello,

our Pinephone arrived about a week ago and I had the "resizing forever" issue with mobian-pinephone-phosh-2021051 yesterday. My solution was to resize it manually before inserting the SD into the computer.

Just wanted to say that the filesystem is f2fs, not ext2 as described in the Installation Instructions

For me, these commands worked:

Code:
: sudo bmaptool copy --bmap Downloads/mobian-pinephone-phosh-20210517.img.bmap Downloads/mobian-pinephone-phosh-20210517.img.gz /dev/mmcblk0
: sudo growpart /dev/mmcblk0 2
: sudo resize.f2fs /dev/mmcblk0p2
  Reply
#14
(09-09-2021, 02:42 AM)loderunner Wrote: Just wanted to say that the filesystem is f2fs, not ext2 as described in the Installation Instructions

Just wanted to say, that these are not the installation instructions for mobian which has it's own.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  bookworm vs trixie discussion for mobian in pinephone regular. zetabeta 28 4,680 06-09-2024, 04:39 AM
Last Post: anonymous
  Mobian-Kicksecure? 3460p 0 371 05-26-2024, 02:09 PM
Last Post: 3460p
  atinout binaries for mobian/debian? NeutralGrey 2 549 05-13-2024, 02:42 PM
Last Post: Gumur
  Mobian repository status henrythemouse 16 10,182 04-10-2024, 10:02 AM
Last Post: diederik
  cant verify mobian image at website gnugpg penguins_rule 0 453 03-18-2024, 08:54 PM
Last Post: penguins_rule
  mobian installed to eMMC - how to install tow-boot grump_fiddle_reinstall 6 2,855 11-22-2023, 11:46 AM
Last Post: aLoop100o
  Errors when start the system kubussz 2 937 11-21-2023, 11:07 AM
Last Post: kubussz
  System won't suspend due to suspention notification user641 6 1,925 09-24-2023, 05:47 AM
Last Post: user641
  What actions needed to keep on mobian testing user641 3 2,129 09-05-2023, 06:44 AM
Last Post: Zebulon Walton
  Mobian boot failed with zstd message after upgrade. Mahgue 0 806 09-01-2023, 11:29 AM
Last Post: Mahgue

Forum Jump:


Users browsing this thread: 1 Guest(s)