Session start fails, need to reinstall?
#1
I posted the same question 5 days ago in "getting started" but perhaps it wasn't the right place.

I received my pinephone with mobian 5 days ago. After playing around and failing to update anything with the software update app, I saw I needed to do that via the command line and using dist-upgrade.

I did that but during the upgrade, as I was touching the screen to avoid the screensaver, I touched the battery icon and the phone immediately wet off. As I powered it up again, I could enter the password to decipher but after seing mobian and the logo, I have a graphical message saying that something went wrong in the session start and I need to try again, but f I power off and on again the same occurs.

Is there any solution apart from reinstalling mobian?

While the phone is connected to my PC running Trisquel, there is no device for it so I guess the only solution to reinstall mobian is to first install mobian on a SD card and after I have a working phone, I can try to access the eMMC to install mobian there again, but I am not sure whether that can be the installer at https://images.mobian-project.org/pinephone/installer/ that is copied to the eMMC directly or not (in order to install the FS ciphered).
  Reply
#2
Hello Avron,

A trick : remove the battery, wait a while, replace the battery. Sometimes it's working for me. 

I get an external power connected when I'm not sure that the charge of the battery is full or/and the USB C - Dock bar with an Ethernet connexion.

For a big update, I prefer to go in the 'Parameters' menu to disable the suspend mode and other things like that, I'm afraid to tape on the screen at a bad moment and/or valid a question  Confused

To install the OS in the eMMC memory, the simplest way is to use 'Jumprive' and 'bmaptools' as describe here : https://wiki.mobian-project.org/doku.php?id=install I've use this few days ago to re-flash my eMMC memory with the Debian  Installer.
  Reply
#3
Thanks for the advice ! In fact, it was easy to reinstall with jumpdrive.

For some reason bmaptool wasn't working so I just used dd.

I guess I need to get used to mobian now, see which apps are effectively usable. It tried Seafile because I have have a Seafile server but the app is most of the time not reacting to touch, it seems hardly usable.
  Reply
#4
For "bmap-tools", I've installed the following packages :
  • Recommends: bzip2, lzop, xz-utils
  • Suggests: lz4, pbzip2, pigz, unzip

If you haven't the "*.bmap" file, the command is "bmap copy --nobmap ..."

I'm using Bmap on my X86 with Debian Buster and ARM (NanoPi M4) with Armbian, searching with "bmap-tools" doesn't work could be interesting.

With some SD card ans "dd", I found that "bs=512" give frequently some better results than something like "bs=1M".
  Reply
#5
I tried with bmap-tools from Trisquel repository on my desktop (amd86) , it is v3.4. I had the bmap file. The issue could be a syntax mistake, but since I wanted the result quickly and I knew that dd only takes a few minutes to flash a file that size on a microSD card, I thought it would be the case here too (and it was) so I gave up bmaptool without searching further.

I used bs=64k as in the example. In what sense is the result "better" with bs=512 as compared with bs=1M?

Besides, when it comes to writing to /dev/sdX, I have already read the advice to just use cp and indeed it worked. I always run sync after dd or cp in this case but I don't know whether it is really necessary.
  Reply
#6
Quote:I used bs=64k as in the example. In what sense is the result "better" with bs=512 as compared with bs=1M?
Only useful with poor quality SD card or USB key :-(
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  UFW (uncomplicated firewall) Start On Boot - Mobian (working) theD0ctor 2 528 02-28-2021, 09:58 PM
Last Post: theD0ctor
  Anyone know how to start a terminal at current dir with Nemo? rp3 6 854 01-19-2021, 10:04 AM
Last Post: KC9UDX
  Geary crashes during start after recent update p1trson 2 782 01-16-2021, 04:49 AM
Last Post: p1trson
  Can't start zram 3x5co 2 710 12-31-2020, 11:35 PM
Last Post: 3x5co

Forum Jump:


Users browsing this thread: 1 Guest(s)