Amazfish on Pinephone
#1
I was disappointed to find out that software only available on Sailfish (and possibly Manjaro I think I heard)?

Saw there were instructions on how to compile for Ubuntu.  Decided to be adventurous, and  I just tried to compile it on my Pinephone running Mobian. It seems to have successfully.  Daemon starts up, and app even seems to want to run. I'm guessing there's something missing still ("No drivers found") or an issue with the fact that Phosh is using Wayland.)  But it sill shows nothing on the screen and is not usable.  If you launch it from the app screen, nothing happens, but the binary will be running in the background.

Code:
mobian@mobian:~$ ps aux | grep amazfish
mobian     14183  0.0  0.7 235988 22976 ?        Ssl  12:53   0:00 /usr/local/bin/harbour-amazfish

mobian@mobian:~$ harbour-amazfish-ui
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
("/var/lib/flatpak/exports/share/icons", "/usr/local/share/icons", "/usr/share/icons", ":/icons") (":qml/custom-icons")
Connecting to daemon signals
void DaemonInterface::changeConnectionState()
No drivers found
QQmlApplicationEngine failed to load component
qrc:/qml/harbour-amazfish.qml:11:1: Type ApplicationWindowPL unavailable
qrc:/qml/components/platform/ApplicationWindowPL.qml:22:1: module "org.kde.kirigami" is not installed
qrc:/qml/components/platform/ApplicationWindowPL.qml:21:1: module "Qt.labs.settings" is not installed
qrc:/qml/components/platform/ApplicationWindowPL.qml:22:1: module "org.kde.kirigami" is not installed
qrc:/qml/components/platform/ApplicationWindowPL.qml:21:1: module "Qt.labs.settings" is not installed
  Reply
#2
(02-15-2021, 12:19 PM)pagesix1536 Wrote: I was disappointed to find out that software only available on Sailfish (and possibly Manjaro I think I heard)?

Saw there were instructions on how to compile for Ubuntu.  Decided to be adventurous, and  I just tried to compile it on my Pinephone running Mobian. It seems to have successfully.  Daemon starts up, and app even seems to want to run. I'm guessing there's something missing still ("No drivers found") or an issue with the fact that Phosh is using Wayland.)  But it sill shows nothing on the screen and is not usable.  If you launch it from the app screen, nothing happens, but the binary will be running in the background.

Code:
mobian@mobian:~$ ps aux | grep amazfish
mobian     14183  0.0  0.7 235988 22976 ?        Ssl  12:53   0:00 /usr/local/bin/harbour-amazfish

mobian@mobian:~$ harbour-amazfish-ui
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
("/var/lib/flatpak/exports/share/icons", "/usr/local/share/icons", "/usr/share/icons", ":/icons") (":qml/custom-icons")
Connecting to daemon signals
void DaemonInterface::changeConnectionState()
No drivers found
QQmlApplicationEngine failed to load component
qrc:/qml/harbour-amazfish.qml:11:1: Type ApplicationWindowPL unavailable
qrc:/qml/components/platform/ApplicationWindowPL.qml:22:1: module "org.kde.kirigami" is not installed
qrc:/qml/components/platform/ApplicationWindowPL.qml:21:1: module "Qt.labs.settings" is not installed
qrc:/qml/components/platform/ApplicationWindowPL.qml:22:1: module "org.kde.kirigami" is not installed
qrc:/qml/components/platform/ApplicationWindowPL.qml:21:1: module "Qt.labs.settings" is not installed
Theres a pkgbuild available for manjaro It lists the dependencies in the pkgbuild file so try find the correct package names for your distro and install them

This looks like missing dependencies
Code:
qrc:/qml/components/platform/ApplicationWindowPL.qml:22:1: module "org.kde.kirigami" is not installed
qrc:/qml/components/platform/ApplicationWindowPL.qml:21:1: module "Qt.labs.settings" is not installed




https://gitlab.manjaro.org/manjaro-arm/p...r/PKGBUILD
  Reply
#3
I also built it on Mobian. The missing dependencies are packaged in debian. Installing them actually works.
Code:
sudo apt install qml-module-qt-labs-settings
The app mostly works, but it looks kinda ugly compared to the screenshots, and I can't figure out how to open the settings menu.

[Image: pObYqMJrTzozbVsBZyjMantH]
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Fedora + Phosh for PinePhone njha 54 29,967 05-01-2021, 02:40 AM
Last Post: Subsentient
  Pine Phone Desktop Mode or "Standard" Gnome Desktop on PinePhone? 4920441 3 446 04-08-2021, 07:06 AM
Last Post: 4920441
  Adafruit Pyloton Open Source Bike computer on the PinePhone? Peter Gamma 0 201 04-02-2021, 06:37 PM
Last Post: Peter Gamma
  PureOS on Pinephone dukla2000 83 46,566 04-02-2021, 07:46 AM
Last Post: darkdragon-001
  openSUSE for Pinephone Alefnode 68 27,797 03-21-2021, 11:43 AM
Last Post: andresbs
  freeglut3 on the PinePhone Samuel Venable 1 339 03-10-2021, 03:06 PM
Last Post: nas
  HowTo: Get a passcode from DUO Mobile working on the Pinephone kop316 0 373 02-22-2021, 12:27 PM
Last Post: kop316
  Easiest way to use Android applications on Pinephone esud 3 1,455 02-21-2021, 12:53 PM
Last Post: reGisterGan578
  Jami on Pinephone [ IM and VOIP ] p1trson 3 744 02-14-2021, 02:15 PM
Last Post: displacefish
  Latest firmware for PinePhone modem! Subsentient 52 32,089 02-13-2021, 02:08 PM
Last Post: surfingtux

Forum Jump:


Users browsing this thread: 1 Guest(s)