Phone won't boot after update: red LED
#1
I checked the wiki and it said for Ubuntu touch, hold the power button until the phone shuts down and then hold it again until the LED lights up. I did this but it just have me the red LED again.

I'm not sure what to do. My OS is on the EMMC and I don't have it backed up. I can't SSH into the phone either.
  Reply
#2
(02-13-2021, 01:47 PM)3x5co Wrote: I checked the wiki and it said for Ubuntu touch, hold the power button until the phone shuts down and then hold it again until the LED lights up. I did this but it just have me the red LED again.

I'm not sure what to do. My OS is on the EMMC and I don't have it backed up. I can't SSH into the phone either.

Fairly regularly I have an instance (with both Mobian & Arch) that the phone gets stuck in u-boot and never launches the operating system. Which is usually solved by the 8 second power off and a retry.

If however your eMMC "boot mechanism" is bust then you can burn an OS onto an SDcard, boot that and then try repair the SDcard. Or retrieve your files (copy /home/mobian/).
  • ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Arch (5.13 kernel, Openbox desktop) for general purpose daily PC.
  • PinePhone BraveHeart now v1.2b 3/32Gb daily driver, dual boot via p-boot with Mobian/f2fs/Phosh on eMMC, Arch/ext4/Phosh on SDcard
  • PinePhone v1.2a 2G/16Gb that needs USB board replaced
  Reply
#3
It's weird, I flashed a new nightly image to an SD card, swapped it into my phone, and my normal installation booted — meaning that all my files and settings were correct. And it was faster than when I run on SD, so it was clearly running the EMMC version.

Then I tried booting with no SD, and got a green light but nothing else. When I put in my old SD, I get a red light and nothing else.

Then I put the new SD in again, and this time it booted the OS on the SD, not on my EMMC. I'm not sure what that's about, but now I'm thinking maybe this is an fstab issue. If you have any other ideas, let me know, but in the meantime I'm going to try to edit my fstab from the live SD.
  Reply
#4
OK, there wasn't anything wrong with my fstab. I was able to chroot into my EMMC installation by following [these instructions](https://wiki.mobian-project.org/doku.php...leshooting). I updated all packages and checked journalctl and I couldn't see any problems.

I did see this in dmesg

```
anx7688 1-0028: boot firmware load failed (you may need to flash FW to anx7688 first)
```

I see [a thread](https://forum.pine64.org/showthread.php?...7#pid89367) about this firmware problem and it looks like it's saying I need to download an image and replace the firmware, but the post refers to postmarketOS. I'm not sure if there's anything else I can do. I can see that I have the 5.10 kernel, so maybe there's a way to roll that back. I can't find grub on my phone and so I'm guessing mobian uses something else.

I saw this solution posted a lot:

# echo 1 > /sys/class/typec/port0/device/flash_eeprom

but I chrooted into the phone and /sys/ is empty.
  Reply
#5
This morning, impossible to boot, the led is green and doesn't blink. In the context : https://forum.pine64.org/showthread.php?...3#pid8954302-12-2021, 10:47 PM . Two 'apt update && dist-upgrade && reboot' missing. 

No effect with power button + volume button.

The solution was to remove the battery. 
  Reply
#6
I tried to boot into recovery mode, using the volume up and power buttons. This didn't work and I still have the red LED.

What are my options from here? Should I repair the firmware? What are the instructions for Mobian?

If not that, is there a way to reinstall the OS and preserve my home folder?

If not, is it possible to make my entire external SD card the home folder? If I do this, I think it'll be a lot easier to reinstall my OS if this happens again, and still have all my settings.
  Reply
#7
When I had the same mobian build on the SD as on the emmc it would boot up either drive randomly. Smile

If you have an SD that boots, you can boot it. Then browse the emmc where you should be able to access your user's home directory.

If you have the convergence dock then it's easy to plug in a thumbdrive to save your files.
  Reply
#8
I didn't know about the convergence dock until just now, but I'll check it out. I ended up just booting from sd, backing up my files and reinstalling. Moving forward, I'm going to make sure I don't have the sid repo enabled and hope that this doesn't happen again.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Keyboard stopped working on disk encryption screen on Mobian after update cowsay 0 43 07-28-2021, 05:46 PM
Last Post: cowsay
  firefox-esr stopped working after June 18 update HLing 17 1,890 07-21-2021, 02:40 PM
Last Post: dante404
  receive a blank screen after expanding SD on first boot ~Daniel~ 1 185 07-02-2021, 08:24 PM
Last Post: ~Daniel~
  phone call using built it app will not go to bluetooth motox6 3 382 06-28-2021, 11:03 AM
Last Post: wibble
  Update-rc.d for Mobian Davio 2 302 06-27-2021, 08:34 AM
Last Post: Davio
  Always-On VPN issues at boot. Need to manually activate it.. What did i miss.. temp0rary 0 193 05-31-2021, 10:35 AM
Last Post: temp0rary
  audio quality on phone Rainer 0 230 05-28-2021, 09:25 AM
Last Post: Rainer
  Can't update OS Mobian Phosh Gon 5 742 05-23-2021, 10:52 PM
Last Post: pajux
  Mobian: 2 week as main phone steves 10 2,006 05-18-2021, 11:55 AM
Last Post: vortex
  Bluetooth audio stalling (maybe the whole phone) motox6 1 313 05-18-2021, 10:15 AM
Last Post: wibble

Forum Jump:


Users browsing this thread: 1 Guest(s)