Unusable ROCKPRO64
#1
Hi all,

            after running well for 25 days more or less, my rockpro64 is unusable. All USB ports and ethernet port are not working. I tried with many images, Manjaro, armbian... to top it all sometimes the startup finish with a kernel panic message.

I'm pretty sure that this is a hardware failure. Has anyone a similar experience? I'm very disgusted, the rockpro64 only ran for 25 days more or less. I have had others SBC, like raspberry pi, in the same place for years without problems. 


Sad
  Reply
#2
(02-09-2021, 10:09 AM)drenedo Wrote: Hi all,

            after running well for 25 days more or less, my rockpro64 is unusable. All USB ports and ethernet port are not working. I tried with many images, Manjaro, armbian... to top it all sometimes the startup finish with a kernel panic message.

I'm pretty sure that this is a hardware failure. Has anyone a similar experience? I'm very disgusted, the rockpro64 only ran for 25 days more or less. I have had others SBC, like raspberry pi, in the same place for years without problems. 


Sad

Please make sure that your power supply rated 12V 3A or 5A. Looks like your board not getting enough power. If you are using teh Raspberry Pi power power which is 5V, then for sure is under power.
  Reply
#3
(02-13-2021, 07:06 PM)tllim Wrote:
(02-09-2021, 10:09 AM)drenedo Wrote: Hi all,

            after running well for 25 days more or less, my rockpro64 is unusable. All USB ports and ethernet port are not working. I tried with many images, Manjaro, armbian... to top it all sometimes the startup finish with a kernel panic message.

I'm pretty sure that this is a hardware failure. Has anyone a similar experience? I'm very disgusted, the rockpro64 only ran for 25 days more or less. I have had others SBC, like raspberry pi, in the same place for years without problems. 


Sad

Please make sure that your power supply rated 12V 3A or 5A. Looks like your board not getting enough power. If you are using teh Raspberry Pi power power which is 5V, then for sure is under power.

The power supply is correct. 12V 5A.
  Reply
#4
Does it boot at all?
Could you hook up a serial connection like outlined here, and see what the boot init looks like?
https://forum.pine64.org/showthread.php?tid=6387
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  RockPro64 - EN62368 m.ekstrom 0 150 06-02-2021, 04:55 AM
Last Post: m.ekstrom
  RPI4 Vs Rockpro64 Performance help? Mangled 0 230 05-25-2021, 03:38 PM
Last Post: Mangled
  Booting my RockPro64 from NVMe drive PsySc0rpi0n 3 457 05-02-2021, 01:56 AM
Last Post: LMM
  ROCKPro64 (4 GB) "In stock (can be backordered)" TRS-80 3 768 03-19-2021, 04:53 PM
Last Post: TRS-80
  Troubleshooting ROCKPro64 alephnull 3 837 03-04-2021, 03:58 AM
Last Post: alephnull
  Petitboot on RockPro64? new_to_arm 0 364 03-03-2021, 05:00 PM
Last Post: new_to_arm
  Feasibility of mining crypto on RockPro64? epoliqui 2 1,571 02-06-2021, 09:23 AM
Last Post: Mangled
  Performance and Power Demand RockPro64 fotastisch 7 4,409 02-05-2021, 07:45 PM
Last Post: foresto
  ROCKPro64 4GB availability p1trson 5 1,659 12-30-2020, 11:28 AM
Last Post: jussi
  Rockpro64 RAM issues sausal 5 2,378 12-06-2020, 12:09 AM
Last Post: tllim

Forum Jump:


Users browsing this thread: 1 Guest(s)