Firmware update issue
(02-08-2021, 12:45 AM)343GuiltySpark Wrote: I get failed notifications both with and without the ":mass-erase:force" option when flashing.

Any ideas?

For me, I can update Pinecil from first batch under Debian fluently.

However, I have tried to update Pinecil from batch #2 and had the same error message as above.
I have noticed that just after trying to update it, the device stops communicating (error messages come up in dmesg), but it still looks somewhat fine till I don't run updater.
(There are some differences between batch #1 and #2 USB descriptors anyway, but vendor / product identifiers are the same.)

However, I was able to update Pinecil form batch 2 by running updater just after connecting the device to computer, so it could catch it in time and download appropriate data. That time I did not have mass-erase option.
Anyway, I could repeat the same process and update was went through well.

Basically it looked like this:
- Connect Pinecil while button was pressed
- Run updater utility as soon as possible
- Run again if it did not found Pinecil
- Updating started
I had same issue in Pinecil Firmware Updater tool.
There are two cases I found so far:
- Pinecils, which needs mass-erase, else the uploaded firmware doesn't work
- Pinecils, which fails on mass-erase, without mass erase, uploading works and the firmware works good too.

So I made in the app this updating optional. Also note, that dfu-util v0.10 have some improvements.
So, use dfu-util v0.10, and if mass-erase fails for you, just remove it, and it should work finely.
Also known as gamiee
I just received my Pinecil and tried to update the firmware with the firmware updater 1.3 (Mac OS 11.2.3), but flashing is aborted with the message:

dyld: Library not loaded: /Users/gamiee/Desktop/libusb-1.0.24/../build/lib/libusb-1.0.0.dylib Referenced from: /Volumes/pinecil_firmware_updater/ Reason: image not found
DFU-Util exited with error code 6!

The missing library is there, but DFU-Util is only searching on the path gamiee used. Sorry, I don't have any experience with DFU-Util. Could you please tell me how to fix that? Thanks! 

Forum Jump:

Users browsing this thread: 1 Guest(s)