I cant write to my sdcard?
Hi all, if anyone can help me, that would be great!

I am having all sorts of trouble writing to my sdcard on 2 different pinephone ce editions, on two different sdcards (both using mobian, from the encrypted installer).

The most I have been able to achieve it to create a new folder on one, using sudo, but even then I could not copy files into it (even using sudo), getting errors like "you dont have permission..."

As the normal user, there is no hope of anything being written, and I have tried a number of file managers, ie: the console-based midnight commander, nemo, nautilus, Pcmanfm and thunar.

I also, using sudo in the console or to run the others, cannot change the ownership of the folder that I created (root).

Please someone tell me the silly mistake I am making? Thanks!
You've not said exactly what you've tried, how the SD is partitioned, formatted or mounted. That makes it tricky to diagnose.
(01-07-2021, 06:50 AM)rp3 Wrote: ...

Please someone tell me the silly mistake I am making? Thanks!

?Somehow mounting the card read-only?

Is Mobian on the eMMC? How are you mounting the SDcard?
  • ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Arch (5.18 kernel, Openbox desktop) for general purpose daily PC.
  • PinePhone Pro Explorer Edition daily driver, Tow-boot on SPI, Arch/phosh on eMMC
  • PinePhone BraveHeart now v1.2b 3/32Gb, Tow-boot with Arch/Phosh on eMMC
Thanks for feedback so far,
I can confirm so far that mobian is installed on the internal memory on both phones, and the sdcards are just being used to load in information from a linux pc (text files etc)
I have spent an hour or so trying to find out more info, but am having a hard time of it.
I might try reformatting an sdcard with gparted on my pc, and see if anything changes.
Regards, everyone.
I seem to have solved my problem, not sure how...

I used gparted on a linux laptop to examine one of the sdcards:
It had one primary fat32 partition on it.

I then used gparted to create a new msdos partition table,
then created a full sized extended partition on it,
then created 1 fat32 logical partition in the extended partition
then created 1 ntfs logical partition in the extended partition
then created 1 ext4 logical partition in the extended partition

when the sdcard was inserted into the pinephone, I found: (using nemo)
I could actually write to the fat32 partition (yay -sucess!)
I could not write to the ntfs partiton (would not mount)
I could not write to the ext4 partition (permission problems)

I then put the sdcard back in the laptop, and deleted all the partitions and replaced them with 1 full sized, primary fat32 partition, which was then writable in the pinephone.

So I can now save files to my sdcard!

-maybe the above might be useful to someone else sometime?

All the best everyone, great project!

Possibly Related Threads…
Thread Author Replies Views Last Post
  Geary: can't write mail jsch 2 631 03-12-2022, 03:28 AM
Last Post: jsch
  External SDcard Captain1ndustry 1 1,105 04-26-2021, 05:14 PM
Last Post: dukla2000

Forum Jump:

Users browsing this thread: 1 Guest(s)