Boot from USB 3.0 with hub
#1
Hello
As storage is going sparse on my Rock64, I would like to put my bootdrive, an Sata SSD connected over an USB 3.0 to Sata bridge, behind an USB 3.0 hub.

However, as soon as I try to boot with this setup, I get the following error in the U-boot console and the rock64 is trapped in a bootloop.
Code:
scanning bus 0 for devices... 1 USB Device(s) found
scanning bus 1 for devices... 1 USB Device(s) found
scanning bus 2 for devices... 1 USB Device(s) found
scanning bus 3 for devices... WARN halted endpoint, queueing URB anyway.
Unexpected XHCI event TRB, skipping... (fcf14530 00000000 13000000 02008401)
"Synchronous Abort" handler, esr 0x96000210
ELR:    fef60008
LR:      fef60008
x0 : 0000000000000000 x1 : 00000000000003e8
x2 : 0000000000000040 x3 : 000000000000003f
x4 : 00000000fcf14910 x5 : 0000000000000031
x6 : 00000000fef8846c x7 : 000000000000000f
x8 : 00000000fcf02ac0 x9 : 0000000000000008
x10: 00000000fcf02775 x11: 0000000000000008
x12: 00000000ffffffff x13: 00000000000035c8
x14: 00000000fcf049cc x15: 0000000000000008
x16: 0000000000000000 x17: 0000000000000000
x18: 00000000fcf0ce08 x19: 00000000fcf13240
x20: 00000000fcf03240 x21: 0000000000000000
x22: 00000000fcf1dad0 x23: 0000000000000000
x24: 00000000fcf02f00 x25: 0000000080000383
x26: 0000000000000002 x27: 0000000000000001
x28: 00000000fcf02dc0 x29: 00000000fcf02c40
Resetting CPU ...


My current setup, in which USB booting works is the following. I use a rock64 v2, on which I've flashed ayufans Uboot fork, version 2017.09-rockchip-ayufan-1065-g95f6152134 from April 2020. (newest version). Boot device is a sata SSD connected directly to the USB 3.0 port with an USB to Sata Bridge.

Does somebody had maybe similiar problems or know a solution? According to my research, there should be a U-boot module which allows to use USB-hubs (PATCH v2 00/15, see here), however it is not clear for me, if this patch is integrated in ayufans U-boot. Or does somebody know another U-boot fork allowing the usage of USB hubs for boot devices?
I know that this question is a bit strange, and that the setup seems utterly complicated, however I have to stall a bit until the rockpro64, my new dream server board, will be back in stock again Smile 
Thank you very much for answer.
Best regards
Turbo
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Setting a MAC on Rock64 U-Boot kiriakos 2 250 03-23-2021, 04:51 AM
Last Post: kiriakos
  Rock64 Rev3 doesn't boot and leds blinking fast dishins 3 2,029 08-16-2020, 07:42 AM
Last Post: aclaret
  Unable to boot armbian fchazal 2 1,115 05-19-2020, 06:43 PM
Last Post: Rocklobster
  Rock64s will not boot any OS camosoul 2 969 05-19-2020, 06:38 PM
Last Post: Rocklobster
  Help me understand the boot up process olivercfc 0 614 11-10-2019, 08:30 AM
Last Post: olivercfc
Brick Rock64 stuck in boot, please help! Malmgren 7 2,427 11-05-2019, 07:02 AM
Last Post: Malmgren
Question [SOLVED] Alpine Linux won't boot rock7 1 1,876 10-22-2019, 04:30 PM
Last Post: rock7
  Forcing u-boot to detect USB3 storage jandastroy 8 3,534 04-02-2019, 10:06 PM
Last Post: t4_4t
  Consistent boot from SSD? Is it possible? SirRyanTheGeek 1 836 04-02-2019, 12:28 PM
Last Post: SirRyanTheGeek
  Not able to boot Armbian 5.75@Rock64 4GB wundidajah 1 1,042 03-29-2019, 05:30 AM
Last Post: dkryder

Forum Jump:


Users browsing this thread: 1 Guest(s)