pmbootstrap error
I attempted to install pmos to SD card using pmbootstrap.  I tried 'shelli' and 'none' for UI.  I tried both on archlinux laptop and on pinephone running archlinux (from eMMC).  Below is the error I'm getting in all cases.  Any ideas how to deal with this error?  Could this error be because of archlinux?

(003971) [05:17:08] *** (4/4) FILL INSTALL BLOCKDEVICE ***
(003971) [05:17:08] (native) copy rootfs_pine64-pinephone to /mnt/install/
(003971) [05:17:08] % sudo mkdir -p /home/alarm/.local/var/pmbootstrap/chroot_native/mnt/rootfs_pine64-pinephone
(003971) [05:17:08] % sudo mount --bind /home/alarm/.local/var/pmbootstrap/chroot_rootfs_pine64-pinephone /home/alarm/.local/var/pmbootstrap/chroot_native/mnt/rootfs_pine64-pinephone
(003971) [05:17:08] (native) % cd /mnt/rootfs_pine64-pinephone; cp -a root sys dev var usr sbin proc mnt opt run lib media etc tmp boot srv bin /mnt/install/
(003971) [05:17:23] % sudo mkdir /home/alarm/.local/var/pmbootstrap/chroot_native/mnt/install/home
(003971) [05:17:28] % sudo cp -a /home/alarm/.local/var/pmbootstrap/chroot_native/mnt/install/etc/skel /home/alarm/.local/var/pmbootstrap/chroot_native/mnt/install/home/j
cp: cannot stat '/home/alarm/.local/var/pmbootstrap/chroot_native/mnt/install/etc/skel': No such file or directory
(003971) [05:17:28] ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
(003971) [05:17:28] NOTE: The failed command's output is above the ^^^ line in the log file: /home/alarm/.local/var/pmbootstrap/log.txt
(003971) [05:17:28] ERROR: Command failed: % sudo cp -a /home/alarm/.local/var/pmbootstrap/chroot_native/mnt/install/etc/skel /home/alarm/.local/var/pmbootstrap/chroot_native/mnt/install/home/j
(003971) [05:17:28] See also: <>
(003971) [05:17:28] Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/pmb/", line 49, in main
    getattr(frontend, args.action)(args)
  File "/usr/lib/python3.9/site-packages/pmb/helpers/", line 269, in install
  File "/usr/lib/python3.9/site-packages/pmb/install/", line 736, in install
    install_system_image(args, 0, f"rootfs_{args.device}", 3, steps,
  File "/usr/lib/python3.9/site-packages/pmb/install/", line 495, in install_system_image
  File "/usr/lib/python3.9/site-packages/pmb/install/", line 181, in create_home_from_skel, ["cp", "-a", rootfs + "/etc/skel", homedir])
  File "/usr/lib/python3.9/site-packages/pmb/helpers/", line 76, in root
    return user(args, cmd, working_dir, output, output_return, check, env,
  File "/usr/lib/python3.9/site-packages/pmb/helpers/", line 58, in user
    return pmb.helpers.run_core.core(args, msg, cmd, working_dir, output,
  File "/usr/lib/python3.9/site-packages/pmb/helpers/", line 285, in core
    raise RuntimeError("Command failed: " + log_message)
RuntimeError: Command failed: % sudo cp -a /home/alarm/.local/var/pmbootstrap/chroot_native/mnt/install/etc/skel /home/alarm/.local/var/pmbootstrap/chroot_native/mnt/install/home/j
Choosing stable rather than edge worked successfully.  Marking thread as solved.

However, I'd prefer to use edge in the future.  I hope the problem that I've encountered above will be gone by then.  My initial choice against stable was because it's version number V.20.05 looked like May-2020, half year ago, but I don't know for sure.  Perhaps, someone can confirm this or correct me.  Maybe this stable version is current, judging from apk upgrade output 'OK: 211 MiB in 184 packages' and nothing else to do.

Anyways, I'm looking forward to exloring pmos for the first time!  Glad that the original error in this thread has not deterred me, especially that I found pmos-based sxmo refreshingly exciting.
The errors are gone with pmbootstrap version 1.27.0  Smile

Possibly Related Threads…
Thread Author Replies Views Last Post
  constant apk error message iwm 2 2,532 11-15-2021, 07:25 PM
Last Post: iwm
  Error when updating syrinx 1 2,333 03-06-2021, 01:32 AM
Last Post: hiimtye
  pmbootstrap issues IVp 3 5,227 09-24-2020, 02:24 AM
Last Post: Pinethom
  chroot can't execute passwd exec format error dimm82 5 5,931 09-18-2020, 07:53 AM
Last Post: krsmith28p
  pmbootstrap build large keyboard not usable u20200719 5 6,957 07-25-2020, 02:31 PM
Last Post: u20200719
  pmbootstrap to sdcard Jeb5Blovrueb 34 47,007 07-07-2020, 04:17 AM
Last Post: fernando_c_m
  Is it possible to pre-configure wifi and ssh with pmbootstrap? kelbot 2 4,653 07-06-2020, 01:55 AM
Last Post: ChriChri
Sad ERROR: Could not find dependency 'firmware-rtl8723bt' Engineer 4 6,064 06-16-2020, 12:29 PM
Last Post: Engineer
  Dumb question: do I have to use pmbootstrap? quixote 5 6,902 06-11-2020, 09:23 AM
Last Post: plainenough
  pmbootstrap on Mac OSX srfne 2 5,386 02-29-2020, 04:15 PM
Last Post: srfne

Forum Jump:

Users browsing this thread: 1 Guest(s)