Possible to disable display of SMS text messages?
#1
I'm sure I'm in a small minority but I don't like to be bothered by text messages. I don't want people sending them to me and don't want to be bothered by texts from my carrier, politicians, or other spammers. My flip phone does not automatically display texts, it merely puts a tiny icon up on its tiny screen to indicate their presence (no audio or vibrating alert is given) and I can go through the phone's menus to look at them if desired. SMS is working in my Mobian installation in testing but it's not something that I plan to use when going live with the Pinephone.

Is there a background daemon in Mobian that can be disabled so incoming text messages are not displayed? (I assume there's no way to stop receiving them since that capability is part of the modem - just not having them pop up on the screen would be sufficient.)
#2
I've not spotted a way to do it, so you probably need to make a feature request upstream. I'd imagine it's the sort of thing people might want a setting for globally, for unknown numbers and on a per-contact basis. And all of these on a per-account basis since SMS is just a specific type of chat account. You can probably kill the daemonized instance of 'chatty', but that probably stops you getting any notification at all unless you write a replacement that listens for the dbus signals from ModemManager.

I think the daemonized chatty is started by /etc/xdg/autostart/sm.puri.Chatty-daemon.desktop
#3
(12-08-2020, 12:12 PM)wibble Wrote: I've not spotted a way to do it, so you probably need to make a feature request upstream. I'd imagine it's the sort of thing people might want a setting for globally, for unknown numbers and on a per-contact basis. And all of these on a per-account basis since SMS is just a specific type of chat account. You can probably kill the daemonized instance of 'chatty', but that probably stops you getting any notification at all unless you write a replacement that listens for the dbus signals from ModemManager.

I think the daemonized chatty is started by /etc/xdg/autostart/sm.puri.Chatty-daemon.desktop

Interesting, thanks, I'll have to experiment with killing/disabling chatty and see how that works out.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Mobian + phosh firefox ublock and other overlays display bugs tuxcall 2 82 Yesterday, 05:21 PM
Last Post: alpineduck
  Mobian external display woes Hiraghm 5 700 12-09-2022, 12:12 PM
Last Post: gregb49
  Disable headphone controls 3x5co 0 254 09-10-2022, 07:11 AM
Last Post: 3x5co
  Unable to send messages with chatty user641 0 283 09-07-2022, 04:35 AM
Last Post: user641
  Chatty - XMPP receiving photos - inline display doesn't work arkadione 2 901 07-10-2022, 03:16 AM
Last Post: arkadione
  Disable vibrations 3x5co 8 5,180 06-11-2022, 09:59 AM
Last Post: iwakura_lain
  Disable *automatic* on-screen keyboard iwakura_lain 0 429 06-11-2022, 09:49 AM
Last Post: iwakura_lain
  Disable on screen keyboard permanently. grump_fiddle_reinstall 12 4,856 06-11-2022, 08:11 AM
Last Post: SwordfishII
  LibreOffice Fix for tiny menu text and missing title bar grump_fiddle_reinstall 0 362 05-29-2022, 11:56 PM
Last Post: grump_fiddle_reinstall
  Text pixelated grump_fiddle_reinstall 1 524 05-26-2022, 09:32 AM
Last Post: grump_fiddle_reinstall

Forum Jump:


Users browsing this thread: 1 Guest(s)