Problem with EMMC bootup and detection
#1
Hello guys,
I have recently bought PINEA64-lts boards with EMMC modules of 16gb. I am having trouble interfacing them now. When I burn any image on EMMC ( I have tried several), it dosen't boot from EMMC. The same image when I burn onto SD card,  it starts booting. When only EMMC is inserted PINE64 shows black screen and there is no sign of booting process. Can you please help me out.

I have also tried auyfan's image on SD card. and when I insert EMMC onto PINEA64-lts and check EMMC status, it gets detected with uenv.txt "mmc_compact=on". But when i burn the same image on EMMC and repeat all of above process, boot process does not start.

I am using pine64 usb programmer to program the emmc modules. and i ordered everything from the pine64 official site. EMMC has FORESEE 16 GB IC on it.

When i plugin emmc module in laptop using programmer, it always gets detected and there is no problem in programming the EMMC module.

I am newbie here, hope you guys will guide me well.... Thanks in advacnce
  Reply
#2
(11-06-2020, 01:47 AM)khantheengr Wrote: Hello guys,
I have recently bought PINEA64-lts boards with EMMC modules of 16gb. I am having trouble interfacing them now. When I burn any image on EMMC ( I have tried several), it dosen't boot from EMMC. The same image when I burn onto SD card,  it starts booting. When only EMMC is inserted PINE64 shows black screen and there is no sign of booting process. Can you please help me out.

I have also tried auyfan's image on SD card. and when I insert EMMC onto PINEA64-lts and check EMMC status, it gets detected with uenv.txt "mmc_compact=on". But when i burn the same image on EMMC and repeat all of above process, boot process does not start.

I am using pine64 usb programmer to program the emmc modules. and i ordered everything from the pine64 official site. EMMC has FORESEE 16 GB IC on it.

When i plugin emmc module in laptop using programmer, it always gets detected and there is no problem in programming the EMMC module.

I am newbie here, hope you guys will guide me well.... Thanks in advacnce

On Pine A64-LTS board, teh SD boot has higher priority than eMMC, please make sure there is no bootable OS build microSD card in microSD slot.
  Reply
#3
That doesn't seem to be the issue. I think it is rather that images made to boot from SD will not boot from emmc, and there is very little clarity what needs to be done to make them boot from emmc.
  Reply
#4
(11-07-2020, 11:52 PM)tllim Wrote:
(11-06-2020, 01:47 AM)khantheengr Wrote: Hello guys,
I have recently bought PINEA64-lts boards with EMMC modules of 16gb. I am having trouble interfacing them now. When I burn any image on EMMC ( I have tried several), it dosen't boot from EMMC. The same image when I burn onto SD card,  it starts booting. When only EMMC is inserted PINE64 shows black screen and there is no sign of booting process. Can you please help me out.

I have also tried auyfan's image on SD card. and when I insert EMMC onto PINEA64-lts and check EMMC status, it gets detected with uenv.txt "mmc_compact=on". But when i burn the same image on EMMC and repeat all of above process, boot process does not start.

I am using pine64 usb programmer to program the emmc modules. and i ordered everything from the pine64 official site. EMMC has FORESEE 16 GB IC on it.

When i plugin emmc module in laptop using programmer, it always gets detected and there is no problem in programming the EMMC module.

I am newbie here, hope you guys will guide me well.... Thanks in advacnce

On Pine A64-LTS board, teh SD boot has higher priority than eMMC, please make sure there is no bootable OS build microSD card in microSD slot.
Yes, i made sure that SD card has not been inserted during boot process and only EMMC module is attached to the board. but issue still not sovled.

(11-08-2020, 06:02 AM)poVoq Wrote: That doesn't seem to be the issue. I think it is rather that images made to boot from SD will not boot from emmc, and there is very little clarity what needs to be done to make them boot from emmc.
i downloaded the following image from pine64 site and they did mention it supports EMMC module tooo
"""""
Armbian Buster for Desktop Usage """"""

I am very worries, i already have emailed PINE64 but they havent replied me. Can you please let me know which image will be better for emmc module.
  Reply
#5
I think the Armbian images currently do not support booting from the emmc. In fact I have trouble getting my Sopine modules (on a clusterboard) to recognize the emmc at all, but I am not sure if that is only a clusterboard specific issue.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Booting from eMMC saileshrajk 11 4,257 11-06-2020, 01:52 AM
Last Post: khantheengr
  Pine64 LTS GbE Problem scchoi 1 706 06-20-2020, 12:39 PM
Last Post: tllim
  SoPine eMMC compatibility Terra854 4 2,776 02-20-2020, 07:52 PM
Last Post: mcrognale
  LTS can't see eMMC devices 1291 4 1,620 02-20-2020, 07:43 PM
Last Post: mcrognale
  eMMC fail in 2% of flashing barucha 9 2,178 02-08-2018, 03:00 AM
Last Post: Chibero
  EMMC cards in Pine64 store stephen fleming 16 14,178 12-26-2017, 12:19 PM
Last Post: tllim

Forum Jump:


Users browsing this thread: 1 Guest(s)