eMMC not gets detected by initramfs?
#1
Hi, this is my first thread, I'm new to PINE64 and need help with a Pinebook Pro.

So... My PBP has elementary OS installed on its internal disk, but after not charging for a while (I guess, it can be some other cause), initramfs stops detecting the eMMC... It says something like "UUID=xxx not found dropping to shell", and in the busybox terminal I found out that there's just no mmcblk2 detected! In /sys/block/ there's only mmcblk1 - my SD card! But the eMMC is definitely not dead, because the PBP still can find the bootloader from eMMC.

So what happens inside my PBP so initramfs can't detect it, but the firmware does??? And the problem just dissappears when charging for a while again?


And sorry if this question is stupid and it's on the first page of some documentation and was answered ~90 times on this forum and it would get 1000 downvotes on stackoverflow.
  Reply
#2
Yea, it really does boot after gets charged (and it doesn't after no charging even if it has 100%)... How is that possible?
  Reply
#3
Not stupid at all, the hardware sometimes is a bit flaky
Just a guess,, emmc maybe starting to die OR needs to removed, reinserted (more likely)
Some came from shipping with emmc rattling around inside, maybe you bumped it wrong?
(so clearly there is no screw to hold it down)
And just how do you know it is using emmc uboot? There is a uboot on SD,
just in case there is no emmc installed
  Reply
#4
(10-27-2020, 09:18 AM)wdt Wrote: Not stupid at all, the hardware sometimes is a bit flaky
Just a guess,, emmc maybe starting to die OR needs to removed, reinserted (more likely)
Some came from shipping with emmc rattling around inside, maybe you bumped it wrong?
(so clearly there is no screw to hold it down)
And just how do you know it is using emmc uboot?  There is a uboot on SD,
just in case there is no emmc installed

Thank you for help!

I bought this PBP a week ago, don't think that the eMMC will start to die so fast. It maybe got damaged in shipping (I live in Europe) or just fell of as you say.
Taking the SD card out doesn't help either.

The most likely working solution will be to reinsert the internal eMMC, let me try that later
  Reply
#5
It didn't help.

I should have mentioned that it also says "mmc2: error -110 whilst initialising MMC card" (pretty British lol). Then, is my eMMC broken?
Will initramfs of another distro work better? I think so. Let me now install Manjaro GNOME and see.
  Reply
#6
(11-04-2020, 03:13 PM)overlisted Wrote: It didn't help.

I should have mentioned that it also says "mmc2: error -110 whilst initialising MMC card" (pretty British lol). Then, is my eMMC broken?
Will initramfs of another distro work better? I think so. Let me now install Manjaro GNOME and see.

Did you ever get this resolved?
  Reply
#7
(05-09-2021, 05:36 PM)djhnsn Wrote:
(11-04-2020, 03:13 PM)overlisted Wrote: It didn't help.

I should have mentioned that it also says "mmc2: error -110 whilst initialising MMC card" (pretty British lol). Then, is my eMMC broken?
Will initramfs of another distro work better? I think so. Let me now install Manjaro GNOME and see.

Did you ever get this resolved?

These are the uboot files from kali. I haven't tried this on anything but kali. However it just booted about 20x in a row. Maybe I will try them elsewhere. 

https://www26.zippyshare.com/v/CgMcFv09/file.html

If anyone knows of a better free file hosting site, feel free to rehost it.

Edit: I did try these files flashed to manjaro, but uboot failed.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  eMMC for Odroid C4 work in PBP? dieselnutjob 6 470 04-05-2022, 10:10 AM
Last Post: jiyong
  Pinebook Pro bricked after flashing eMMC User 24592 0 459 02-17-2022, 07:55 AM
Last Post: User 24592
  2021.10 u-boot broken on emmc clonex10100 3 1,483 12-14-2021, 04:24 PM
Last Post: jiyong
  U-Boot with direct NVMe boot support for eMMC/SPI Flash pcm720 122 140,458 12-13-2021, 03:48 PM
Last Post: wdt
Question Just purchased a used PBP (with no eMMC!) - any tips for a new user? pinemouth 15 2,541 12-07-2021, 08:23 PM
Last Post: wdt
  eMMC disconnecting for no reason? overlisted 1 805 10-26-2021, 03:08 PM
Last Post: overlisted
  PInebook not booting with eMMC enabled aragaer 4 1,406 10-25-2021, 09:11 PM
Last Post: wdt
  Pinebook Pro not powering on when eMMC hardware switch is off vgrimaldi 2 1,296 06-29-2021, 05:19 AM
Last Post: KC9UDX
  UK Pinebook Pro for sale (UK buyers only, 64GB, eMMC reader, NVME add-on) Z0rua 0 1,005 06-01-2021, 12:51 PM
Last Post: Z0rua
  I am ready to accept that there may be a problem with my emmc. djhnsn 4 2,353 05-18-2021, 12:25 AM
Last Post: djhnsn

Forum Jump:


Users browsing this thread: 1 Guest(s)