How to setup a ffmpeg streaming server on Manjaro?
#1
On my PinebookPro running Majaro, I try to setup a ffmpeg streaming server.

I start ffmpeg this way:

Code:
ffmpeg -listen 1 -i rtmp://localhost:1935/live/cube -c copy  rtmp://localhost:1935/live/mpv

As a result, ffmpeg is hangig as if it was listening on the socket. But when I check the sockets (e.g. with ss -a), port 1935 is not displayed.

When I try to stream from the pinecube, with this command: 
Code:
[root@nixos:/home/nixos]# ffmpeg -s 640x480 -r 15 -i /dev/video0 -vcodec flv -f flv rtmp://pbp:1935/live/cube
 I get this error:
Code:
[tcp @ 0x81110] Connection to tcp://pbp:1935 failed: Connection refused
[rtmp @ 0x80c10] Cannot open connection tcp://pbp:1935
rtmp://pbp:1935/live/cube: Connection refused
which can be expected, as there is nothing listening on port 1935 on pbp.

Has anybody got ffmpeg  working as a rtmp server or are you using nginx with rtmp support enabled?
Are there other lightweight streaming servers availabe?
Thanks for your help!
  Reply
#2
(10-26-2020, 09:15 AM)vfr400racer Wrote: On my PinebookPro running Majaro, I try to setup a ffmpeg streaming server.

I start ffmpeg this way:

Code:
ffmpeg -listen 1 -i rtmp://localhost:1935/live/cube -c copy  rtmp://localhost:1935/live/mpv

As a result, ffmpeg is hangig as if it was listening on the socket. But when I check the sockets (e.g. with ss -a), port 1935 is not displayed.

When I try to stream from the pinecube, with this command: 
Code:
[root@nixos:/home/nixos]# ffmpeg -s 640x480 -r 15 -i /dev/video0 -vcodec flv -f flv rtmp://pbp:1935/live/cube
 I get this error:
Code:
[tcp @ 0x81110] Connection to tcp://pbp:1935 failed: Connection refused
[rtmp @ 0x80c10] Cannot open connection tcp://pbp:1935
rtmp://pbp:1935/live/cube: Connection refused
which can be expected, as there is nothing listening on port 1935 on pbp.

Has anybody got ffmpeg  working as a rtmp server or are you using nginx with rtmp support enabled?
Are there other lightweight streaming servers availabe?
Thanks for your help!
Problem was not the listening on the server, but the copy target on the server. Copy to a local file as target works.
ffmpeg is listening, but it can not be seen with ss -a. the correct command is ss -tunlp
  Reply
#3
Try setting it to your actual ip address instead of localhost
  Reply
#4
(10-31-2020, 12:20 AM)bhhaskin Wrote: Try setting it to your actual ip address instead of localhost
I tried that before and it didn't make a difference. The problem was, that I was forwarding (copying) the stream to a port where nothing was listening.
Instead of copying to a port, copying to a local file worked well. Recently I installed nginx with the rtmp module (was a bit painful on pbp / manjaro)
but now it is running and is working absolutely perfect.
  Reply
#5
There is also a docker option that worked really well for me
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)