noob with non booting rock64 4g
#1
Hi

ive read other posts and im trying to establish if my board has a HW issue.
ive flashed some raspberry pi (32 bit) previously so i believe im flashing my sd card ok.
i gave a green led on longside the power connector
i have a solid red and a while led on by the gpio pins.
the activity led on the nic port (on the usb side of the port) is solid amber regardless of cable in or out
the other nic led is always off.
the power button longside the white led turns all but the green led off.
there is no hdmi output .


what do i do next to determine if its a brick or not
  Reply
#2
What image are you trying to boot?
  Reply
#3
Hi

the last image i tried was Armbian_20.08.1_Rock64_bionic_current_5.8.6_desktop

regards
  Reply
#4
Can't be certain but I think the Rock64 struggles with newer versions of Linux 5x. I'm using the following version


____ ___ ____ _ ____ _ _
| _ \ / _ \ / ___| |/ / /_ | || |
| |_) | | | | | | ' / '_ \| || |_
| _ <| |_| | |___| . \ (_) |__ _|
|_| \_\\___/ \____|_|\_\___/ |_|

Welcome to Debian Buster with Armbian Linux 4.4.192-rockchip64
System load: 0.01 0.02 0.00 Up time: 12 days
Memory usage: 14 % of 3988MB IP: 192.168.0.206
CPU temp: 47°C
Usage of /: 7% of 58G

[ General system configuration (beta): armbian-config ]



See if you grab the above version as I can confirm it works.
  Reply
#5
IIRC i never managed to boot Buster in mainline, however it booted Focal with GUI. 5.8 6.
  Reply
#6
(10-11-2020, 06:36 PM)Rocklobster Wrote: Can't be certain but I think the Rock64 struggles with newer versions of Linux 5x. I'm using the following version


____  ___  ____ _  ____  _  _ 
|  _ \ / _ \ / ___| |/ / /_ | || | 
| |_) | | | | |  | ' / '_ \| || |_
|  _ <| |_| | |___| . \ (_) |__  _|
|_| \_\\___/ \____|_|\_\___/  |_| 
                                   
Welcome to Debian Buster with Armbian Linux 4.4.192-rockchip64
System load:  0.01 0.02 0.00  Up time:      12 days         
Memory usage:  14 % of 3988MB  IP:            192.168.0.206
CPU temp:      47°C           
Usage of /:    7% of 58G       

[ General system configuration (beta): armbian-config ]



See if you grab the above version as I can confirm it works.

thanks

more of the same im afraid :-)
the lack of output from hdmi doesn't help.
  Reply
#7
(10-12-2020, 01:58 PM)john72carter Wrote:
(10-11-2020, 06:36 PM)Rocklobster Wrote: Can't be certain but I think the Rock64 struggles with newer versions of Linux 5x. I'm using the following version


____  ___  ____ _  ____  _  _ 
|  _ \ / _ \ / ___| |/ / /_ | || | 
| |_) | | | | |  | ' / '_ \| || |_
|  _ <| |_| | |___| . \ (_) |__  _|
|_| \_\\___/ \____|_|\_\___/  |_| 
                                   
Welcome to Debian Buster with Armbian Linux 4.4.192-rockchip64
System load:  0.01 0.02 0.00  Up time:      12 days         
Memory usage:  14 % of 3988MB  IP:            192.168.0.206
CPU temp:      47°C           
Usage of /:    7% of 58G       

[ General system configuration (beta): armbian-config ]



See if you grab the above version as I can confirm it works.

thanks

more of the same im afraid :-)
the lack of output from hdmi doesn't help.

So connected up to HDMI you are seeing nothing. Make sure you have a good quality HDMI cable connected to the monitor and the board before you power up the Rock64

The only other thing to check I can think of is a bad SD card or a flaky power supply. Try substituting both and see if that helps.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Python GPIO Library for the Rock64 (R64.GPIO) Leapo 36 33,604 04-17-2021, 08:59 AM
Last Post: theophile
Question Hardware issues with Rock64 grobbs 10 619 04-08-2021, 05:24 AM
Last Post: t4_4t
  Rock64 Long Term stability ramprasad 4 1,251 03-16-2021, 07:23 PM
Last Post: Rocklobster
  Rock64 No Audio - Solved wbecks 11 14,001 03-15-2021, 03:15 PM
Last Post: lowry
  Safest way to send shutdown signal to headless Rock64 SMB server? bmurphr1 3 729 03-14-2021, 06:01 PM
Last Post: clach04
  Rock64 as a router (OpenWRT,etc) bob-anon 2 1,158 03-12-2021, 01:16 AM
Last Post: arkadione
  Rock64 enable 1-wire to read DS18B20 or Dallas temperature sensor Perry 2 885 02-12-2021, 08:02 PM
Last Post: Perry
  Will Mobian Run On Rock64? Porcupine 1 417 01-13-2021, 12:39 PM
Last Post: tophneal
  Rock64 v2 as Openmediavault server - buffers / shutdown problems helpmerock 2 758 12-29-2020, 09:46 AM
Last Post: helpmerock
  rock64, compile problems "illegal instruction", "memory fault" -> ddr_333Mhz? hunderteins 10 4,631 11-17-2020, 08:00 AM
Last Post: Johannes

Forum Jump:


Users browsing this thread: 1 Guest(s)