Correct setup for u-boot and fstab ? Device not booting
I am trying to boot from eMMC and no I did not flash uBoot into SPI and everything is on the same card, but divided in 3 partitions (boot=ext2 / root=ext4 / swap)

My extlinux.conf is as below
DEFAULT debian

LABEL debian
KERNEL /vmlinuz
INITRD /initrd.img
APPEND console=tty1 root=LABEL=root rw rootwait

I have not tried to boot from SD-Card, will do next week when I have more time on hand.
Do you have some strange characters in the file or something similar? The contents itself look okay to me. Did you change something in u-boot when compiling it such as removing support for extlinux or the like? At least these messages seem to indicate that uboot does not know what the commands in the extlinux.conf mean:

Retrieving file: /extlinux/extlinux.conf
191 bytes read in 2 ms (92.8 KiB/s)
Ignoring unknown command: MENULABEL
Ignoring unknown command: KERNEL
Ignoring unknown command: INITRD
Ignoring unknown command: DEVICETREEDIR
Ignoring unknown command: APPEND

One thing you could try would be entering the relevant commands by hand on the command line and see if it boots then for you.
Tried with an SD-Card and it behaves exactly the same, won't parse extlinux.conf.

I have checked the file in nano and could not see any strange symbols or similar, only plain text.

And I use stock u-boot without any modification, direct from source/github.

@as365n4 That's really strange. Did you try with an older uboot version as well? I will try to reproduce the issue once I free my eMMC module (I currently use it on my rockpro64 but plan to switch to microSD this weekend).
@as365n4 I just tried with the latest build I just finished (using Debian instead of Devuan this time). No issues with u-boot, it just boots fine (tried using eMMC). Would it help if I send you my u-boot image?
sorry for the late reply, I was busy with work all February... Undecided

I just downloaded the sources again for arm-trusted-firmware and uboot.
Tha arm-trusted-firmware built just fine without errors (v2.4).
But the u-boot built finished with an yellow error, as below (v2021.01), could this the reason why my built of u-boot wont decode extlinux.conf ?

Image 'main-section' is missing external blobs and is non-functional: scp

   SCP firmware is required for system suspend, but is otherwise optional.
   Please read the section on SCP firmware in board/sunxi/README.sunxi64

Some images are invalid

And many thanks for your offer in sending your u-boot image, but I would like to crack that nut and manage to build a working u-boot.
Main goal is to provide a "simple to follow" guide to build Debian for H64 Boards and publish that on Github for others to use who might be interested. Wink
As I believe the H64 doen't get enough "love" from the wider Linux Community / Distros.
You are welcome. :-)

And no, I don't remember getting this error. Maybe it would help if I record a small asciinema screencast when building u-boot, probably we will be able to find the difference this way faster.

@as365n4 I tried it again, and indeed newer u-boot versions seem not to work for the H64. But v2020.10 does. See my recording here (including the failed attempts):

(recording will be auto-deleted after 7 days)
I compiled arm-trusted-firmware 2.4 and u-boot 2020.10 flashed onto eMMC with the same effect, won't decode extlinux.conf.
Then I compiled arm-trusted-firmware 2.3 and u-boot 2020.10 flashed onot eMMC now it can't see the eMMC.

Watched your screencast, many thanks it is appreciated.

Have to see and figure out what I am doing wrong....

Also, I tried to read up on that SCP firmware and how to compile, but despite having musl on the system it won't compile, but this is for later to solve.

This is how I compile ATF and u-boot
git clone
cd arm-trusted-firmware
git checkout v2.3
make CROSS_COMPILE=aarch64-linux-gnu- PLAT=sun50i_h6 bl31
cd ..
git clone git://
cd u-boot
git checkout v2020.10
ln -s /home/youruser/assets/arm-trusted-firmware/build/sun50i_h6/release/bl31.bin bl31.bin
make CROSS_COMPILE=aarch64-linux-gnu- BL31=bl31.bin pine_h64_defconfig
make -j4 CROSS_COMPILE=aarch64-linux-gnu- BL31=bl31.bin
Looks okay to me, and your u-boot seems to load but the question is why it can't parse the extlinux.conf. Maybe a partitioning issue? A few ideas in order to rule out some causes on a more coarse-grained level:

- does the same OS boot fine on another Allwinner platform (e.g. A64) if you replace the bootloader with the one for the other platform?
- did you try to use another OS from a precompiled image (e.g. Armbian) where you just replaced their bootloader with yours?
I have 3 partitions on the eMMC, the first starts at sector 2048 and ends at sector 647167 and is formated as ext2 and mounted as /boot and marked as active, the second starts at sector 647168 and ends on sector 28211199 is formated as ext4 and mounted as / the third partition starts at sector 28211200 and ends at 30308351 and is formated and mounted as swap.

I do not have any other Allwinner SBC, I mainly use Rock64 and have a spare RockPro64, PinebookPro and a Pinephone all 3 for tinkering. The Rock64 are my main SBC for daily use (I operate several Flight and Ship Tracker at different locations and all of them using Rock64 SBC and Vanilla Debian).

Before I tried to adapt Vanilla Debian for the H64 I tired Armbian, but they are of no use as they don't support High Speed eMMC on the H64 and otherwise unpleasant to deal with. So I dropped them very very quickly. Then I used the Manjaro build for the H64 for quite a while which actually worked just fine but Manjaro lacks certian packages which I require for my use case and since I am more of a Debian person as all my Computers running Debian except a bunch of servers which run BSD. Hence the "urge" to get Vanilla Debian running on the H64.

Possibly Related Threads…
Thread Author Replies Views Last Post
  U-boot not booting on H64 model B CGNZVV 2 2,208 06-08-2022, 10:32 AM
Last Post: as365n4
  Unable to boot any armbian linux vicsanca 6 6,922 10-17-2019, 12:08 PM
Last Post: JGwinner

Forum Jump:

Users browsing this thread: 1 Guest(s)