NVMe timeout when booting from eMMC but not SD
#4
Hello, @alexeymin 

I'm also currently experiencing flaky boots with the Kingston A2000 NVMe. I guess that this is most likely some U-Boot issue. When I first tried this drive, I used pcm720's U-Boot build, with great success. Note the patch that increases the timeout, to give more time to the NVMe drives to appear. I even had this U-Boot flashed to the SPI and I had the /boot partition on the NVMe. Alas, for some reason this build broke the SD Card reader - SD Cards were neither bootable, not even readable when inserted after boot.

I'm currently using the last build of mrfixit's U-Boot, with /boot partition on the eMMC and the root partition on the NVMe. It boots most of the time, and drops me at the initramfs prompt when it doesn't find the NVMe. From there, by reloading the nvme module (rmmod nvme; modprobe nvme),  I'm able to continue the boot process and everything boots successfully.

I don't have much time at the moment to play around with different U-Boot builds and kernels. I'm currently using the unofficial Debian installer by Daniel Thompson, along with his 5.7 kernel. I guess that there should be some combination of U-Boot and kernel that will behave more consistently. Somebody will surely find it. Rolleyes
  Reply


Messages In This Thread
RE: NVMe timeout when booting from eMMC but not SD - by psstoev - 05-03-2021, 02:08 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Help installing Manjaro on eMMC of Pinebook Pro pine4546464 4 2,456 12-13-2023, 07:22 PM
Last Post: trillobite
  Manjaro 20.04 not loading from SD (with Manjaro on eMMC) zaius 1 562 12-07-2023, 03:11 PM
Last Post: wdt
  [Manjaro] u-boot won't boot from eMMC with (unbootable) SD card present zackw 1 2,110 08-21-2023, 09:08 PM
Last Post: vanessadonald
  Issue with booting Manjaro from encrypted NVMe drive on pbp Cs137 1 1,095 08-18-2023, 01:58 AM
Last Post: juliamenendez
  Blank screen after Armbian 20.04 install to emmc? psychoacoustic 3 3,725 04-01-2023, 03:22 PM
Last Post: TRS-80
  Fix for Armbian not booting on PBP from eMMC agreenbhm 7 4,223 04-01-2023, 02:58 PM
Last Post: TRS-80
  NVME fails detection our0 1 907 01-30-2023, 08:45 AM
Last Post: Tazdevl
  My installation guide starting from messed up eMMC Besouro 0 936 12-19-2022, 01:01 PM
Last Post: Besouro
  dwmmc_rockchip fe320000.mmc: Unexpected CMD11 timeout gsplitz 0 613 11-29-2022, 06:47 PM
Last Post: gsplitz
  newer ""emmc-installer" images (manjaro xfce) magistral 1 1,183 10-10-2022, 06:22 AM
Last Post: maxjrh

Forum Jump:


Users browsing this thread: 1 Guest(s)