NVMe timeout when booting from eMMC but not SD
#3
I'm seeing the same 60s delay and the same timeout with the same SSD (Kingston A2000 256 Gb) when booting from eMMC:

Code:
[   1.886899] usb 2-1.2: Manufacturer: Sonix Technology Co., Ltd.
[  31.847180] vbus_5vout: disabling
[  64.487248] nvme nvme0: I/O 0 QID 0 timeout, disable controller
[  64.607160] nvme nvme0: Device shutdown incomplete; abort shutdown
[  64.608409] nvme nvme0: Identify Controller failed (-4)
[  64.609050] nvme nvme0: Removing after probe failure status: -5
[  64.640311] Freeing unused kernel memory: 2816K
[  64.707554] Run /init as init process

P.S. I'm using posmarketOS

What's interesting though is that u-boot seems to recognize the drive fine during boot: https://imgur.com/q59Hiel

[Image: q59Hiel.jpg]

Also when booting the same posmarketOS image (or Manjaro ARM image) from SD card there are no timeouts and it can see this nvme drive just fine.

Instructions to alter kernel cmdline from this post from kernel bug report - https://bugzilla.kernel.org/show_bug.cgi?id=195039#c73 - specifically 
Code:
nvme_core.default_ps_max_latency_us=0 pci_aspm=performance
also don't help Sad

That kernel bug report also mentions kingston firmware update that might help - https://www.kingston.com/unitedstates/us...are-update - that you can only install from Windows Sad
Code:
Firmware Rev S5Z42109(03-30-2021):
Fixed an issue that might cause the drive to become unresponsive on Linux systems


If nothing works I guess I'll try another SSD  Cry
  Reply


Messages In This Thread
RE: NVMe timeout when booting from eMMC but not SD - by alexeymin - 05-02-2021, 04:25 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Help installing Manjaro on eMMC of Pinebook Pro pine4546464 4 2,491 12-13-2023, 07:22 PM
Last Post: trillobite
  Manjaro 20.04 not loading from SD (with Manjaro on eMMC) zaius 1 572 12-07-2023, 03:11 PM
Last Post: wdt
  [Manjaro] u-boot won't boot from eMMC with (unbootable) SD card present zackw 1 2,119 08-21-2023, 09:08 PM
Last Post: vanessadonald
  Issue with booting Manjaro from encrypted NVMe drive on pbp Cs137 1 1,103 08-18-2023, 01:58 AM
Last Post: juliamenendez
  Blank screen after Armbian 20.04 install to emmc? psychoacoustic 3 3,734 04-01-2023, 03:22 PM
Last Post: TRS-80
  Fix for Armbian not booting on PBP from eMMC agreenbhm 7 4,248 04-01-2023, 02:58 PM
Last Post: TRS-80
  NVME fails detection our0 1 912 01-30-2023, 08:45 AM
Last Post: Tazdevl
  My installation guide starting from messed up eMMC Besouro 0 940 12-19-2022, 01:01 PM
Last Post: Besouro
  dwmmc_rockchip fe320000.mmc: Unexpected CMD11 timeout gsplitz 0 620 11-29-2022, 06:47 PM
Last Post: gsplitz
  newer ""emmc-installer" images (manjaro xfce) magistral 1 1,191 10-10-2022, 06:22 AM
Last Post: maxjrh

Forum Jump:


Users browsing this thread: 1 Guest(s)