NVMe timeout when booting from eMMC but not SD
#1
I just got an NVMe adapter for my Pinebook Pro and have installed it with a Kingston A2000 250GB NVMe SSD.  This is an SSD that others have reported success with on the wiki.

The boot process stalls for 60s and then I get a timeout error like this:

Code:
[    3.742566] nvme nvme0: pci function 0000:01:00.0
[    3.742612] nvme 0000:01:00.0: enabling device (0000 -> 0002)
[   64.480323] nvme nvme0: I/O 12 QID 0 timeout, disable controller
[   64.600233] nvme nvme0: Device shutdown incomplete; abort shutdown
[   64.640667] nvme nvme0: Identify Controller failed (881)
[   64.641472] nvme nvme0: Removing after probe failure status: -5

And then it boots normally, but none of the /dev/nvme0* devices are available.  This is on Debian Bullseye installed with Daniel Thompson's installer and kernel.  Kernel 5.5 and 5.7 both have this same behavior.

Here's the weird part.  I only have this problem booting from eMMC.  If I boot from an SD card with basically the same Bullseye install and the same kernel, the NVMe drive works perfectly.  So it doesn't seem to be bad hardware or a simple compatibility issue.

I'm a little stumped.
  Reply


Messages In This Thread
NVMe timeout when booting from eMMC but not SD - by satwell - 10-01-2020, 09:49 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Help installing Manjaro on eMMC of Pinebook Pro pine4546464 4 2,605 12-13-2023, 07:22 PM
Last Post: trillobite
  Manjaro 20.04 not loading from SD (with Manjaro on eMMC) zaius 1 630 12-07-2023, 03:11 PM
Last Post: wdt
  [Manjaro] u-boot won't boot from eMMC with (unbootable) SD card present zackw 1 2,169 08-21-2023, 09:08 PM
Last Post: vanessadonald
  Issue with booting Manjaro from encrypted NVMe drive on pbp Cs137 1 1,146 08-18-2023, 01:58 AM
Last Post: juliamenendez
  Blank screen after Armbian 20.04 install to emmc? psychoacoustic 3 3,843 04-01-2023, 03:22 PM
Last Post: TRS-80
  Fix for Armbian not booting on PBP from eMMC agreenbhm 7 4,436 04-01-2023, 02:58 PM
Last Post: TRS-80
  NVME fails detection our0 1 944 01-30-2023, 08:45 AM
Last Post: Tazdevl
  My installation guide starting from messed up eMMC Besouro 0 978 12-19-2022, 01:01 PM
Last Post: Besouro
  dwmmc_rockchip fe320000.mmc: Unexpected CMD11 timeout gsplitz 0 647 11-29-2022, 06:47 PM
Last Post: gsplitz
  newer ""emmc-installer" images (manjaro xfce) magistral 1 1,229 10-10-2022, 06:22 AM
Last Post: maxjrh

Forum Jump:


Users browsing this thread: 1 Guest(s)