No sound from Rock64 DAC
#1
I bought the rock64 dac from ameridroid:

https://ameridroid.com/products/rock64-s...ifi-shield

I de-soldered the ethernet port so that it would fit in the pine64 aluminum case.

I flashed a fresh copy of armbian onto an emmc module and booted. I built and installed musikcube and tried every one of the alsa audio devices available, but I get no sound out of the dac. Any suggestions?

Code:
cbrown@rock64:~$ aplay -L
default
    Playback/recording through the PulseAudio sound server
null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    PulseAudio Sound Server
sysdefault:CARD=rockchiprk3328
    rockchip,rk3328, ff000000.i2s-i2s-hifi i2s-hifi-0
    Default Audio Device
dmix:CARD=rockchiprk3328,DEV=0
    rockchip,rk3328, ff000000.i2s-i2s-hifi i2s-hifi-0
    Direct sample mixing device
dmix:CARD=rockchiprk3328,DEV=1
    rockchip,rk3328, ff010000.i2s-rk3328-hifi ff410000.codec-1
    Direct sample mixing device
dmix:CARD=rockchiprk3328,DEV=2
    rockchip,rk3328, ff030000.spdif-dit-hifi dit-hifi-2
    Direct sample mixing device
dsnoop:CARD=rockchiprk3328,DEV=0
    rockchip,rk3328, ff000000.i2s-i2s-hifi i2s-hifi-0
    Direct sample snooping device
dsnoop:CARD=rockchiprk3328,DEV=1
    rockchip,rk3328, ff010000.i2s-rk3328-hifi ff410000.codec-1
    Direct sample snooping device
dsnoop:CARD=rockchiprk3328,DEV=2
    rockchip,rk3328, ff030000.spdif-dit-hifi dit-hifi-2
    Direct sample snooping device
hw:CARD=rockchiprk3328,DEV=0
    rockchip,rk3328, ff000000.i2s-i2s-hifi i2s-hifi-0
    Direct hardware device without any conversions
hw:CARD=rockchiprk3328,DEV=1
    rockchip,rk3328, ff010000.i2s-rk3328-hifi ff410000.codec-1
    Direct hardware device without any conversions
hw:CARD=rockchiprk3328,DEV=2
    rockchip,rk3328, ff030000.spdif-dit-hifi dit-hifi-2
    Direct hardware device without any conversions
plughw:CARD=rockchiprk3328,DEV=0
    rockchip,rk3328, ff000000.i2s-i2s-hifi i2s-hifi-0
    Hardware device with all software conversions
plughw:CARD=rockchiprk3328,DEV=1
    rockchip,rk3328, ff010000.i2s-rk3328-hifi ff410000.codec-1
    Hardware device with all software conversions
plughw:CARD=rockchiprk3328,DEV=2
    rockchip,rk3328, ff030000.spdif-dit-hifi dit-hifi-2
    Hardware device with all software conversions
cbrown@rock64:~$
  Reply
#2
I don't have a DAC hat or a Rock64 but the following suggestions might contain an answer.

A few questions:
- Did you test the DAC hat was working completely before modifying it?
- Are there jumpers on the DAC hat that need to be set correctly?
- Does the kernel automatically support the DAC hat?

To see if the kernel is automatically detecting the DAC hat:
1. Without the DAC hat installed list all the audio devices, then install the DAC hat
2. List all the audio devices again and compare with the previous list -- any differences?

Until there is a difference need to run around trying different jumper settings, re-booting, listing the devices until it appears. If there are no results then need to look in to the kernel to make sure it supports the DAC or take the nuclear option and build a new kernel. The DAC hat does need support in the kernel for it to appear in audio device listings (assuming jumpers are setup correctly).

Instead of messing with the kernel, trying volumeio might be a direct route to testing and proving the audio DAC hat is working?

NB just throwing in the existence of jumpers for the heck of it (I see pins sticking up they might be jumpers), I don't know if the hat actually has any - you tell us!
  Reply
#3
Thanks for the suggestions. I can confirm that the dac works with volumio. I can also report that the list of audio devices from aplay -L is no different when the dac is or is not connected.

I do wonder if it is an overlay problem. I will investigate that next and report back.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Display options for the Rock64 joey49 1 107 11-23-2020, 09:52 AM
Last Post: joey49
  Are HW design files available for ROCK64? irenek 1 503 09-29-2020, 05:57 PM
Last Post: tllim
  Which Voltage and Amper to supply both Rock64 + External drive enclosure ? prog-amateur 0 373 08-21-2020, 09:16 PM
Last Post: prog-amateur
Information Rock64 RTL8188EU Wifi Adapter from Pine Store Tested Well MarkHaysHarris777 7 3,074 05-13-2020, 06:00 PM
Last Post: Leon Rembowski
  accident got 12v at my rock64 lifeform 1 688 04-17-2020, 09:46 AM
Last Post: fire219
  Help! Rock64 won't boot anything! trohn_javolta 3 1,138 03-09-2020, 06:03 PM
Last Post: tllim
  Power Supply and Sinks for multi-Rock64 env Davo-CC 1 1,727 01-02-2020, 02:26 PM
Last Post: dpgraham
Lightbulb Mount a HeatSink on the Rock64 using 3M Thermal Tapes MarkHaysHarris777 22 18,506 11-29-2019, 03:14 AM
Last Post: ab1jx
  My Rock64 died (with a happy ending!) rmbusy 1 1,170 08-15-2019, 06:48 PM
Last Post: tllim
Information Brushless Fan (5v) for Rock64 Clear Case Soft PWM Drive 2N2222 MarkHaysHarris777 7 6,830 07-09-2019, 06:15 AM
Last Post: merwone

Forum Jump:


Users browsing this thread: 1 Guest(s)