USB-C Power Delivery does not work
I have PinePhone PostmarketOS edition (3GB). But i have a problem with PD charging. I bought a PD charger that support the '5V/3A' PD mode and a 'USB-C -> USB-C' cabel that supports PD and says 'max. 3A'. But I can't make Power Delivery work. I also tried other PD chargers and other USB-C cables. I tried on recent images of Mobian and Ubuntu Touch.

My PD charger will become green if PD negotiation is successful.

Does PinePhone software have some driver that performs PD negotiation with the Type-C charger? Should I use USB-A chargers for now?
I have the same problem with a PD charger and USB-C -> USB-C cable. I tried the tweak mentioned here and now charging works - not at 5 V×3 A = 15 W Power Delivery specs, but at 5 V×1.5 A = 7.5 W (USB Battery Charging 1.1 spec?).

I thought the problem could be the USB-C hardware bug on the 1.2 rev boards (UBports) preventing charging negotiation, but that should be fixed on the PostmarketOS phones if I remember correctly (maybe I don't)?

Anyway, 1.5 A is better than the 0.5 A I got with my old USB charger, and much better than no charging at all! Smile
Details from Megi below - I'm not sure how much of that has made it into which distros so far. For the moment it looks like the 5V/2.1A battery Charging 1.2 spec chargers are a better bet than PD chargers, especially the 3A ones.

Possibly Related Threads…
Thread Author Replies Views Last Post
  How does calls work in debian? temp0rary 4 576 05-31-2021, 10:44 AM
Last Post: temp0rary
  alarms do not seem to work motox6 2 469 05-06-2021, 11:08 AM
Last Post: motox6
  Making nextcloud sync work on the phone 3x5co 4 1,768 03-27-2021, 03:49 PM
Last Post: MarkF
  Alarm clock doesn’t work Captain1ndustry 10 4,528 01-15-2021, 12:29 PM
Last Post: moodroid
  Manjaro convergence edition (3GB) charging/power issue Saliency 1 817 11-24-2020, 11:04 AM
Last Post: Saliency
  USB-C Power Delivery cmicallef 8 2,874 10-04-2020, 07:34 PM
Last Post: HLing
  Delayed shut down or restart through power menu DarkManiels 1 903 10-04-2020, 07:19 PM
Last Post: HLing
  apt-get update hanging twice (work-around included) motox6 11 5,499 08-08-2020, 04:20 PM
Last Post: jed
  Incoming call does not work firefox-58 19 7,693 08-03-2020, 05:03 AM
Last Post: dancingqueen74
  Mobian Mobile Data Doesn't Work pablo180 5 2,979 07-23-2020, 08:54 AM
Last Post: jed

Forum Jump:

Users browsing this thread: 1 Guest(s)