Pinebook Pro won't post after hard reset
#11
(09-22-2020, 04:46 PM)KC9UDX Wrote: You can re-flash the eMMC once you've booted from SD or USB.  Try both now that you've flashed SPI.

Update: I managed to finally boot into the Debian image from my SD card. Run lsblk to list my drives and noticed the internal eMMC was listed as mmcblk0. Now from memory I think it should be mmcblk2 right? Does this mean my boot order is all messed up? I tried to flash the SD card to the eMMC, all appeared to work fine but upon a reboot I still have the same issue. It won't boot to the eMMC. Just an amber light on the keyboard. Any ideas on how to fix this issue? Now I'm unable to boot back into the SD card both with eMMC on and off.
#12
So you booted from SD card, copied SD to eMMC, like this, I assume: `dd if=/dev/mmcblk2 of=/dev/mmcblk0` Correct? And now booting to SD gives the same bad result as booting to eMMC did previously. It sure sounds like you inadvertently copied the eMMC contents to the SD card.

If all this is correct, then re-flash the SD card with a bootable image, from another device. Note that several bootable SD images won't work when written to the eMMC. I'd copy a compressed image suitable for eMMC to the filesystem on the SD. Boot from SD, and use `mount` to verify which device you've booted from. Decompress and write your new eMMC image to the device you now think should be the eMMC.

I normally use NetBSD which doesn't use the mmcblk? nomenclature so I'm not positive what to recommend for which device is which.
#13
>internal eMMC was listed as mmcblk0.
Most distros are NOT consistent, why they don't follow the uboot ordering, I am not sure
(uboots numbers in order found by bootrom)
That the last paragraphs about the SPI are how to zero, that is a gigantic clue
I am amazed at the compulsion to do this, with somewhat immature firmware
Bottom line, unless you are an expert (or almost), you shouldn't do this
Maybe next year
--edit--
You should NOT dd a running system to emmc, you can rsync, exclude proc, sys, dev, run
In a non-running system they should be empty directories
Do make sure fstab and extlinux.conf are right
Better to copy image to sd or usb stick, cd to image,(as root) xzcat compressed-image |dd of=/dev/emmc bs=1M status=progress
(emmc as appropriate)
#14
(09-23-2020, 06:20 PM)KC9UDX Wrote: So you booted from SD card, copied SD to eMMC, like this, I assume: `dd if=/dev/mmcblk2 of=/dev/mmcblk0` Correct? And now booting to SD gives the same bad result as booting to eMMC did previously.  It sure sounds like you inadvertently copied the eMMC contents to the SD card.

If all this is correct, then re-flash the SD card with a bootable image, from another device.  Note that several bootable SD images won't work when written to the eMMC.  I'd copy a compressed image suitable for eMMC to the filesystem on the SD.  Boot from SD, and use `mount` to verify which device you've booted from.  Decompress and write your new eMMC image to the device you now think should be the eMMC.

I normally use NetBSD which doesn't use the mmcblk? nomenclature so I'm not positive what to recommend for which device is which.

Yep, you were correct, I pushed the eMMC to the SD card like a rookie. Went through and flashed my SD again, booted it, pushed it to the eMMC and tried to boot from the eMMC. Unfortunately, it wouldn't boot. Just ended up giving me a green light to indicate it was loading. I have tried booting with the eMMC Manjaro image and all I get is the Manjaro splash screen with the loading circle. Never actually boots or installs. I'm going to try a different image when it downloads and see how I get on.
#15
Try the Debian image for PBP. When I first got mine, for reasons I don't understand, that was the only image I could download, for which the U-boot would actually work. (Well not the only. The Chrome OS one worked too).
#16
I seem to be able to boot into Arch Linux and can configure that way. Been a little while since I've installed Arch so I'll run through that and see if I can get it to work but for the most part I can confirm there is no actual damage to the laptop. I'll mark this as completed now since I have access to it and it can actually boot into an OS now. Thanks for all the help and suggestions.


Possibly Related Threads…
Thread Author Replies Views Last Post
  ISO/UK Pinebook Pro for sale mstevens 4 231 09-17-2021, 10:49 AM
Last Post: mstevens
  Testing Some More Games on the Pinebook Pro! ImmyChan 3 192 09-16-2021, 07:06 AM
Last Post: poVoq
  Looking to buy a Pinebook Pro US Stucht13 11 975 09-11-2021, 06:40 PM
Last Post: drinkmorejava
  Pinebook Pro (ISO) for sale from Germany to Europe and UK 1yk0s 1 376 09-08-2021, 10:55 AM
Last Post: cypresstwist
Star Looking to buy a Pinebook Pro in Europe cypresstwist 0 117 09-04-2021, 02:02 PM
Last Post: cypresstwist
  Pinebook Pro Stopped Charging via USB-C MickTheGeek 4 311 08-25-2021, 02:51 PM
Last Post: MickTheGeek
  Pinebook Pro (ISO) for sale - UK Sootstone 2 421 08-24-2021, 03:08 PM
Last Post: Sootstone
  looking to buy one pinebook pro (mainland China) duanduan 0 117 08-24-2021, 08:53 AM
Last Post: duanduan
  Pinebook Pro ISO for sale (Spain) e-minguez 6 826 08-24-2021, 07:53 AM
Last Post: e-minguez
  Main Stream Debian on Pinebook Pro ? bcnaz 4 389 08-22-2021, 09:11 AM
Last Post: wdt

Forum Jump:


Users browsing this thread: 1 Guest(s)