Debian (Vanilla) on Rock64 and eMMC - how ?
#1
Hi all,

I have downloaded the 2 files (partition.img.gz + firmware.rock64-rk3328.img.gz) from https://d-i.debian.org/daily-images/arm6...rd-images/ and build the final image with zcat firmware.rock64-rk3328.img.gz partition.img.gz > debian_rock64.img and flashed that image to an SD-Card.
Inserted the SD-Card, installed an empty eMMC-Module, attached the serial cable to UART and powered-up the Rock64.

The Board boots from SD-Card into the Debian Installer and installs Debian onto the eMMC, once the installation is finished I remove the SD-Card and reboot the Rock64 and then the board is stuck and won't boot at all (no sign of life). Only if I reinsert the SD-Card and reset the board it then boots from eMMC, so the SD-Card has to be present otherwise it won't boot.

How can I setup the system so that it does not require the presence of an SD-Card to boot directly from the eMMC-Module?
Any ideas or adivce?

edit: attached the output of lsblk
Code:
Debian GNU/Linux bullseye/sid debian-rock64 ttyS2

debian-rock64 login: root
Password:
Linux debian-rock64 5.7.0-3-arm64 #1 SMP Debian 5.7.17-1 (2020-08-23) aarch64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Mon Sep  7 12:15:32 BST 2020 on ttyS2
root@debian-rock64:~# lsblk
NAME         MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
mmcblk0      179:0    0 14.8G  0 disk
└─mmcblk0p1  179:1    0 81.7M  0 part
mmcblk1      179:256  0 14.5G  0 disk
├─mmcblk1p1  179:257  0  487M  0 part /boot
├─mmcblk1p2  179:258  0   13G  0 part /
└─mmcblk1p3  179:259  0  961M  0 part [SWAP]
mmcblk1boot0 179:512  0    4M  1 disk
mmcblk1boot1 179:768  0    4M  1 disk
root@debian-rock64:~#
  Reply
#2
After many unsuccessful attempts in getting the Rock64 to boot from eMMC post Vanilla Debian install, it seems that the Debian installer is unable to flash a working u-boot to the eMMC.

Then I compiled U-Boot from scratch and flashed it to the eMMC which broke the Vanilla Debian installation, as Debian uses a similar setup to Arch with boot.scr file and U-Boot from scratch seems to expect a extlinux.conf file. :-\

So in the end I followed and amended this guide https://www.kulesz.me/post/140-debian-de...4-install/ here so that it fits my needs.
Credit goes to user @kuleszdl

Now my Rock64 boots Debian from eMMC and works quite fine, except every time when UART0 is not connected the HDMI output is also not activated. When I attach UART0 my HDMI output comes back. Huh 

I suspect something is missing from my extlinux.conf file
Code:
TIMEOUT 2
PROMPT 1
DEFAULT debian

LABEL debian
MENU LABEL Debian
KERNEL /vmlinuz
INITRD /initrd.img
DEVICETREEDIR /dtbs
APPEND console=tty1 console=ttyS2,1500000 root=LABEL=root rw rootwait
  Reply
#3
Happy to hear my guide helped you getting your rockpro64 running. However, especially regarding the rockpro64 (and pinebook pro) I also had strange behavior with the microSD card using the 5.7 kernel. Did this get better with the current 5.8 kernel?

Regarding the HDMI I really can't tell. You could try to leave out the following line:

Code:
console=ttyS2,1500000

Also, trying a newer uboot version (like the current RC version) might help. Good luck!
  Reply
#4
Yeah 5.8 kernel is problematic as Arch and Manjaro also had issues after update to this Kernel.

Maybe that's causing my issue too but I am not sure. I am using Arm Trusted Firmware v2.3 and U-Boot v2020.07 at the moment.
I made a detailed write-up on github to document how things go.
Rock64 --> https://github.com/as365n4/Debian_on_Rock64
H64B --> https://github.com/as365n4/Debian_on_Pine64_H64B
  Reply
#5
Upgraded to U-Boot v2020.10rc4 and removed console-ttyS2,1500000 from extlinux.conf but still no HDMI video when UART0 is not connected.
Will try again when U-Boot v2020.10 becomes available, also worth noting USB3 is not recognised. I think the dtb-file which comes with u-boot might be the culprit.

Edit:
It turns out that the dtb-file provided by U-Boot is incomplete or they turnoff HDMI output.
As a workaround one can extract a working dtb-file from ArchLinuxARM-aarch64-latest.tar.gz provided by https://archlinuxarm.org/platforms/armv8...hip/rock64 with the added benefit of USB3 fully working, downside is NO HDMI-Audio and the screen flickers a lot when any Desktop Environment is running, in Terminal it is just fine.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Armbian for Rock64 pineadmin 33 26,318 Yesterday, 01:40 PM
Last Post: Rocklobster
  openwrt for the rock64 wilsonYan 17 7,624 09-22-2021, 06:38 PM
Last Post: wilsonYan
  DietPi OS for ROCK64 MichaIng 19 5,204 09-17-2021, 02:38 PM
Last Post: MichaIng
  slarm64 (unofficial slackware) Rock64 RK3328 (aarch64) mara 117 76,623 09-10-2021, 03:01 PM
Last Post: mara
  rock64-debian-mrfixit-190531.img.xz : missing /usr/lib/dri/rockchip_dri.so popi 5 660 08-12-2021, 04:55 AM
Last Post: igorp
  Centos 8 Stream on Rock64 ayoungdukie 1 646 06-07-2021, 11:50 AM
Last Post: zer0sig
  Talos on ROCK64 cjyar 2 751 06-04-2021, 11:50 AM
Last Post: cjyar
  CentOS 7 for Rock64 pineadmin 3 3,795 05-30-2021, 08:20 AM
Last Post: ayoungdukie
  Rock64 CRUX-ARM (aarch64) mara 0 503 05-27-2021, 02:22 PM
Last Post: mara
  RETRO-GAMING: UPDATED RELEASE OF RECALBOX FOR THE ROCK64 Mrfixit2001 32 28,106 05-22-2021, 07:01 AM
Last Post: fartadeadrian

Forum Jump:


Users browsing this thread: 1 Guest(s)