Darktable - characters are square
#1
Love my Pinebook, setting it up with my favourite apps, then ran into a problem with Darktable. It appears to need a font that's missing, because all of the characters are little squares. I ran sudo fc-cache -vf, but this did not help. I wonder if anyone else has ran into this, and if so, what's the solution?
  Reply
#2
(08-30-2020, 06:08 PM)PaulQ Wrote: Love my Pinebook, setting it up with my favourite apps, then ran into a problem with Darktable. It appears to need a font that's missing, because all of the characters are little squares. I ran sudo fc-cache -vf, but this did not help. I wonder if anyone else has ran into this, and if so, what's the solution?

I am sorry, I do not have a solution for you, but as a Darktable fan myself...how did you install it, did you compile yourself?   Last time I tried the git package off AUR it failed even after editing the build script for aarch64.  At the time I did not investigate the failure further (I do not plan on serious RAW processing on the PBP anyway) and just put on RAWTherapee.

I know in 3 they changed the way fonts are handled...and it is now editable in the CSS theme stylesheet usr/share/darktable/themes/darktable.css  ...you might want to poke around in there after making a backup (this is by memory...so sorry if wrong).  there should be font family and font size settings.
  Reply
#3
(08-31-2020, 12:35 PM)gabeeg Wrote: I am sorry, I do not have a solution for you, but as a Darktable fan myself...how did you install it, did you compile yourself?  
I installed it with snapd. It worked well except for this font thing. I'm going to look at that file and see if there's missing fonts I need to install. Here's a screenshot of how it looks on my system.
.png   Screenshot_20200830_192508.png (Size: 38.98 KB / Downloads: 128)
  Reply
#4
(08-31-2020, 02:23 PM)PaulQ Wrote:
(08-31-2020, 12:35 PM)gabeeg Wrote: I am sorry, I do not have a solution for you, but as a Darktable fan myself...how did you install it, did you compile yourself?  
I installed it with snapd. It worked well except for this font thing. I'm going to look at that file and see if there's missing fonts I need to install. Here's a screenshot of how it looks on my system.
Paul,

Snaps are weird. They package their dependencies in isolation from the hosting system, but this means they can also suffer in isolation from some shared resources. This is commonly identified in GTK+ themes, etc. Usually, to match a desktop look and feel, the snap for a desktop theme must also be installed, that matches the one in /usr/share/themes, or wherever.

I suspect that the problem lies here. It's just not normal, that your UI font - set in an appearance control panel, is not picked up by the snap.

Either the snap is somehow set for a different locale/codepage - which is unlikely, or that the Darktable snap may need the fonts installed as additional snap packages themselves. It's worth looking for a solution here, because in other messages, you have already installed a huge number of typeface families, on many paths for fonts.

This is a topic probably best answered on https://forum.snapcraft.io/, tho' I've had mixed results with closing issues in that forum before - it's where the expertise will best be shared, and the findings of earlier users is searchable.

I hope this sets you along a helpful path for resolution. I look forward to your results.

Best,
— Jeremiah Cornelius
"Be the first person not to do some­thing, that no one has thought of not doing before’’
— Brian Eno, "Oblique Strategies"
  Reply
#5
(09-01-2020, 08:46 AM)Jeremiah Cornelius Wrote: I suspect that the problem lies here. It's just not normal, that your UI font - set in an appearance control panel, is not picked up by the snap.

Either the snap is somehow set for a different locale/codepage - which is unlikely, or that the Darktable snap may need the fonts installed as additional snap packages themselves. It's worth looking for a solution here, because in other messages, you have already installed a huge number of typeface families, on many paths for fonts.

This is a topic probably best answered on https://forum.snapcraft.io/, tho' I've had mixed results with closing issues in that forum before - it's where the expertise will best be shared, and the findings of earlier users is searchable.

I hope this sets you along a helpful path for resolution. I look forward to your results.

Best,
Thanks for the input, I'll try that. The only thing that makes me think maybe something's misconfigured with my system is the fact that, when I open a LibreOffice app, the font names do not show up in the list unless I highlight them. Is this normal behaviour for the Pinebook Pro? I have a picture of this issue here: https://cloud.pquirk.com/index.php/s/si6aSQR26SwYXBQ
  Reply
#6
(09-01-2020, 02:13 PM)PaulQ Wrote:
(09-01-2020, 08:46 AM)Jeremiah Cornelius Wrote: I suspect that the problem lies here. It's just not normal, that your UI font - set in an appearance control panel, is not picked up by the snap.

Either the snap is somehow set for a different locale/codepage - which is unlikely, or that the Darktable snap may need the fonts installed as additional snap packages themselves. It's worth looking for a solution here, because in other messages, you have already installed a huge number of typeface families, on many paths for fonts.

This is a topic probably best answered on https://forum.snapcraft.io/, tho' I've had mixed results with closing issues in that forum before - it's where the expertise will best be shared, and the findings of earlier users is searchable.

I hope this sets you along a helpful path for resolution. I look forward to your results.

Best,
Thanks for the input, I'll try that. The only thing that makes me think maybe something's misconfigured with my system is the fact that, when I open a LibreOffice app, the font names do not show up in the list unless I highlight them. Is this normal behaviour for the Pinebook Pro? I have a picture of this issue here: https://cloud.pquirk.com/index.php/s/si6aSQR26SwYXBQ

I had that issue as well in Libreoffice, if you go to tools/options/view and deselect "show preview of fonts" the font list shows up normally...but without preview of course.   There is probably a color setting somewhere that will darken the background of the preview font list....but as usual...I have not looked into it yet (just need to get work done Smile ).  
  Reply
#7
(09-01-2020, 05:52 PM)gabeeg Wrote:
(09-01-2020, 02:13 PM)PaulQ Wrote: Thanks for the input, I'll try that. The only thing that makes me think maybe something's misconfigured with my system is the fact that, when I open a LibreOffice app, the font names do not show up in the list unless I highlight them. Is this normal behaviour for the Pinebook Pro? I have a picture of this issue here: https://cloud.pquirk.com/index.php/s/si6aSQR26SwYXBQ

I had that issue as well in Libreoffice, if you go to tools/options/view and deselect "show preview of fonts" the font list shows up normally...but without preview of course.   There is probably a color setting somewhere that will darken the background of the preview font list....but as usual...I have not looked into it yet (just need to get work done Smile ).  
I think too, like gabeeg seems to confirm, that these are separate issues. Font preview is a mismatch between how OpenOffice wants to render, and the behavior of the chosen theme. Nonetheless, the fonts are there! They render the right shapes when highlighted.

It will help the troubleshooting of the snap, to see thsese as separate issues.

Good luck! I am interested in this outcome.
— Jeremiah Cornelius
"Be the first person not to do some­thing, that no one has thought of not doing before’’
— Brian Eno, "Oblique Strategies"
  Reply
#8
I was able to compile DarkTable from source with my pinebook pro running Manjaro.  Followed these instructions

https://github.com/darktable-org/darktab...or-Manjaro

After building successfully, you need to to run this to get DarkTable displayed with your other apps:
ln -s /opt/darktable/share/applications/darktable.desktop /usr/share/applications/darktable.desktop

It seemed to work well and I was able to edit some photos.  Hope this works for you.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  < and > as characters in C? ab1jx 4 433 01-20-2021, 04:40 AM
Last Post: barray
  Keyboard types random characters erock22 10 2,648 10-30-2020, 08:53 PM
Last Post: erock22

Forum Jump:


Users browsing this thread: 1 Guest(s)