[AUG 2020] PBP Battery Issue (?)
#1
Just got my newly ordered PBP a few days back, and started playing around with it. Overall love it, and I'm looking forward to experimenting with different OSes and configurations.

The charger that came with the box manages to charge the PBP, but it seems to get stuck at ~87% battery no matter how long I leave it charging whilst it's off. I switched to a 5V3A USB 3.0 PD charger and cable, and that pushed it to around ~91% but no further.

Today I got around to downloading Fedora Linux and went through the motion of decompressing and dd'ing onto a SanDisk Class-10 A1 64GB microSD (verified with F3), and I noticed that the action of these two combined whacked my battery from 25% to 12% even while charging at max input of 5V3A (USB 3.0 port). The action of writing/reading 50+GiBs alone shouldn't cause the drain, as F3 testing did that with no discernible impact on battery.

Is this normal? Or is there something wrong with my battery? With both the inability to reach capacity and the massive drain issue. I believe it's still under warranty so I could perhaps ask for a replacement battery.
  Reply
#2
It doesn't sound like a battery problem. It seems to be a known problem to draw more power during use than the charger can deliver. There are other threads here about mitigating that.

If it were me, I would charge it powered off over night and then measure the charging voltage and current.

You don't have an NVMe, do you?
  Reply
#3
(08-30-2020, 12:32 PM)KC9UDX Wrote: It doesn't sound like a battery problem.  It seems to be a known problem to draw more power during use than the charger can deliver.  There are other threads here about mitigating that.

If it were me, I would charge it powered off over night and then measure the charging voltage and current.

You don't have an NVMe, do you?

I usually charge it powered off overnight, but the battery never reaches 100% no matter what. Any advice on how to check it?

I don't have any NVMe SSDs if that's what you're asking.
  Reply
#4
upower -d
  Reply
#5
Hi,

I'm having the same problem. My battery charges up to 92%, but no more. I don't mind having less than 100% capacity, I'm just worried that constatly charging the battery would cause the battery to fail.
I don't think that this is connected to the power useage, as it does not charge above 92% even when sleeping, or when it is just sitting without any application running, network disconnected with minimal backlight.
I don't have an SSD, and I'm using the barrel connector power supply that came with it.

upower -d: https://pastebin.com/F53E7hQ4
  Reply
#6
I wonder what voltage it's at, at 92%. I wonder if 92% was calculated incorrectly.
  Reply
#7
(09-19-2020, 10:43 AM)xmixahlx Wrote: upower -d

xmix, thanks for all the great links in your signature... pbp-tools is helping me learn more about my pbp and getting me closer to being able to HELP. thanks.

i know that your message is intended to help the OP with the charging issue... is there any more information about the issue, or even some keywords that the OP might search on here to learn about it?

thanks for sharing 'upower -d' which i know is the upower daemon command line client... but what does -d do/more info so the OP can grasp the issue?? sorry to bug you, and i most appreciate the links in your siggy.
-----
 pAULIE42o
.  .  .  .   .  . .
/s
  Reply
#8
man is the user's best friend. Except that this is Linux, and Linux isn't all that well documented, unfortunately. `man upower`sort of reveals that "-d" is equivalent to "--dump"

Execution reveals that this displays what various power-related sensors are reporting.

The BSD equivalent of this is envstat, which allows the displaying of, and editing of, environmental sensor properties.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  NVMe SSD and battery life? dieselnutjob 2 214 04-11-2021, 11:07 AM
Last Post: dieselnutjob
Bug [Fixed] Issue with mesa-git (Manjaro ARM Stable Update 2020-09-22)) JasonG-FR 20 5,403 12-12-2020, 05:09 AM
Last Post: mogwai
  New Rockchip RK3588 In PBP Q1 2020 oxoocoffee 8 3,902 11-29-2020, 03:47 AM
Last Post: DrYak
  Pinebook Pro PCIe init issue R32Fanboy 4 1,121 11-05-2020, 09:59 AM
Last Post: vssz
  Boot issue (red light) pineitup 10 2,467 11-01-2020, 11:26 PM
Last Post: wdt
  Boot issue DarrowAtreides 0 496 10-29-2020, 07:23 AM
Last Post: DarrowAtreides
  Issue with screeen tilers - Anyone can recommend? motezart 0 440 10-20-2020, 10:35 AM
Last Post: motezart
  No battery or wifi after poweroff Goin2mars 3 1,217 09-19-2020, 09:58 AM
Last Post: xmixahlx
  Graphics issue on ubuntu bionic das 0 567 08-03-2020, 09:39 AM
Last Post: das
  Install TorBrowser on Pinebook pro 2020 edition BananaPekan 0 795 07-30-2020, 04:52 AM
Last Post: BananaPekan

Forum Jump:


Users browsing this thread: 1 Guest(s)