PBP won't boot (no amber or green LED)
#31
Not sure if this is the correct thread, but...

This started about 4 months ago. Due to my own fault, I discovered that I was trying to flash my PBP w/the wrong image. I aborted the process halfway through. Obviously, bricked my PBP.

I have read every forum post about recovering a 'bricked' PBP. And I have read every link I could find about the rkdeveloptool. I ran into some error messages that are still unanswered on the rkdeveloptool Github page. So I pursued the snap version.

After weeks of false starts & dead ends, I have gotten the snap version of rkdeveloptool to run on another laptop. KDE Neon. I have tried to get rkdeveloptool to install and run on at least four laptops. Always run into some kind of roadblock. Very little up-to-date documentation it seems.

`journalctl -f` confirms that rkdeveloptool is running.

However, `rkdeveloptool ld` always shows: 'no device connected!' after following the steps for shorting the SPI and pressing the reset button. I am using commercial grade tweezers. I am in the IT industry (40+ years), so I have some experience w/troubleshooting. But this seems to be beyond me now.

I am wondering if I have well and truly bricked my PBP.
  Reply
#32
>I discovered that I was trying to flash my PBP w/the wrong image
usually a flash goes on emmc, you have to do something __special__ to flash SPI
Is this the case? (rkdeveloptool is mostly for a bad SPI uboot flash)
Have you tried booting with emmc removed? (or disabled)
--more--
If you flash a distro for a wrong architecture Then the uboot will be BADLY wrong
Since uboot goes in the the 1st few megs, it probably got written (& likely to the emmc)
Since the PBP has a battery somehow it can remember the bad code, even if the media is removed
I have done this, mid last year, a a64 distro
It appeared dead, no matter what I did
By luck, I tried holding pwr a long time (20+ seconds,, press hard, don't let up)
It was back to normal, as if nothing had happened
Since, I have had to do this 7-8 times (obviously the 'bad' uboot MUST be removed first)
  Reply
#33
Thanks for the replies. Very helpful.

I have had the PBP disassembled in parts for a few months, waiting for the time and motivation to work on it again. I am fully versed in x86 troubleshooting, but not so much (not at all) w/ARM.

Would you suggest putting all the parts back together and starting over?

I am not sure what you mean by this: (obviously the 'bad' uboot MUST be removed first)

What steps do you suggest I follow to try to get this PBP functioning again?

Thanks!
  Reply
#34
Put it back together, but leave the bottom cover off. Have the hinge at 90 degrees but be careful, don't break it to get it there.

Disable the eMMC.
Boot to a newly written micro SD card.
Enable the eMMC with power on.
Zero out the first 64k of the eMMC.
Flash a new operating system image with U-boot included, to the eMMC.
  Reply
#35
>I am not sure what you mean by this: (obviously the 'bad' uboot MUST be removed first)
Wherever your failed,, wrong arch write went to,,,likely emmc
(In my case, 10 months ago, I removed SD, but it was still dead, until 20s press)
So, remove or disable (note, instructions are a bit backwards, unless it has been corrected)
(enabled = switch enabled = shorted = emmc has no clock = emmc disabled)
Easier to remove, no confusion possible
Even if it is removed, you may have to do 20s press,, somehow it remembers bad config
(or disconnect battery for ?? _ 1 hour _ ??)
  Reply
#36
At first, success. Then failure.

I pulled the eMMC.
I flashed the latest Manjaro arm image to a microSD card.
PBP booted properly. Success!
I rebooted from the microSD 3 or 4 times successfully and no eMMC chip installed.
I installed all pending updates.
Rebooted at least once after that successfully.
Shut down the PBP.
Made no further changes. microSD card still inserted. eMMC still pulled out.
This morning...nothing. No response from PBP when power button is pressed.
Pressed power button 60+ seconds (very firmly) multiple times. No response.

I reflashed the microSD card.
After inserting the microSD card, with the emmc still removed, no response.
I just unplugged the battery and will let it sit for an extended period of time.

But I am wondering why I was able to reboot from the microSD card multiple times, then nothing.
  Reply
#37
Try a different distro or maybe try a different card
Some people have had problems with later manjaro, a not quite right uboot
(problems reading SD card)
I am using a bsp uboot for s3 (s2ram), most (?all?) manjaro are mainline (uboot)
  Reply
#38
I recommend the "Debian Desktop" image from the wiki. It's less complete but more reliable.

Also, once you have a card that works, don't update it if you can at all avoid it. Call it your rescue boot.
  Reply
#39
>don't update it if you can at all avoid it
I strongly suggest the kernel/uboot update, icon next to time (rock login)
Or mrfixit_update.sh (which is same)
The mrfixit distro is good for another reason than recovery,
it is 64 bit kernel and 32 bit userland, so if you need to run something only armhf.......
--more--
>Pressed power button 60+ seconds (very firmly) multiple times. No response.
After the long (20+s) press, let up, then a regular 1-2s start press,,, a quick tap is not enough
Sometimes it just need a hard power-off (7-8s),, not a hard reset (20s)
So, always, first try a hard power-off, and then if it does not work a hard reset (with good media)
  Reply
#40
New wrinkle. Seem to be making progress.

Since I was attempting to use rkdeveloptool which requires a USB C cable connected to another computer, I was still trying to power my PBP using my Pinephone charging cable. Totally forgot that there was an AC charger for it.

Turns out that when I found the AC charger and plugged it in, I got a consistent 'power source attached' red light above the F2 key. Previously, using the Pinephone charging cable, the red power light was extremely intermittent.


With the AC charger plugged in, my PBP now powers on reliably and boots from the sd card. So that is wonderful.

However, I cannot seem to get the system to recognize my 64GB emmc card.

On the systemboard there is no 'disable/enable' label for the emmc switch, as I have seen referenced in the documentation and forum posts I have read. Instead there is a 'rectangle' printed on the board which the switch can slide over in one of its two positions. I haven't found any videos or documentation that state whether this 'rectangle' indicates enabled or disabled for the emmc.

I have tried booting and sliding the emmc switch from one position to the other, but so far the system does not recognize the emmc.

Any guidance on exactly how to get the emmc to be recognized would be great.

Thanks for the help so far. I am learning a lot!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Pinebook Boot CharlesBunders 12 262 5 hours ago
Last Post: CharlesBunders
  Broken Boot djhnsn 15 384 05-05-2021, 04:14 PM
Last Post: djhnsn
  PIneBook Pro - Boot from SD mcdomx 12 9,532 03-29-2021, 01:13 AM
Last Post: 5825bc9762
  Novice question: Pinebook Pro does boot (does it?) but black screen Gert V. 21 3,349 01-27-2021, 10:48 PM
Last Post: rimaille
  [split] U-Boot with NVMe support, keyboard & display working as400 83 31,014 01-27-2021, 12:48 AM
Last Post: as400
  Sudden Pinebook Pro boot problems ndp 3 820 01-21-2021, 09:51 AM
Last Post: ndp
  How to determine which U-boot I am using edandjeanmcknight@gmail.com 0 360 01-15-2021, 08:25 AM
Last Post: edandjeanmcknight@gmail.com
  U-Boot with direct NVMe boot support for eMMC/SPI Flash pcm720 115 84,853 01-04-2021, 09:57 AM
Last Post: wdt
  Pinebook Pro refuses to boot from eMMC pivic 23 4,299 12-14-2020, 05:08 PM
Last Post: KC9UDX
  Booting - User device selection in U-Boot? Arwen 10 4,041 11-21-2020, 01:22 PM
Last Post: Arwen

Forum Jump:


Users browsing this thread: 1 Guest(s)