PBP won't boot (no amber or green LED)
#21
Quote:@wdt


My pbp is a virgin, the back has NEVER been off, so.... no serial, no disable emmc,, so no maskrom

Logic, I use logic.

Giving advice on techniques you've never tried and problems you've never had to solve doesn't strike me as very wise. If you've never flashed your SPI and used rkdeveloptool, then there is little you can add to this thread. If you want to chitchat that's fine, but I'm looking for something else.

Sorry if that sounds harsh. I don't mean to be impolite. I know that you were only trying to help.

(08-23-2020, 02:24 PM)James Good Wrote: It sometimes is good (or at least reassuring) to know that someone else has experienced a problem similar to what you are having.  On Friday of this past week (August 21, 2020), I turned my PBP on and let it run for a while.  I also connected the charging cable in case some update needed a little more power from the battery.  There were several updates that were completed without any problem (that I know of).  When I turned the PBP off after an hour or two, maybe a bit longer, the power indicator showed a little over 95% charge.  Today when I attempted to turn it on again, the power button seemed to work as it should.  The power LED was first amber then turned to green.  But the screen was still black.  There was no log-in screen at all.  I tried some of the tools that could be used to get into the log-in screen and then to the desktop.  All without any change or success.  In a few minutes, I will print, from another computer, the file referenced and attempt that recovery method.  Thanks to the community for the responses to the newly found problems and for finding at least 'work around' solutions until the problem could be corrected at its source.
James Good

Good luck, @James Good! If you run into issue with those recovery methods, I recommend you make a new thread because your situation is different than mine, as shown by your green power LED.
  Reply
#22
(08-23-2020, 02:00 PM)ian-s-mcb Wrote: Fair enough. I'll stay away from paperclips.
I wouldn't; they are an excellent tool for this in a pinch.  Just be aware of the pitfalls.
  Reply
#23
@ian-s-mcb
>If you want to chitchat that's fine
Do you have a reading comprehension problem?
I have given some advice on troubleshooting and maybe fix your problem,
if you have the wit to see
But apparently I also have to fail before I have credibility.
Sort of the blind leading the blind

In the x86 world, up until recently, if you flashed wrong bios, likely the mb
would end up in trash. If the buttons worked (NOTE PLURAL) , this would not happen here
--edit--
plugging in two running machines, to see if there is a vid:pid
One cable had a distinct difference when inverted, no connection,, and BTW, no vid:pid
(there will be in maskrom, if the cable is right,, there were errors in dmesg)
  Reply
#24
@wdt
> Do you have a reading comprehension problem?

Gee, this is getting ugly. I don't have the energy for trolls. Do what you want with this thread. I'm getting help elsewhere.
  Reply
#25
First, I posted the question/comment in the "Getting Started" section mainly because I still consider myself a very new user to both the PBP and to Manjaro. I think the situation is at least corrected, if not fixed entirely. Additional testing and use of the PBP will tell. What I did to correct the problem was to erase all the data on the micro USB card that was used to install Manjaro after an earlier, similar, problem. After re-flashing the micro USB card, the PBP booted into the initial start menu where I set (reset) the general location and time zone, etc. Again, the problem that prompted me to post the message here has been corrected. It might take several more days of use to see if the problem is fully corrected.
Side note about paper clips: There are times when a paper clip can be very (make that VERY) useful especially after straightening one end (or leg) of the paper clip. Looking at the keyboard and screen of the PBP, on the left side of the keyboard just behind the spot where the power cord is plugged in, there is a small hole. That hole is about the size of the paper clip that has been straightened and can be used to reset the laptop.
  Reply
#26
Sorry for the late reply.

@ian-s-mcb the only way you can check if your in maskrom mode is @clover command or alternatively you can connect the machines as he said. And then open your console on the computer you are connecting your pbp to, switch to root and:

Code:
journalctl -f

You should have new USB device showing up when you enter maskrom mode. Than use a command from @clover  to confirm you're in maskrom mode.
  Reply
#27
(08-27-2020, 11:41 PM)as400 Wrote: Sorry for the late reply.

@ian-s-mcb the only way you can check if your in maskrom mode is @clover command or alternatively you can connect the machines as he said. And then open your console on the computer you are connecting your pbp to, switch to root and:

Code:
journalctl -f

You should have new USB device showing up when you enter maskrom mode. Than use a command from @clover  to confirm you're in maskrom mode.

Thanks for the reply, @as400. You're just the person I hoped to reach.

Now I have two ways to see whether I'm in maskrom mode: 1) the "rkdeveloptool ld" command and 2) journalctl -f. What about the PBP itself? Should it light up the power LED is some way?
  Reply
#28
No it will not light anything. So the only way to confirm it entered maskrom mode is to observe journalctl and then issue “rkdeveloptool ld“ command.
  Reply
#29
lsusb |grep 2207
ID 2207:330c Fuzhou Rockchip Electronics Co., Ltd. USB download gadget
----------------
Not so much for you, specifically, but anyone else following .....
There is a whole other world out there in arm land other than phones ... TV boxes
Lots of times the wrong image is blown on, because the hardware is far from immutable, or mistake
Obviously amlogic or allwinner have different recovery methods than rockchip
To the point
To switch the cable or try another socket, a reboot is NOT needed
(extra typing NOT needed,,, up arrow(once), enter)
All usb ports are supposed to be equal, in real life NOT
Don't use hub
With x86 box, use back ports, on mb
With laptop, try ALL ports
With usbC, at least this example, flip plug
Good thing a reboot is not needed ,, yes?
Of course this may all be in vain, it may not be in maskrom
  Reply
#30
Thank you, @as400. You cleared up my confusion about maskrom mode. I will add that info to the wiki for the next person who falls for this pitfall.

By some divine intervention, I successfully got into maskrom mode! Oh yea!

What I did differently was use a tweezer, instead of a paperclip, and had "journalctl -f" running. The tweezer was easier for me to grip with one hand while I used the other hand to press the reset push-down button. I saw output on my second machine, which was connected to my PBP via USB, that indicated the PBP was detected. And then running the "rkdeveloptool ld" command showed a connected device.

Thank you everyone who posted in this thread!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Pinebook Boot CharlesBunders 12 262 5 hours ago
Last Post: CharlesBunders
  Broken Boot djhnsn 15 384 05-05-2021, 04:14 PM
Last Post: djhnsn
  PIneBook Pro - Boot from SD mcdomx 12 9,532 03-29-2021, 01:13 AM
Last Post: 5825bc9762
  Novice question: Pinebook Pro does boot (does it?) but black screen Gert V. 21 3,349 01-27-2021, 10:48 PM
Last Post: rimaille
  [split] U-Boot with NVMe support, keyboard & display working as400 83 31,014 01-27-2021, 12:48 AM
Last Post: as400
  Sudden Pinebook Pro boot problems ndp 3 820 01-21-2021, 09:51 AM
Last Post: ndp
  How to determine which U-boot I am using edandjeanmcknight@gmail.com 0 360 01-15-2021, 08:25 AM
Last Post: edandjeanmcknight@gmail.com
  U-Boot with direct NVMe boot support for eMMC/SPI Flash pcm720 115 84,853 01-04-2021, 09:57 AM
Last Post: wdt
  Pinebook Pro refuses to boot from eMMC pivic 23 4,299 12-14-2020, 05:08 PM
Last Post: KC9UDX
  Booting - User device selection in U-Boot? Arwen 10 4,041 11-21-2020, 01:22 PM
Last Post: Arwen

Forum Jump:


Users browsing this thread: 1 Guest(s)