Signal on PostmarketOS
#1
Hi


I've looked around, but can't really find anything on it.
Is it possible to get Signal to work on PostmarketOS currently? Looked around, but can't find anything on it really.
#2
I'm currently running a self compiled version of axolotl on Mobian, running only the server portion in the background and the frontend via webbrowser. Calls don't work and I have some weird issues in group chats (messages ariving more than once for others or for me in Signal Desktop). But it's good enough.
I wanted to get it to a state where it can be packaged for other operating systems, but I couldn't find the time yet. But compilation is fairly easy and if I remember correctly well documented.

There has also been some recent activity on libpurple-signald, integrating Signal into Pidgin and others (Chatty uses libpurple as well). But I haven't tried that yet.
#3
Sounds messy to run it via web-browser Smile

Installed Pidgin to try and see how it runs on PostmarketOS. Launches as a regular desktop app so not very well. I guess that was to be expected.
#4
There is some progress with signal:

The signald daemon works on postmarket os. Follow the installation and quickstart guide on the gitlab repository:

https://git.callpipe.com/finn/signald

The registration issue I had was solved:

https://gitlab.com/thefinn93/signald/-/issues/52

There is a pidgin plugin (mentioned in the post above: https://github.com/hoehermann/libpurple-signald). I was able to compile the plugin and I can choose signald in pidgin, but I can not enter my phone number ("username"). In general I have some doubts about the usability of pidgin on the pinephone.


It would be great to have a plugin for chatty. Is there a capable men/woman?

Update:

There is a interesting discussion in the librem5 forum about the implementation of signal into phosh (or was, as there are no new comments since May 25th):

https://forums.puri.sm/t/signal-silence-...5-app/5002
#5
I've started integrating libpurple-signald into chatty. You have to register manually and as of now you cannot start a conversation or participate in group chats. But you can at least answer when someone messages you. I hope I can get it into a usable state, but my time is limited.

https://source.puri.sm/btantau/chatty/-/...le-signald
#6
(08-27-2020, 02:19 PM)Boern Wrote: I've started integrating libpurple-signald into chatty. You have to register manually and as of now you cannot start a conversation or participate in group chats. But you can at least answer when someone messages you. I hope I can get it into a usable state, but my time is limited.

https://source.puri.sm/btantau/chatty/-/...le-signald

Thanks for your efforts! I have issues building your package, which is related to cmake. Not sure where to post my question so I leave it here:

when I run meson build it quits with the following error message (this is the last part from meson-log.txt):

Code:
Found CMake: /usr/bin/cmake (3.17.2)
Extracting basic cmake information
Try CMake generator: auto
None of 'CXX' are defined in the environment, not changing global flags.
None of 'CXXFLAGS' are defined in the environment, not changing global flags.
None of 'LDFLAGS' are defined in the environment, not changing global flags.
None of 'CPPFLAGS' are defined in the environment, not changing global flags.
None of 'CXX_LD' are defined in the environment, not changing global flags.
None of 'FC' are defined in the environment, not changing global flags.
None of 'FFLAGS' are defined in the environment, not changing global flags.
None of 'LDFLAGS' are defined in the environment, not changing global flags.
None of 'FC_LD' are defined in the environment, not changing global flags.
None of 'F_LD' are defined in the environment, not changing global flags.
Called `/usr/bin/cmake --trace-expand --trace-format=json-v1 --no-warn-unused-cli --trace-redirect=cmake_trace.txt .` in /home/nieral/programs/chatty-libpurple-signald/build/meson-private/cmake_libebook-contacts-1.2 -> 0
  -- Module search paths:    ['/', '/opt', '/usr', '/usr/local']
  -- CMake root:             /usr/share/cmake
  -- CMake architectures:    []
  -- CMake lib search paths: ['lib', 'lib32', 'lib64', 'libx32', 'share']
None of 'CMAKE_PREFIX_PATH' are defined in the environment, not changing global flags.
Preliminary CMake check failed. Aborting.
Run-time dependency libebook-contacts-1.2 found: NO (tried pkgconfig and cmake)

meson.build:87:0: ERROR: Dependency "libebook-contacts-1.2" not found, tried pkgconfig and cmake

libebook-contacts-1.2 is installed (as part of evolution) but it is located in /usr/lib and not in the folders cmake is looking by default (see above: -- CMake lib search paths:...).

I tried: export CMAKE_LIBRARY_PATH='usr/lib' to add this folder but it had no effect.
Modifying the cmakelists.txt is a possibilty, but, according to some comments, not advised and I honestly have no idea what to add to this fie.


Any Idea?
#7
You might have to install the libebook-contacts1.2-dev package (I'm not sure about the exact name)? This installs header files and pkg-config files. You must likely be able to run 'pkg-config --cflags libebook-contacts-1.2' and not get an error for your build to succeed.

(Note I haven't built things on PostmarketOS myself, so this is rather general info. Not sure about the specifics.)
#8
Yeah you need to install the -dev package, not just the regular one. The package will be called evolution-dev (no need to specify the version).
#9
(09-01-2020, 03:50 AM)PureTryOut Wrote: Yeah you need to install the -dev package, not just the regular one. The package will be called evolution-dev (no need to specify the version).

I tried but apk won't install the package because of "unsatisfiable constraints" as it seems to break with other installed packages (see the attached file with the output from the apk command). This is something I have repeatedly observed when installing .-dev packages and the reason I stuck compiling stuff as I do not want to try to remove the packages which are conflicting (in this case mesa-dev-20.0.7). Same happend when I tried to install "evolution-data-server-dev" a couple of days ago which contains libebook-contacts too.


Quote:bitnick

You must likely be able to run 'pkg-config --cflags libebook-contacts-1.2' and not get an error for your build to succeed.

I tried that too:

"Package libebook-contacts-1.2 was not found in the pkg-config search path. Perhaps you should add the directory containing 'libebook-contact.pc' to the PKG_CONFIG_PATH environment variable.
Note: I couldn't find 'libebook-contact.pc' on the system with "find -name "libebook-contacts*", so I guess installing the mentioned .-dev package is the only way it will work.


Attached Files
.txt   evol.txt (Size: 2.74 KB / Downloads: 234)


Possibly Related Threads…
Thread Author Replies Views Last Post
  no screen rotation on pinephone pro with postmarketOS + phosh elode 2 702 07-03-2022, 09:13 AM
Last Post: a.h.littorin
  Pinephone Keyboard Utilities on postmarketOS elof 2 922 06-20-2022, 01:33 PM
Last Post: elof
  Best Place To Learn PostmarketOS mw4jet 6 4,180 01-30-2022, 11:57 PM
Last Post: arcanemachine
  axolotl signal client on postmarket os? nieral 2 1,489 10-29-2021, 07:41 AM
Last Post: nieral
  Build signal-cli uby89 2 2,123 07-25-2021, 10:23 AM
Last Post: uby89
  [PostmarketOS with Plasma Mobile] Angelfish adblock + wpa supplicant time out Egolep 0 1,305 03-23-2021, 10:25 AM
Last Post: Egolep
  Pinephone 64 PostMarketOS edition Battery problem Alejandro.SU 9 4,914 12-22-2020, 04:33 PM
Last Post: Alejandro.SU
  Anbox on postmarketos Diego 6 6,021 09-18-2020, 05:01 AM
Last Post: josekar
  Unable to mount root partition PostmarketOS lanawwas 0 1,897 09-06-2020, 07:42 AM
Last Post: lanawwas
  How to update U-Boot for PostmarketOS on the PinePhone and much more! dustfinger 2 3,028 08-21-2020, 10:49 AM
Last Post: bingo600

Forum Jump:


Users browsing this thread: 1 Guest(s)