Unable to mount exFAT file system
#1
When trying to open an exFAT formatted drive in Mobian's file manager an error message pops up saying: unknown filesystem type 'exfat'

I tried installing exfat-fuse and exfat-utils, but still get the error message. Are there some additional things missing that are keeping this from working?
#2
I know it certainly works after installing those two packages and mounting it manually. I can then access its contents using the file manager.
My SD card is mounted that way on fstab.
I am not sure if automounting exfat volumes works.
I think that was the reason I added my SD card to fstab.
#3
(07-22-2020, 01:39 PM)fernando_c_m Wrote: I know it certainly works after installing those two packages and mounting it manually. I can then access its contents using the file manager.
My SD card is mounted that way on fstab.
I am not sure if automounting exfat volumes works.
I think that was the reason I added my SD card to fstab.

Weird. I still get the same error message when trying to mount exFAT filesystems manually from the terminal. I definitely have exfat-fuse and exfat-utils installed at this point. I'm using a CE pinephone with the VCONN switches removed and haven't had any issues mounting FAT32, EXT4, and NTFS (after installing ntfs-3g) formatted SD cards or USB flash drives.
#4
(07-23-2020, 02:44 AM)jyc88 Wrote:
(07-22-2020, 01:39 PM)fernando_c_m Wrote: I know it certainly works after installing those two packages and mounting it manually. I can then access its contents using the file manager.
My SD card is mounted that way on fstab.
I am not sure if automounting exfat volumes works.
I think that was the reason I added my SD card to fstab.

Weird. I still get the same error message when trying to mount exFAT filesystems manually from the terminal. I definitely have exfat-fuse and exfat-utils installed at this point. I'm using a CE pinephone with the VCONN switches removed and haven't had any issues mounting FAT32, EXT4, and NTFS (after installing ntfs-3g) formatted SD cards or USB flash drives.
mount.exfat-fuse /dev/mmcblk0p1 /mnt/sdcard
works in my case...
#5
(07-23-2020, 05:49 AM)fernando_c_m Wrote:
(07-23-2020, 02:44 AM)jyc88 Wrote:
(07-22-2020, 01:39 PM)fernando_c_m Wrote: I know it certainly works after installing those two packages and mounting it manually. I can then access its contents using the file manager.
My SD card is mounted that way on fstab.
I am not sure if automounting exfat volumes works.
I think that was the reason I added my SD card to fstab.

Weird. I still get the same error message when trying to mount exFAT filesystems manually from the terminal. I definitely have exfat-fuse and exfat-utils installed at this point. I'm using a CE pinephone with the VCONN switches removed and haven't had any issues mounting FAT32, EXT4, and NTFS (after installing ntfs-3g) formatted SD cards or USB flash drives.
mount.exfat-fuse /dev/mmcblk0p1 /mnt/sdcard
works in my case...

Looks like I had just forgotten the ".exfat-fuse" when manually mounting. So I am able to mount it from the terminal now. Thanks!


Possibly Related Threads…
Thread Author Replies Views Last Post
  Programs unable to open display via sudo or pkexec (linssid not working) Zebulon Walton 3 280 07-24-2021, 06:11 PM
Last Post: Zebulon Walton
  Unable to play videos ("bitstream error") pietenpol 1 294 06-14-2021, 07:58 AM
Last Post: Gribouille
  can't get file transfer working. Help, please! quixote 25 2,491 05-28-2021, 06:53 PM
Last Post: Rainer
  Unable to turn off auto brightness at times motox6 0 303 05-05-2021, 07:56 PM
Last Post: motox6
  Installing Mobian --> "Resizing file system" forever Anna 9 2,292 05-01-2021, 07:51 PM
Last Post: jonnicholson
  "Unable to download updates: The following packages have unmet dependencies:" bitnick 13 3,363 04-23-2021, 09:45 PM
Last Post: ryo
  File transfer from Linux Desktop and PinePhone livanti21 18 13,145 03-09-2021, 08:15 PM
Last Post: MtnSk8
  Mobian Development Environment - system requirements mgronbak666 1 632 02-12-2021, 07:27 AM
Last Post: cybercow
  USB file transfer question DarkManiels 4 1,337 12-11-2020, 06:18 PM
Last Post: Zebulon Walton
  Unable to send SMS on US Mobile GSM (T-Mobile MVNO) NoahAndrews 17 6,888 12-06-2020, 07:03 PM
Last Post: NoahAndrews

Forum Jump:


Users browsing this thread: 1 Guest(s)