Alarm clock doesn’t work
#1
I don’t know where else to post this, but the alarm clock function in the clock app does not work. I updated as recently as yesterday evening. Just putting this out there again, if there is a better place for trivial bug reports please direct me there. Thanks again for all the amazing work and rapid progress to this point.
  Reply
#2
(07-20-2020, 12:45 PM)Captain1ndustry Wrote: I don’t know where else to post this, but the alarm clock function in the clock app does not work. I updated as recently as yesterday evening. Just putting this out there again, if there is a better place for trivial bug reports please direct me there. Thanks again for all the amazing work and rapid progress to this point.

Yes I noticed the same, not sure where to file a bug report myself.
For the interm as a work around I have been using a cronjob and music123

apt install music123
crontab -e

and add something like
0 7 * * * /usr/local/bin/alarm.sh

and in alarm.sh have something like
Code:
#!/bin/bash
Code:
for i in `seq 1 10`; do
Code:
    music123 /usr/share/sounds/freedesktop/stereo/alarm-clock-elapsed.oga
Code:
done
which plays the alarm clock sound 10 times in a row

The unfortunate thing is that doing so will be quite difficult to turn off and it is kindof quiet. You could modify the script to fix this a number of ways I am certain. My initial thought would be check for a file, but making a file takes more time than the thing plays for. Maybe an adaption to check if the flashlight app is running... then you could start the flashlight app to turn it off.
  Reply
#3
(07-20-2020, 12:45 PM)Captain1ndustry Wrote: but the alarm clock function in the clock app does not work.
Did you activate it after you programmed it?

Cause I tested it and it's working at my place.
  Reply
#4
(07-22-2020, 03:00 PM)chris_02 Wrote:
(07-20-2020, 12:45 PM)Captain1ndustry Wrote: but the alarm clock function in the clock app does not work.
Did you activate it after you programmed it?

Cause I tested it and it's working at my place.

Also just tested and it worked fine. (A couple of weeks ago I tested and it did not work but seems that is history.)
  • ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Arch (5.13 kernel, Openbox desktop) for general purpose daily PC.
  • PinePhone BraveHeart now v1.2b 3/32Gb daily driver, dual boot via p-boot with Mobian/f2fs/Phosh on eMMC, Arch/ext4/Phosh on SDcard
  • PinePhone v1.2a 2G/16Gb that needs USB board replaced
  Reply
#5
Make sure your volume is loud enough.
  Reply
#6
The alarm doesn't wake the phone for me, if I set the alarm for more than the sleep time, it only goes off when I wake the phone manually.
  Reply
#7
(07-24-2020, 09:33 PM)scott_VYuCAbn3k1NFK Wrote: The alarm doesn't wake the phone for me, if I set the alarm for more than the sleep time, it only goes off when I wake the phone manually.

I have been thinking about this. I think the "Clock app" will need to be modified to set a timer interrupt or similar so as to wake the phone in time to sound the alarm.

(10-21-2020, 03:43 AM)Kawayuppie Wrote:
(07-24-2020, 09:33 PM)scott_VYuCAbn3k1NFK Wrote: The alarm doesn't wake the phone for me, if I set the alarm for more than the sleep time, it only goes off when I wake the phone manually.

I have been thinking about this. I think the "Clock app" will need to be modified to set a timer interrupt or similar so as to wake the phone in time to sound the alarm.

Experimenting with linux RTC ... will see if this works.
  Reply
#8
(10-21-2020, 03:43 AM)Kawayuppie Wrote:
(07-24-2020, 09:33 PM)scott_VYuCAbn3k1NFK Wrote: The alarm doesn't wake the phone for me, if I set the alarm for more than the sleep time, it only goes off when I wake the phone manually.

I have been thinking about this. I think the "Clock app" will need to be modified to set a timer interrupt or similar so as to wake the phone in time to sound the alarm.

Preliminary testing using "rtcwake" does work a treat.
To test, set the alarm for some time, say a couple hours later, to be sure the pinephone is nicely asleep when the alarm is supposed to sound.
The set "rtcwake";


Code:
sudo rtcwake -m no -l -t "$(date -d 'today 16:00:00' '+%s')"

where  -m no means dont suspend/sleep now, -l means local time, -t the time and date string when to wake up.

Note: kernel time needs to be same as local time, in the above example, or you will need to work out the difference.
Check this with;

Code:
sudo hwclock -r


Next steps will be to see if it will be possible to change the clock code or write a new clock program.  Will be interesting how to handle multiple alarms.
  Reply
#9
I wrote an alarm clock app which wakes the device through systemd timers setting the RTC device clock: https://gitlab.gnome.org/kailueke/wake-mobile

Mobian packages are linked in the README
  Reply
#10
Great work on this, working timer and alarms in the Clocks app would be very useful. Thanks!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  How does calls work in debian? temp0rary 4 546 05-31-2021, 10:44 AM
Last Post: temp0rary
  alarms do not seem to work motox6 2 450 05-06-2021, 11:08 AM
Last Post: motox6
  Making nextcloud sync work on the phone 3x5co 4 1,733 03-27-2021, 03:49 PM
Last Post: MarkF
  Chromium doesn't seem to recognize that I'm on a mobile device 3x5co 2 546 02-05-2021, 11:13 PM
Last Post: 3x5co
  USB-C Power Delivery does not work nazarii.kretovych 2 1,213 10-05-2020, 09:15 AM
Last Post: wibble
  Ringer and Alarm Tones discogribbs 3 2,235 09-28-2020, 03:15 AM
Last Post: alpopa
  Watch out for your system clock , when upgrading. bingo600 4 1,804 08-21-2020, 03:04 PM
Last Post: bcnaz
  apt-get update hanging twice (work-around included) motox6 11 5,419 08-08-2020, 04:20 PM
Last Post: jed
  Phone doesn't boot after latest kernel update Boern 12 4,846 08-06-2020, 11:34 AM
Last Post: Boern
  Incoming call does not work firefox-58 19 7,573 08-03-2020, 05:03 AM
Last Post: dancingqueen74

Forum Jump:


Users browsing this thread: 1 Guest(s)