GloDroid (Android-13)
#11
Thank you for the info, but for me it does not work at all: Exec format error...
Any idea what the issue is?

EDIT:
I think the problem is that I am trying this from the PBP. I tried to install adb and android-tools from the repo, but there is a version difference between libprotobuf-lite.so and android-tools. I did not find a solution yet.
Problem is I can't run an sh executable on Windows 10 right? Big Grin
  Reply
#12
(08-01-2020, 04:05 AM)cefre00 Wrote: I think the problem is that I am trying this from the PBP. I tried to install adb and android-tools from the repo, but there is a version difference between libprotobuf-lite.so and android-tools. I did not find a solution yet.

Sounds like you're running into this issue when installing adb. Maybe a different distro might help but I'm running x86 linux so can't really advise.

Have you tried flashing the pre-built image for 0.2.0 instead?
  Reply
#13
I installed the v 0.3 to the sdcard, but something weird happens, the screen flikers a lot, and some colos leaves traces on the display. I think hw acceleration is not enabled... im on the ubports edition pinephone.
  Reply
#14
(08-01-2020, 08:57 AM)paju1986 Wrote: I installed the v 0.3 to the sdcard, but something weird happens, the screen flikers a lot, and some colos leaves traces on the display.

Yes, this issue has been reported on github. Setting a dark theme and increasing screen brightness seems to help.
  Reply
#15
(08-01-2020, 06:53 AM)nas Wrote: Maybe a different distro might help

I concur. Try using a spin of Debian, if you can:

Code:
apt install adb fastboot

Debian has always worked perfectly for me when using these tools - hopefully they work for you on ARM64.
  Reply
#16
(08-01-2020, 06:53 AM)nas Wrote:
(08-01-2020, 04:05 AM)cefre00 Wrote: I think the problem is that I am trying this from the PBP. I tried to install adb and android-tools from the repo, but there is a version difference between libprotobuf-lite.so and android-tools. I did not find a solution yet.

Sounds like you're running into this issue when installing adb. Maybe a different distro might help but I'm running x86 linux so can't really advise.

Have you tried flashing the pre-built image for 0.2.0 instead?

Yes, and that works from the SD card! Smile
Can it be updated OTA to 0.3?
  Reply
#17
(08-01-2020, 01:08 PM)cefre00 Wrote: Yes, and that works from the SD card! Smile
Can it be updated OTA to 0.3?

No ota update but you can try generating an image file with this script. Save it to where you extracted 0.3.0 and run it - if it completes successfully, flash the resultant sdcard.img file to your card and see if it boots
  Reply
#18
(07-28-2020, 06:22 PM)Hyz Wrote: Has anyone found a workaround for bug 39? https://github.com/GloDroid/glodroid_manifest/issues/39

This thread on usb tethering appears to be a related issue.   
  Reply
#19
(08-01-2020, 02:56 PM)nas Wrote:
(08-01-2020, 01:08 PM)cefre00 Wrote: Yes, and that works from the SD card! Smile
Can it be updated OTA to 0.3?

No ota update but you can try generating an image file with this script. Save it to where you extracted 0.3.0 and run it - if it completes successfully, flash the resultant sdcard.img file to your card and see if it boots

I am writing now from glodroid 0.3 . Smile Thanks for the advice, the sricpt was great, easy stuff and after a restart the OS is just awesome. On phosh you don't get to see this phone so smooth. I hope this one gets further developed.

I did not think I would run android on the pinephone, but until a Linux distro is mature enough I might just do so. Smile

EDIT:
Amazing, how well it runs. As soon as it has telephony it goes to the eMMC right away.
  Reply
#20
(08-01-2020, 02:56 PM)nas Wrote:
(08-01-2020, 01:08 PM)cefre00 Wrote: Yes, and that works from the SD card! Smile
Can it be updated OTA to 0.3?

No ota update but you can try generating an image file with this script. Save it to where you extracted 0.3.0 and run it - if it completes successfully, flash the resultant sdcard.img file to your card and see if it boots
Thank you for the link to the script!

However, I'm afraid it doesn't complete successfully: in the end, I get an error message saying that it can't find the file "vbmeta.img", and indeed it doesn't appear to exist anywhere. Where do I find it, or how do I create it?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  GloDroid (Android-14) GaryM 1 619 04-17-2024, 08:39 AM
Last Post: GaryM
Tongue Android Auto on Pinephone via Waydroid: a pipe dream? slondr 1 2,268 11-06-2022, 01:46 PM
Last Post: wibble
  difference between android and linux? vanja 3 2,362 09-16-2022, 07:43 PM
Last Post: TRS-80
  Android and Google Play Store on a PinePhone? Solra Bizna 22 42,587 11-01-2021, 07:11 AM
Last Post: digitalmouse
  Easiest way to use Android applications on Pinephone esud 4 9,122 06-21-2021, 04:52 AM
Last Post: vanja
  Remote connection from Linux Mobile to unrooted Android? (surely very useful?!) 4w7gvrvsjcyvd 0 1,926 01-30-2021, 06:48 PM
Last Post: 4w7gvrvsjcyvd
  pine phone came with android? andrewiassur 1 3,473 04-11-2020, 02:06 PM
Last Post: fire219

Forum Jump:


Users browsing this thread: 1 Guest(s)