Non-booting SD
I am trying to copy the Manjaro KDE 20.06 image to an SD as step one in creating a 128G eMMC. Have been doing so for over a week.

I was able to create an XFCE SD and eMMC with no problem. Both worked fine. I've tried all the methods I have seen on the forums, but always end up with a non-booting KDE SD and a perpetual green led. Well, all methods but the installer script at That requires binfmt-qemu-static, which is not in the Arch repository.

So I'm at a standstill for the time being. My PBP is still working fine with the original KDE 64G eMMC or the XFCE 128G eMMC that I made. The XFCE UI is just not what I need.

I'm getting ready to see if a PBP will work as a frisbee. But, until I get to that point, has anyone any ideas that might prevent a flying PBP (not really, I quite like it)?


Big edit.

All is well. Boot problem resolved. It was a matter of paying attention.

Today I created a new KDE image for my SD using the Raspberry Pi Imager on my Mac, which works great with no dd, etc., although dd works fine, too. I then tried to boot it and got the perpetual green led again. OK, only thing left was to turn off eMMC. Did that, and poof! Booted as it should. That's an important step, because the machine remembers last boot.

I powered down, switched eMMC back on, and rebooted. Worked fine because the machine remembered it booted last from SD.

Next, I downloaded another image and check file, did all the check and prep, and wrote it with dd to the eMMC. Powered down, removed SD (getting smarter), and restarted. Perfect. Running KDE from my new 128G eMMC.

This was not wasted effort. I learned a lot from the process.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Total Noob. Need help booting from SD Mattchublean 16 904 08-26-2021, 12:06 AM
Last Post: wdt
  Manjaro i3 Edition not booting mtndew 0 162 08-23-2021, 06:21 PM
Last Post: mtndew
Video Problem Booting from SD card ezryder324r 0 344 05-19-2021, 02:42 PM
Last Post: ezryder324r
  Forgot my Pinebook password. Booting from MIcroSD doesn't work. ksfoodforest 0 549 01-30-2021, 11:08 AM
Last Post: ksfoodforest
Wink Booting Windows on bare-metal rk3399 SBC (no linux involved) strongtz 7 3,141 01-24-2021, 01:33 PM
Last Post: cefre00
  Booting to sdcard stopped working after emmc flash techiedog 3 1,431 12-31-2020, 06:30 PM
Last Post: Anarethos
  Booting - User device selection in U-Boot? Arwen 10 5,220 11-21-2020, 01:22 PM
Last Post: Arwen
Lightbulb Booting from SD card CalmMopey 8 2,529 09-17-2020, 08:23 AM
Last Post: wdt
  Booting OS from SD card: consistency issue pivic 8 4,339 07-21-2020, 09:46 AM
Last Post: pivic
  Manjaro not booting sinistermrcream 29 14,193 06-19-2020, 11:09 PM
Last Post: p3pp3r

Forum Jump:

Users browsing this thread: 1 Guest(s)