Unable to send SMS on US Mobile GSM (T-Mobile MVNO)
#11
I have just briefly had a look through the code.
What appears to happen is that chatty has no SMS protocol enabled at that time making the "+" button greyed out.
Presumably chatty does not "find" the modem on startup and therefore has no SMS support.

Could you try doing the following:
After boot wait a little bit to make sure the modem is online and connected to your carrier (I don't think you necessarily need to be connected - I could be wrong though).
then run "killall chatty" a few times until you get "no process found" and then start chatty again from the UI.

I have the suspicion that the "protocol detection" is only run once on startup and maybe it is during a time (since a daemon is autostarted)
where the modem is not yet "fully up". Obviously when you receive a new SMS chatty will then know that SMS work (if that makes sense) ;)
  Reply
#12
(07-09-2020, 01:04 AM)devrtz Wrote: I have just briefly had a look through the code.
What appears to happen is that chatty has no SMS protocol enabled at that time making the "+" button greyed out.
Presumably chatty does not "find" the modem on startup and therefore has no SMS support.

I have the suspicion that the "protocol detection" is only run once on startup and maybe it is during a time (since a daemon is autostarted)
where the modem is not yet "fully up". Obviously when you receive a new SMS chatty will then know that SMS work (if that makes sense) Wink

Whoa !

My phone was sitting for 5 or 6 hours and apparently did an auto-update.

The signal strength icon has completely disappeared,   no modem function at all now.
I cannot even make a phone call...

When I restart the phone,  only sometimes the signal icon shows for an instant, but does not populate with a signal
  THEN  when I sign-in there is no signal indicator at all.

* * * * * * * * * * * * * * * *

I have just installed the July 09 nightly release,

I have a working modem again,  but still have the problem of text App/chatty (not initializing )

  I tried leaving an un-opened text in the App and re-starting the phone but that did not help.

   >  Though if I receive a text while my Brave Heart is turned off,  it will activate/initialize when I turn it on.
  Reply
#13
I have the suspicion that the "protocol detection" is only run once on startup and maybe it is during a time (since a daemon is autostarted)
where the modem is not yet "fully up". Obviously when you receive a new SMS chatty will then know that SMS work (if that makes sense) Wink


I have no idea when that was  "Changed"  but it would seem to be fairly recent, as maybe just a few weeks back...

   That did just "work"  in the past.

Thanks for your keen observations,  could this possibly only affect the version 1.1 motherboards ? (Brave Heart )

  >   I would think more people would be complaining if it affected everyone.

BC
  Reply
#14
Must have been when I updated the package to the latest chatty release.

And I don't think this would be limited to BH users (I could be wrong though!)

Did you try killing the process and starting chatty fresh as I described in the last post?
For this to work your modem needs to be detected though (the cellular icon should appear,
but does not necessarily have to have a connection I think)

Edit: If we can't figure out what the problem is, we should open an issue here

Edit^2: Just come across this issue myself and confirmed it can be "solved" by killing and restarting chatty.
Have opened an issue
  Reply
#15
Updating to the newest purple-mm-sms package should fix your issue!
It now watches for changes in ModemManager.

Btw we kind of hijacked the thread a bit.
Next time this should be discussed in a different thread.
Maybe the mods can move it?
  Reply
#16
I was away from service over the weekend...

  I Just made a copy of the July 13 nightly.... and flashed it.
I still need to initialize the text app using my second phone.  (?)

IT works just fine once it is initialized.  ( until the next boot )

I am wondering how many others have not been able to use their text ?
    ( How many have a second phone to initialize their text App ? )

BC
  Reply
#17
I am testing US Mobile service and also unable to send SMS



Running mobian, nightly from yesterday, but image from week ago had the same problem



In journalctl output I see


Code:
...ModemManager[1615]: transaction 0xd aborted, but message is not abortable
...ModemManager[1615]: [/dev/cdc-wdm0] No transaction matched in received message




Same issue regardless of using Chatty vs modem-manager-gui
  Reply
#18
(07-18-2020, 05:49 PM)radarman Wrote: I am testing US Mobile service and also unable to send SMS



Running mobian, nightly from yesterday, but image from week ago had the same problem



In journalctl output I see


Code:
...ModemManager[1615]: transaction 0xd aborted, but message is not abortable
...ModemManager[1615]: [/dev/cdc-wdm0] No transaction matched in received message




Same issue regardless of using Chatty vs modem-manager-gui

That's really interesting, I wonder if our issue was specific to US Mobile somehow.

At any rate, I just re-flashed my phone using the new FDE installer, and sending SMS messages from chatty works fine now!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Unable to turn off auto brightness at times motox6 0 93 05-05-2021, 07:56 PM
Last Post: motox6
  "Unable to download updates: The following packages have unmet dependencies:" bitnick 13 2,510 04-23-2021, 09:45 PM
Last Post: ryo
  lightdm-mobile-greeter mobian dawg161 0 308 03-08-2021, 08:59 PM
Last Post: dawg161
  Sylpheed, Nextcloud Screensize not for Mobile Franze_m 6 474 02-25-2021, 09:55 AM
Last Post: C0ffeeFreak
  Chromium doesn't seem to recognize that I'm on a mobile device 3x5co 2 380 02-05-2021, 11:13 PM
Last Post: 3x5co
  Howto - automatically recover your modem and mobile data after deep sleep as400 23 4,939 01-05-2021, 08:14 AM
Last Post: scholbert
  Volte and T-mobile danielrs80 1 589 01-04-2021, 01:21 AM
Last Post: dcinoz
  Mobile network is not working tlo 11 4,594 12-15-2020, 02:49 PM
Last Post: jim.uren@gmail.com
Question Plasma Mobile on Mobian? dancingqueen74 22 9,308 12-01-2020, 06:29 PM
Last Post: deedend
  IPv6 and routing mobile data puffchumpy 3 952 11-11-2020, 01:37 PM
Last Post: dukla2000

Forum Jump:


Users browsing this thread: 1 Guest(s)