Unable to send SMS on US Mobile GSM (T-Mobile MVNO)
#11
I have just briefly had a look through the code.
What appears to happen is that chatty has no SMS protocol enabled at that time making the "+" button greyed out.
Presumably chatty does not "find" the modem on startup and therefore has no SMS support.

Could you try doing the following:
After boot wait a little bit to make sure the modem is online and connected to your carrier (I don't think you necessarily need to be connected - I could be wrong though).
then run "killall chatty" a few times until you get "no process found" and then start chatty again from the UI.

I have the suspicion that the "protocol detection" is only run once on startup and maybe it is during a time (since a daemon is autostarted)
where the modem is not yet "fully up". Obviously when you receive a new SMS chatty will then know that SMS work (if that makes sense) ;)
#12
(07-09-2020, 01:04 AM)devrtz Wrote: I have just briefly had a look through the code.
What appears to happen is that chatty has no SMS protocol enabled at that time making the "+" button greyed out.
Presumably chatty does not "find" the modem on startup and therefore has no SMS support.

I have the suspicion that the "protocol detection" is only run once on startup and maybe it is during a time (since a daemon is autostarted)
where the modem is not yet "fully up". Obviously when you receive a new SMS chatty will then know that SMS work (if that makes sense) Wink

Whoa !

My phone was sitting for 5 or 6 hours and apparently did an auto-update.

The signal strength icon has completely disappeared,   no modem function at all now.
I cannot even make a phone call...

When I restart the phone,  only sometimes the signal icon shows for an instant, but does not populate with a signal
  THEN  when I sign-in there is no signal indicator at all.

* * * * * * * * * * * * * * * *

I have just installed the July 09 nightly release,

I have a working modem again,  but still have the problem of text App/chatty (not initializing )

  I tried leaving an un-opened text in the App and re-starting the phone but that did not help.

   >  Though if I receive a text while my Brave Heart is turned off,  it will activate/initialize when I turn it on.
#13
I have the suspicion that the "protocol detection" is only run once on startup and maybe it is during a time (since a daemon is autostarted)
where the modem is not yet "fully up". Obviously when you receive a new SMS chatty will then know that SMS work (if that makes sense) Wink


I have no idea when that was  "Changed"  but it would seem to be fairly recent, as maybe just a few weeks back...

   That did just "work"  in the past.

Thanks for your keen observations,  could this possibly only affect the version 1.1 motherboards ? (Brave Heart )

  >   I would think more people would be complaining if it affected everyone.

BC
#14
Must have been when I updated the package to the latest chatty release.

And I don't think this would be limited to BH users (I could be wrong though!)

Did you try killing the process and starting chatty fresh as I described in the last post?
For this to work your modem needs to be detected though (the cellular icon should appear,
but does not necessarily have to have a connection I think)

Edit: If we can't figure out what the problem is, we should open an issue here

Edit^2: Just come across this issue myself and confirmed it can be "solved" by killing and restarting chatty.
Have opened an issue
#15
Updating to the newest purple-mm-sms package should fix your issue!
It now watches for changes in ModemManager.

Btw we kind of hijacked the thread a bit.
Next time this should be discussed in a different thread.
Maybe the mods can move it?
#16
I was away from service over the weekend...

  I Just made a copy of the July 13 nightly.... and flashed it.
I still need to initialize the text app using my second phone.  (?)

IT works just fine once it is initialized.  ( until the next boot )

I am wondering how many others have not been able to use their text ?
    ( How many have a second phone to initialize their text App ? )

BC
#17
I am testing US Mobile service and also unable to send SMS



Running mobian, nightly from yesterday, but image from week ago had the same problem



In journalctl output I see


Code:
...ModemManager[1615]: transaction 0xd aborted, but message is not abortable
...ModemManager[1615]: [/dev/cdc-wdm0] No transaction matched in received message




Same issue regardless of using Chatty vs modem-manager-gui
#18
(07-18-2020, 05:49 PM)radarman Wrote: I am testing US Mobile service and also unable to send SMS



Running mobian, nightly from yesterday, but image from week ago had the same problem



In journalctl output I see


Code:
...ModemManager[1615]: transaction 0xd aborted, but message is not abortable
...ModemManager[1615]: [/dev/cdc-wdm0] No transaction matched in received message




Same issue regardless of using Chatty vs modem-manager-gui

That's really interesting, I wonder if our issue was specific to US Mobile somehow.

At any rate, I just re-flashed my phone using the new FDE installer, and sending SMS messages from chatty works fine now!


Possibly Related Threads…
Thread Author Replies Views Last Post
  Amberol Mobile Music player(flatpak) biketool 0 158 06-19-2022, 07:16 AM
Last Post: biketool
  DNS Problems with Mobile Data arno_nuehm 27 5,177 05-16-2022, 04:14 PM
Last Post: henrythemouse
  Mobile internet via cellular network mostly not working Anna 17 2,997 02-28-2022, 02:51 PM
Last Post: TRS-80
  sharing mobile data through usb tethering deb75 7 1,346 02-26-2022, 08:52 AM
Last Post: Zebulon Walton
  Programs unable to open display via sudo or pkexec (linssid not working) Zebulon Walton 4 1,985 01-17-2022, 01:58 AM
Last Post: vusra
  Reskinning Apps for Mobile biketool 6 1,033 12-05-2021, 02:30 PM
Last Post: biketool
  Mobile network mode setting not saved Zebulon Walton 3 1,486 12-05-2021, 12:12 AM
Last Post: bcnaz
  gnome podcasts on debian repo, dino-mobile user641 3 1,615 09-11-2021, 12:04 AM
Last Post: user641
  mobile data on mobian not working synaption 10 3,548 08-29-2021, 07:22 AM
Last Post: bcnaz
  Pinephone in Canada using Shaw mobile provider RRman 0 819 06-19-2021, 06:35 PM
Last Post: RRman

Forum Jump:


Users browsing this thread: 1 Guest(s)