My PBP does not power on at all

My PBP arrived home past june 22. I've been working with it for some days.

Trying to solve the usual problem of not activating the screen when turning on Pinebook Pro with Manjaro, using the method, the laptop has finished without turning on at all. No light comes on when I press the power key.

I have tried to solve this problem using the methods explained in several of the threads of this forum, but I have not been successful.

Can someone help me? Thank you very much in advance
you dont use the mrfixit script with manjaro. it is specific to the custom debian squeeze with 4.4 bsp kernel and armhf userspace.

you should probably reinstall your OS after backing up data using a separate sdcard install.
Thank you very much for your quick response.

Yes, I have already tried to reinstall the OS on the emmc card. I don't have an emmc to usb adapter, so what I have done is install Manjaro on an SD card and start the laptop from the SD card.

But, since the laptop doesn't turn on ...

Anyway, thank you very much for your help.
you then need to turn off the emmc and toggle on after booting an sdxard, and use the reset emmc script to access the emmc again.
Again, thank you very much for your interest and your help.

I have tried this solution before, but after reading your proposal I have tried again. With the same null result.

My Pinebook is still dead. It does not react at all to the power button. No led lights up.

I've also tried pressing the reset button, disconnecting and reconnecting the battery, and even connecting the laptop to the AC, bypassing the two disconnected wires (of course, with the battery previously disconnected).

As I say, no solution has worked. My Pinebook is still absolutely dead.

Again, thank you very much.
Hopefully you followed instructions in the wiki per running with battery disconnected ?
   Donate to $upport
your favorite OS Team
Yes of course. However, the problem of not turning on was earlier. Precisely because the laptop was no longer turning on I tried to fix it bypassing the wires.

I wonder if the problem is that, having modified the emmc card, the laptop doesn't recognize the keyboard and consequently "doesn't know" that I'm telling it to turn on when pressing the power key.
I'm not certain of the proper terms, but in the wiki they do discuss part of the pre-boot directions are on the eMMC module.
So a corrupt eMMC can cause it to not boot from the SD card also.
I have been 'playing' with Linux for 30+ years, but I am not tech savvy even yet.

There are tech methods to fix the eMMC, but I would simply remove the eMMC module, and use the eMMC to USB adapter to correct this.
Then re-install the module.

The keyboard is isolated from the operating system,
so unless you changed the keyboard firmware ? It should not affect keyboard performance.
What you say explains very well the cause of the problem. Perfect. I think indeed the solution may be to flash the emmc again using an emmc to usb adapter. In fact, there is a thread that explains that, to be safe, every owner of a pinebook pro should have an adapter. I am concluding that this is great advice.

Thank you very much.
I've managed to resurrect my Pinebook Pro! Of course, from SD.

Analyzing all the suggestions that you have made me, and looking for other forums related to the Pinebook Pro, I discovered that some users had failed to load it with the USB-C cable. I remembered that, just before my PBP died, I had recharged it through that system. This possibility I had previously ruled out because, afterwards, once the PBP no longer turned on, I had recharged it with the normal cable several times. unsuccessfully. However, I read that a user had managed to bring the laptop back to life after recharging it overnight with the normal cable, and decided to try the same. I plugged it into the wall socket and, more than twelve hours later, it finally turned on.

What I still do not understand is why the PBP did not turn on when, previously, I disconnected the battery and bypassed the wires to work with AC ...

It appears that what appeared to be a software bug is actually a hardware problem with the USB-C

Possibly Related Threads…
Thread Author Replies Views Last Post
  Replacement Power Cord recommendation? nathanielwheeler 3 1,276 01-23-2021, 06:43 PM
Last Post: KC9UDX
  power light blinking during charge when pbpro is off Idaho 0 896 01-04-2021, 10:53 AM
Last Post: Idaho
  Taming the power switch? ab1jx 4 2,329 11-30-2020, 10:57 PM
Last Post: rimaille
  Power consumption and suspend to ram robt 33 22,472 11-30-2020, 04:32 PM
Last Post: wdt
Exclamation Seemingly lost power permanently now /cry jimsurvak 2 1,564 11-16-2020, 06:22 PM
Last Post: jimsurvak
Photo Faulty power circuit hackerfantastic 1 1,089 08-24-2020, 01:48 PM
Last Post: Arwen
  We need more power, Scotty! mtnygard 4 2,827 07-23-2020, 11:21 AM
Last Post: mamboman777
Exclamation [SOLVED] PBP will no longer power on s3rvant 10 5,148 07-04-2020, 01:57 PM
Last Post: prokofiev
  Battery draining with external power while under load? RndmNmbr 17 9,744 06-24-2020, 08:33 PM
Last Post: Syonyk
  Noisy power light..... rick1959 2 2,121 06-17-2020, 09:34 AM
Last Post: rick1959

Forum Jump:

Users browsing this thread: 1 Guest(s)