Arch Linux ARM on PinePhone (2020/12/23)
#21
camera still not working as of today's updates. opening the camera in the terminal only says that there's a timeout and it fails (other than the usual locale error). camera clicks a little bit but that's it. in that Mobian thread they said there's a bug in the camera setup script that was revealed by the most recent kernels, but I'm not sure what packages they use to find the new (fixed) version of the script.

edit: I located the Mobian version but it didn't fix anything. reverted to repo version with a quick reinstall of device-pine64-pinephone
  Reply
#22
I figured out how to autostart in Phosh. copy a .desktop file to ~/.config/autostart then edit the "Exec" and "TryExec" lines. optionally edit the rest of the lines. here's my ~/.config/autostart/udiskie-autostart.desktop for reference:
https://snipboard.io/6NDG7n.jpg
  Reply
#23
is there a way to set autoscaling for the keyboard and wallpaper? I set the scaling in phoc.ini to 1.4 for usability, but I'd like for the keyboard and wallpaper to remain at 2. the wallpaper shrinks up in the top left corner to what ever scaling factor, and the keyboard just gets harder and harder to use at smaller scaling factors, especially with my boxing glove hands.
  Reply
#24
I noticed that autorotation is quite slow, it takes forever to rotate the screen and many times it gets stuck on the wrong orientation.
  Reply
#25
flashed latest build to eMMC, camera still doesn't load. complains that it timed out and then exits.
  Reply
#26
Arch Linux ARM (20200822):
  • You can now use sudo instead of logging as root.
  • Added gnome-camera (pinhole) to the image.
  • Added gnome-usage to the image.
  • Added geary to the image.
  • Added support for LZ4 (#37) and support for MIDI keyboards.
  • Fixed no audio until devices are swapped issue (#35)
  • Upgrade chatty to 0.1.15

Download: https://github.com/dreemurrs-embedded/Pi...g/20200822
Find me in the forest, when I'm at my lowest. I don't really think you should continue..

HOLD YOUR BREATH.
  Reply
#27
Looks almost like a daily driver. Almost everything working! Just a laggy keyup response. Not a fan of the PHOSH UI esp compared to UBports but hey, it works!
  Reply
#28
Tried this for the first time today after using Ubuntu touch and this is far more like a daily driver.

The one issue that I have had since installing is that it seems to turn itself off or goes to sleep and then takes several on/off button presses to get going again.

Thank you
  Reply
#29
There's a variant of Arch Linux ARM called Stormux (https://stormux.org), billed as "The accessible Linux distribution for the Raspberry Pi 4". I wonder whether it might be possible to fold in their added accessibility packages, such as alsa-utils, fenrir, orca, etc.  Here's the Stormux package list, for purposes of comparison:

https://gitlab.com/stormux/stormux/-/blo...kages.list

-r
  Reply
#30
Given the work being done here, why isn't Arch Linux ARM listed as a partner project on the main website?

What collaboration is being done with ALARM generally? I can't see any mentions of the PinePhone on the ALARM forum at all... :/
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Keyboard not appearing in Arch Diagon 3 484 03-14-2021, 02:15 AM
Last Post: Danct12
  Pinephone debugging tools jjdekroon 0 175 02-27-2021, 05:05 AM
Last Post: jjdekroon

Forum Jump:


Users browsing this thread: 1 Guest(s)