[Solved] SD Card strange boot behaviour
#3
(06-29-2020, 09:21 AM)carlosqueso Wrote:
(06-29-2020, 02:55 AM)benderni Wrote: I have a pinebook pro running the Manjaro KDE default install everything is working fine. I'm very pleased with the device. I had ordered an additional eMMC of 128GB to replace the 64GB eMMC with. So I installed an other OS, Manjaro I3 SD card image, on a micro SD card I owned (samsung micro sd hc card of 32 GB read and write speeds not known..) and I am experiencing some weird boot issues.

Here are the scenario's:
- If I shutdown the pinebook pro insert the SD Card and power it on, I get the orange light, turning green, but the device won't boot from the SD-card.
- If I boot from the eMMC, insert the SD Card, mount the boot partition of the SD-card and restart the device, it boots without any issues from the SD-card.

Now if I want to replace the eMMC with the 128GB one I am not able to boot from the SD-card as it won't boot from a 'cold' start.

Might this be an issue with the SD-card being to slow? or is this some other problem? I've done the above two scenario's many times over and over again and it always succeeds when first booting up from eMMC, inserting the SD Card, mounting the boot partition of the SD-card and reboot.
Try mounting your SD card boot partition, and editing the extlinux/extlinux.conf file for the SD card to add two dots before each slash as in this post: https://forum.manjaro.org/t/arm-stable-update-2020-04-02-kde-plasma-5-18-4-xorg-server-1-20-8-plasma-mobile-uboots-and-kernels/133266/2 

I
 know it's not supposed to be required on a fresh image, but it solved it for me when I was in your exact scenario.

Thanks for the info, the extlinux/extlinux.conf file already contained the two dots before each slash. I tried /boot/ also instead of the two dots. But that didn't work either. So I'm still stuck on the cold boot issue from my SD card. I also updated the /boot/extlinux/extlinux.conf to contain the two dots. But that didn't help to boot from the SD card either.

Any other suggestions?


Messages In This Thread
RE: SD Card strange boot behaviour - by benderni - 06-29-2020, 01:35 PM
RE: SD Card strange boot behaviour - by benderni - 06-30-2020, 04:27 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Broken boot loader Tango Drango 3 190 08-12-2022, 02:47 PM
Last Post: jpalus
  U-Boot, video console, and visual artifacts dsimic 20 9,371 07-08-2022, 03:29 AM
Last Post: Tazdevl
  PBP Can't Boot Up iscmob 4 807 05-11-2022, 09:14 AM
Last Post: iscmob
  Problem SD card willahughes 1 501 03-22-2022, 09:27 AM
Last Post: jiyong
  Kali Linux on SD card boot wils91 5 1,558 03-08-2022, 04:39 AM
Last Post: Tazdevl
  Very low battery (but charging) causes boot failures Phillip Bell 7 1,598 02-22-2022, 11:20 AM
Last Post: wdt
  Updated stock Manjaro, now won't boot (brick?) pineymousepad 17 4,506 02-18-2022, 02:29 PM
Last Post: jiyong
  boot order straightwalker 7 3,426 12-25-2021, 09:23 AM
Last Post: alidonkaka6
  2021.10 u-boot broken on emmc clonex10100 3 1,842 12-14-2021, 04:24 PM
Last Post: jiyong
  U-Boot with direct NVMe boot support for eMMC/SPI Flash pcm720 122 151,763 12-13-2021, 03:48 PM
Last Post: wdt

Forum Jump:


Users browsing this thread: 1 Guest(s)