Low Transfer Speeds from Pine Samba Server
#1
Hi all,

I am using the latest version of longsleep's Ubuntu to set up a samba server.
After setting the server up and accessing the samba server through my desktop, I transferred a large file directly to the SD card.
To test the read speed, I started a transfer from the Pine to my Desktop.
Despite having gigabit ethernet, I seem to only be able to get speeds of 2 MB/s to 5 MB/s.
Any ideas what could be going on here?

Thanks
  Reply
#2
(05-14-2016, 07:14 PM)preimmortal Wrote: Hi all,

I am using the latest version of longsleep's Ubuntu to set up a samba server.
After setting the server up and accessing the samba server through my desktop, I transferred a large file directly to the SD card.
To test the read speed, I started a transfer from the Pine to my Desktop.
Despite having gigabit ethernet, I seem to only be able to get speeds of 2 MB/s to 5 MB/s.
Any ideas what could be going on here?

Thanks

Could I refer you to this section of the form Ethernet Port, there's a number of topics under discussion there on ethernet port speed. Also what model are you using?

I would start by doing some basic network performance testing, I was luck enough to have a another Linux machine, so I used iperf which has to be installed on both machines. here a guide to using it...
  Reply
#3
Lightbulb 
Using the same xenial longsleep image with a fresh samba install
I get consistent read speed of just over 20MB/s. Samba serves files
from the SD card (32 MB Samsung, as recommended by tkaiser).

The write speeds are around 15MB/s.


Attached Files Thumbnail(s)
   
  Reply
#4
Check you SD speed , You you Sd read at low speed, Does not matter how fast the ethernet is

I suggest the 400X ones not the cheaper ones
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Ubuntu server 20.04 request phi0x 2 872 12-30-2020, 08:02 PM
Last Post: phi0x
  Xenial Minimal Image (PINE A64(+)) 0.6.2-77 pineadmin 4 11,889 08-30-2020, 10:35 AM
Last Post: jrronimo
  Successful build on arm64 pine a64 1GB on armbian alladinrouteme 1 1,538 09-23-2019, 03:30 AM
Last Post: cr2016
  Pine hangs up on boot if I add my exFAT USB drive to /etc/fstab pqueiro 0 1,233 06-10-2019, 12:07 PM
Last Post: pqueiro
  Pine Board using linux stuck during boot sequence ktaragorn 0 1,042 03-23-2019, 04:06 AM
Last Post: ktaragorn
  PINE A64 upgrade to 18.04 possible? RandomUser324 4 4,496 11-29-2018, 11:46 PM
Last Post: tllim
  Xenial Minimal Image (PINE A64(+)) 0.5.5-65 pineadmin 0 2,814 06-15-2017, 12:37 AM
Last Post: pineadmin
  Xenial Minimal Image (PINE A64(+)) 0.5.2-59 pineadmin 0 2,461 05-25-2017, 09:27 AM
Last Post: pineadmin
  Pine as a Pi-hole ... Does that make it a PineHole? tomd 13 15,320 01-26-2017, 12:15 AM
Last Post: auger
  Unable to start Pine Topgun505 16 7,339 11-13-2016, 12:01 AM
Last Post: Gnx

Forum Jump:


Users browsing this thread: 1 Guest(s)