CrOS boot from sd, now pinebook doesn't boot anymore
#6
Again thank you so much for your replies!!

(06-19-2020, 06:38 AM)tophneal Wrote: Green during boot typically indicated that the OS has been found and is booting. (Though that's not always the case.) Have you verified that the SD you're using is fast enough, or has no errors? It could be a bunk card for the high speeds required to run an OS from an SD card.

Got myself another SD card which is faster with more memory. At first, I flashed chromium again, this time it gave a green light, yet it doesn't boot up after half a minute.

I then decided to flash manjaro on this new SD card. And this time, it actually started booting, yet it fails and gives this error:
EXT4-fs error (device mmcxxxxx): ext4_journal_check_start:83: Detected aborted journal
EXT4-fs (mmcxxxxx): Remounting filesystem read-only

So this seems to be related to the actual emmc. Could be wrong tho

(06-19-2020, 06:38 AM)tophneal Wrote: The u-boot changes are pretty normal in the same sense that we get kernel updates. The community has found ways to improve upon it and updates it. Unfortunately in this case, there is an issue with this u-boot update.

Yes, more specifically, you want the idbloader.img, uboot.img, and trust.img files from here: https://github.com/mrfixit2001/updates_r...filesystem
If you look in the update script in that repo, you'll find the commands needed to write those uboot files to your emmc.

Not sure what I'm supposed to do here. First flash the idbloader.img, then the uboot.img and the nthe trust.img to the sd card and run a few commands when booted?

(06-19-2020, 06:38 AM)tophneal Wrote: To make sure I'm understanding you correctly, are you saying Manjaro no longer boots from your emmc? You're correct here, booting an OS should not overwrite/erase your emmc (unless your booting an emmc installer img.)
Exactly, booting from the eMMC seems broken as well. I only used the chromium image mentioned on the pine wiki, which is not an emmc installer as far as I know.


@wdt Thanks for your reply! I've executed exactly what you mentioned yet there doesn't seem to be any difference in behaviour. It turns on, shows the orange power light, and nothing.


Messages In This Thread
RE: CrOS boot from sd, now pinebook doesn't boot anymore - by qdoy55d9wkn8zw - 06-20-2020, 04:14 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  FydeOS for You - Pinebook Pro also1412 52 49,571 12-19-2022, 07:42 PM
Last Post: wangyukunshan
  Which OS can I actually run a 1080p pinebook non-pro? Scott104 1 1,905 10-09-2021, 02:47 PM
Last Post: TRS-80
  Panfrost and CrOS tophneal 2 3,486 04-20-2020, 12:23 PM
Last Post: tophneal
  CrOS debugging request brent.thierens 10 10,533 03-21-2020, 06:20 AM
Last Post: Hexxeh
Question Does the Pinebook Pro support chromium developer mode? TDC_PBP 3 5,473 12-07-2019, 02:33 PM
Last Post: TDC_PBP

Forum Jump:


Users browsing this thread: 1 Guest(s)