External USB C Monitor not working
#30
EDIT: Today dmesg is giving something:
Code:
[  116.626032] cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work [rockchipdrm]] Connected with sink. Re-train link
[  117.851634] usb 7-1: new full-speed USB device number 4 using xhci-hcd
[  118.034760] usb 7-1: New USB device found, idVendor=06c4, idProduct=c100, bcdDevice= 1.24
[  118.034783] usb 7-1: New USB device strings: Mfr=1, Product=2, SerialNumber=5
[  118.034796] usb 7-1: Product: USB-C To DisplayPort Adapter
[  118.034807] usb 7-1: Manufacturer: BizLink Technology Inc.
[  118.034818] usb 7-1: SerialNumber: 101

---------------
It's Xfce, and dmesg doesn't give much to go on.
Code:
$ sudo dmesg --clear
$ dmesg --follow | grep cdn-dp
[656498.179883] cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work [rockchipdrm]] Not connected. Disabling cdn
[656498.650125] cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work [rockchipdrm]] Connected, not enabled. Enabling cdn
I tried another brand of USB-C -> DisplayPort cable and the behavior is the same.

It works the same using xrandr instead of the Xfce Display control panel.
Code:
$ xrandr --output DP-1 --mode 1920x1920 --rate 59.94   # DisplayPort Signal Error
$ xrandr --output DP-1 --mode 1920x1920 --rate 29.94   # Back on again

The X server defaults to the "preferred" refresh rate of 59.94 Hz. To make the monitor work on the sddm login screen, we can change that:
https://blog.victormendonca.com/2018/06/...e-screens/
(the reboot mentioned at the end isn't necessary; it's sufficient to log out & back in to Xfce.)

Code:
xrandr --output DP-1 --mode 1920x1920 --rate 29.94 --primary
All I had to add to /usr/share/sddm/scripts/Xsetup .

Todo: write a file for /usr/share/X11/xorg.conf.d/ so it will apply across all display managers.

The framebuffer video is another matter. Judging by the stretched M at startup & shutdown, it's defaulting to 1920x1080. Setting the resolution on the kernel command line in /boot/extlinux/extlinux.conf seems to affect it since framebuffer video on the monitor stops working, but so far I haven't found a working mode for 1920x1920. Tried IIRC
Code:
video=DP-1:1920x1920@29.94
video=DP-1:1920x1920@59.94
video=DP-1:1920x1920@60
video=DP-1:1920x1920
  Reply


Messages In This Thread
External USB C Monitor not working - by altacus - 06-11-2020, 08:56 PM
RE: External USB C Monitor not working - by v-man - 06-16-2020, 10:35 AM
RE: External USB C Monitor not working - by DrYak - 06-16-2020, 01:24 PM
RE: External USB C Monitor not working - by v-man - 06-16-2020, 02:20 PM
RE: External USB C Monitor not working - by tllim - 06-26-2020, 01:41 PM
RE: External USB C Monitor not working - by wdt - 08-24-2020, 01:33 PM
RE: External USB C Monitor not working - by wdt - 09-03-2020, 10:53 AM
RE: External USB C Monitor not working - by wdt - 10-18-2020, 08:50 PM
RE: External USB C Monitor not working - by DrYak - 11-15-2020, 07:30 PM
RE: External USB C Monitor not working - by jkm - 06-29-2021, 10:34 AM
RE: External USB C Monitor not working - by jkm - 08-02-2021, 07:40 AM
RE: External USB C Monitor not working - by Dendrocalamus64 - 08-08-2021, 10:19 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Slackware Linux working on PBP vxzero 0 397 06-05-2024, 04:30 PM
Last Post: vxzero
  No external monitorvia USB-C over Dockingstation bnjmnhg 14 3,934 11-28-2023, 01:35 PM
Last Post: zaius
  Manjaro ARM: enabling external monitors & fixing Broadcom WiFi after updating trifleneurotic 2 1,231 11-14-2023, 10:57 AM
Last Post: trifleneurotic
  USB 3 port not working with Armbian zaius 3 1,228 11-13-2023, 01:54 PM
Last Post: zaius
  Sleep and external display - Are there any options? chris88233 7 2,299 09-04-2023, 09:03 PM
Last Post: wdt
  Camera not working with Cheese cypresstwist 1 1,447 08-18-2023, 02:02 AM
Last Post: juliamenendez
  5GHz wifi not working snorwood 11 6,309 01-16-2023, 03:41 PM
Last Post: ehcorn
  Pinebook Pro wifi not working Queliffrel 1 1,461 11-30-2022, 06:30 AM
Last Post: myself600
  Resume from suspend not working after flashing Tow-Boot to SPI xp19375 3 2,209 10-31-2022, 10:14 AM
Last Post: wdt
  Webcam not working in Manjaro with Cheese, but works in Armbian petaramesh 1 1,253 09-30-2022, 10:09 AM
Last Post: crazyquark

Forum Jump:


Users browsing this thread: 2 Guest(s)