External USB C Monitor not working
#6
(06-16-2020, 01:28 PM)jiyong Wrote: Connect the monitor before you boot the PBP.
Worked for me with Manjaro and a 1080p monitor.
Hot plugging doesn't work for me.
When I try booting with the USB-C cable between PineBook and monitor I get less errors indeed, but still no picture. Here some of my dmesg (which may or may not be relevant - I just looked for "dp"):
Code:
[    7.031789] dwmmc_rockchip fe310000.mmc: Successfully tuned phase to 47
[    7.035004] mmc0: new ultra high speed SDR104 SDIO card at address 0001
[    7.636187] rockchip-vop ff8f0000.vop: Adding to iommu group 1
[    7.640167] rockchip-vop ff900000.vop: Adding to iommu group 2
[    7.643677] rockchip-dp ff970000.edp: no DP phy configured
[    7.656244] rockchip-drm display-subsystem: bound ff8f0000.vop (ops vop_component_ops [rockchipdrm])
[    7.659642] rockchip-drm display-subsystem: bound ff900000.vop (ops vop_component_ops [rockchipdrm])
[    7.660798] rockchip-drm display-subsystem: bound ff970000.edp (ops rockchip_dp_component_ops [rockchipdrm])
[    7.662036] cdn-dp fec00000.dp: Direct firmware load for rockchip/dptx.bin failed with error -2
[    7.665313] rockchip-drm display-subsystem: bound fec00000.dp (ops cdn_dp_component_ops [rockchipdrm])
[    7.666636] es8316 1-0011: Failed to get IRQ 0: -22
[    7.666638] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    7.807492] asoc-simple-card es8316-sound: ES8316 HiFi <-> ff890000.i2s mapping ok
[    7.807544] asoc-simple-card es8316-sound: ASoC: no DMI vendor name!
[    7.811928] input: rockchip,es8316-codec Headphones as /devices/platform/es8316-sound/sound/card0/input6
[    8.049148] Console: switching to colour frame buffer device 240x67
[    8.114078] rockchip-drm display-subsystem: fb0: rockchipdrmfb frame buffer device
[    8.151955] [drm] Initialized rockchip 1.0.0 20140818 for display-subsystem on minor 0
[    8.219507] fuse: init (API version 7.31)
[    8.253723] usbcore: registered new interface driver uvcvideo
[    8.254506] USB Video Class driver (1.1.1)
[    8.374629] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[    8.375584] cfg80211: failed to load regulatory.db
[    8.741114] cdn-dp fec00000.dp: Direct firmware load for rockchip/dptx.bin failed with error -2
[    8.960333] EXT4-fs (mmcblk2p6): mounted filesystem with ordered data mode. Opts: (null)
[    9.283042] systemd[1]: System time before build time, advancing clock.
[    9.293423] systemd[1]: systemd 245.6-1 running in system mode. (+PAM +AUDIT +SELINUX +IMA +APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD +IDN2 -IDN +PCRE2 default-hierarchy=hybrid)
[    9.296593] systemd[1]: Detected architecture arm64.
Thanks everyone for the quick replies! Actually connecting the extra monitor is not that important to me right now. So far especially video performance still is so poor on the PineBook that I prefer using my 2013 AMD64 PC (8 GByte RAM), when sitting at the desk anyway. I'm mostly using the PBP for when I'm sitting in a more relaxed position.

My monitor is 2560x1440, by the way... about the highest resolution my PC would still support with its integrated Radeon HD graphics.
  Reply


Messages In This Thread
External USB C Monitor not working - by altacus - 06-11-2020, 08:56 PM
RE: External USB C Monitor not working - by v-man - 06-16-2020, 10:35 AM
RE: External USB C Monitor not working - by DrYak - 06-16-2020, 01:24 PM
RE: External USB C Monitor not working - by v-man - 06-16-2020, 02:20 PM
RE: External USB C Monitor not working - by tllim - 06-26-2020, 01:41 PM
RE: External USB C Monitor not working - by wdt - 08-24-2020, 01:33 PM
RE: External USB C Monitor not working - by wdt - 09-03-2020, 10:53 AM
RE: External USB C Monitor not working - by wdt - 10-18-2020, 08:50 PM
RE: External USB C Monitor not working - by DrYak - 11-15-2020, 07:30 PM
RE: External USB C Monitor not working - by jkm - 06-29-2021, 10:34 AM
RE: External USB C Monitor not working - by jkm - 08-02-2021, 07:40 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Slackware Linux working on PBP vxzero 0 231 06-05-2024, 04:30 PM
Last Post: vxzero
  No external monitorvia USB-C over Dockingstation bnjmnhg 14 3,665 11-28-2023, 01:35 PM
Last Post: zaius
  Manjaro ARM: enabling external monitors & fixing Broadcom WiFi after updating trifleneurotic 2 1,132 11-14-2023, 10:57 AM
Last Post: trifleneurotic
  USB 3 port not working with Armbian zaius 3 1,111 11-13-2023, 01:54 PM
Last Post: zaius
  Sleep and external display - Are there any options? chris88233 7 2,128 09-04-2023, 09:03 PM
Last Post: wdt
  Camera not working with Cheese cypresstwist 1 1,376 08-18-2023, 02:02 AM
Last Post: juliamenendez
  5GHz wifi not working snorwood 11 6,100 01-16-2023, 03:41 PM
Last Post: ehcorn
  Pinebook Pro wifi not working Queliffrel 1 1,414 11-30-2022, 06:30 AM
Last Post: myself600
  Resume from suspend not working after flashing Tow-Boot to SPI xp19375 3 2,140 10-31-2022, 10:14 AM
Last Post: wdt
  Webcam not working in Manjaro with Cheese, but works in Armbian petaramesh 1 1,211 09-30-2022, 10:09 AM
Last Post: crazyquark

Forum Jump:


Users browsing this thread: 1 Guest(s)