Can't boot up Manjaro 20.04 eMMc image from SD card...
#11
(06-11-2020, 11:07 AM)tophneal Wrote:
(06-11-2020, 11:00 AM)rick1959 Wrote: Interesting...
There is no mmcblk0....There is mmcblk1 and mmcblk2, one of which is the SD card. And then there are also the choice's for the mmcblk0p1 and mmcblk0p2, which are the wrong choices.
But even if I select the non-SD card choice and hit enter, it takes me to the next page which says "no image available" and a command line prompt......
Maybe I should try XFCE version...?
I'm concerned about bricking the computer....Many Thanks for your time...:-)

mmcblk0 was just an example. the numbering of emmc and sd aren't universal across different OSes for the PBP. One OS could show it as mmcblk1, and another will show it as mmcblk0. determine which mmcblk is the drive you want to write to, and then write your downloaded .img to it. If you're writing to your emmc, be sure to download and use a live .img (you wouldn't want to write manjaro's emmc flash img to you emmc.)
Yes, I understand....Guess I thought the emmc img would guide me through writing the new image to the PBP emmc. Maybe I'm not understanding as well as I'd like to think :-)
Which brings me to whether I'm competent enough to write a live img to the PBP emmc.....One problem at a time....:-)
Many Thanks!! :-)
#12
(06-11-2020, 11:22 AM)rick1959 Wrote: Yes, I understand....Guess I thought the emmc img would guide me through writing the new image to the PBP emmc. Maybe I'm not understanding as well as I'd like to think :-)
Which brings me to whether I'm competent enough to write a live img to the PBP emmc.....One problem at a time....:-)
Many Thanks!! :-)

When you write the emmc installer img to an SD and boot from it, that's exactly what it should do! i brought up writing the live boot img as an alternative you can do, if the emmc installer continues to not boot from sd for you.
#13
(06-11-2020, 01:07 PM)tophneal Wrote:
(06-11-2020, 11:22 AM)rick1959 Wrote: Yes, I understand....Guess I thought the emmc img would guide me through writing the new image to the PBP emmc. Maybe I'm not understanding as well as I'd like to think :-)
Which brings me to whether I'm competent enough to write a live img to the PBP emmc.....One problem at a time....:-)
Many Thanks!! :-)

When you write the emmc installer img to an SD and boot from it, that's exactly what it should do! i brought up writing the live boot img as an alternative you can do, if the emmc installer continues to not boot from sd for you.
You've been very helpful....Thank You!! :-)

I'm likely to hold off now doing a rewrite of the eMMC for now,to preserve the original OS. I can do everything from the SD card and keep it with the OS for testing (play)...But having the fall back to the original, for the time being, so I always have a usable computer. For now...:-)
#14
I am using the ARM Manjaro XFCE 20.04 eMMC to SD Installer on the newest Pinebook Pro.  Because my laptop did not pass QA, I got a backup Pinebook Pro running MATE Debian, not Manjaro KDE like most everyone else got.

Anyway, I boot up the microSD card and hit ESC when the Manjaro logo appears.  I then get the following prompt (but with console GUI):

Code:
Choose your eMMC device - Be sure the correct drive is selected!
Currently, the booted sdcard is at "mmcblk1"

- mmcblk2
- mmcblk2boot0
- mmcblk2boot1
- mmcblk1

Naturally, I choose mmcblk2, only to suddenly exit the gui and get the following:

Code:
==> Image does not exists....
[root@manjaro-arm ~]#

I made this image using Etcher as advised, and I'm looking at the files and there is definitely an image on this micoSD.  What am I missing here?
#15
(06-22-2020, 09:18 PM)nathanielwheeler Wrote: I am using the ARM Manjaro XFCE 20.04 eMMC to SD Installer on the newest Pinebook Pro.  Because my laptop did not pass QA, I got a backup Pinebook Pro running MATE Debian, not Manjaro KDE like most everyone else got.

Anyway, I boot up the microSD card and hit ESC when the Manjaro logo appears.  I then get the following prompt (but with console GUI):

Code:
Choose your eMMC device - Be sure the correct drive is selected!
Currently, the booted sdcard is at "mmcblk1"

- mmcblk2
- mmcblk2boot0
- mmcblk2boot1
- mmcblk1

Naturally, I choose mmcblk2, only to suddenly exit the gui and get the following:

Code:
==> Image does not exists....
[root@manjaro-arm ~]#

I made this image using Etcher as advised, and I'm looking at the files and there is definitely an image on this micoSD.  What am I missing here?

I too am having problems trying to install Manjaro as well.....

Did you run the checksum to make sure the image you have is good? Have you tried the KDE version to see if there's a difference?

I've been able to install either Manjaro XFCE or KDE....However, when it comes to running the first update, I get an error message saying that "usr/lib/P11-kit.trust" already exists and then terminates the update.

Being that it occurs regardless of which image, KDE or XCFE, I use (both were checksummed) I get the same issue.

So, it seems there's something going on. Wonder if my PBP has an internal problem....

Hope you get some resolution soon! :-)
#16
(06-23-2020, 06:35 AM)rick1959 Wrote: I've been able to install either Manjaro XFCE or KDE....However, when it comes to running the first update, I get an error message saying that "usr/lib/P11-kit.trust" already exists and then terminates the update.

Being that it occurs regardless of which image, KDE or XCFE, I use (both were checksummed) I get the same issue.

So, it seems there's something going on. Wonder if my PBP has an internal problem....

So I think this is an issue with Arch. I had to run:
Code:
pamac update --overwrite /usr/lib\*/p11-kit-trust.so

to get the updates to install.

Got the idea from here: https://www.archlinux.org/news/nss3511-1...ervention/
but changed it to use pamac instead of the upstream Arch.
#17
(06-23-2020, 08:08 AM)carlosqueso Wrote:
(06-23-2020, 06:35 AM)rick1959 Wrote: I've been able to install either Manjaro XFCE or KDE....However, when it comes to running the first update, I get an error message saying that "usr/lib/P11-kit.trust" already exists and then terminates the update.

Being that it occurs regardless of which image, KDE or XCFE, I use (both were checksummed) I get the same issue.

So, it seems there's something going on. Wonder if my PBP has an internal problem....

So I think this is an issue with Arch.  I had to run:
Code:
pamac update --overwrite /usr/lib\*/p11-kit-trust.so

to get the updates to install.

Got the idea from here: https://www.archlinux.org/news/nss3511-1...ervention/
but changed it to use pamac instead of the upstream Arch.
Ahhh, Thank You!!
I'll give it a try now...:-)

(06-23-2020, 08:08 AM)carlosqueso Wrote:
(06-23-2020, 06:35 AM)rick1959 Wrote: I've been able to install either Manjaro XFCE or KDE....However, when it comes to running the first update, I get an error message saying that "usr/lib/P11-kit.trust" already exists and then terminates the update.

Being that it occurs regardless of which image, KDE or XCFE, I use (both were checksummed) I get the same issue.

So, it seems there's something going on. Wonder if my PBP has an internal problem....

So I think this is an issue with Arch.  I had to run:
Code:
pamac update --overwrite /usr/lib\*/p11-kit-trust.so

to get the updates to install.

Got the idea from here: https://www.archlinux.org/news/nss3511-1...ervention/
but changed it to use pamac instead of the upstream Arch.
Thank You!!
It worked perfectly. Went from ready to give up to happy camper! Perhaps you might want to add that to the wiki?
Seems too valuable to not put in the wiki...Have you thought about it??
Hope you do...:-)
P.S. I'm skilled at passing the buck! :-)
#18
(06-23-2020, 08:08 AM)carlosqueso Wrote:
(06-23-2020, 06:35 AM)rick1959 Wrote: I've been able to install either Manjaro XFCE or KDE....However, when it comes to running the first update, I get an error message saying that "usr/lib/P11-kit.trust" already exists and then terminates the update.

Being that it occurs regardless of which image, KDE or XCFE, I use (both were checksummed) I get the same issue.

So, it seems there's something going on. Wonder if my PBP has an internal problem....

So I think this is an issue with Arch.  I had to run:
Code:
pamac update --overwrite /usr/lib\*/p11-kit-trust.so

to get the updates to install.

Got the idea from here: https://www.archlinux.org/news/nss3511-1...ervention/
but changed it to use pamac instead of the upstream Arch.

How do I access wifi from the microSD?  iwconfig and netctl aren't installed, so I'm not sure how I can update this library.
#19
(06-23-2020, 12:31 PM)nathanielwheeler Wrote:
(06-23-2020, 08:08 AM)carlosqueso Wrote:
(06-23-2020, 06:35 AM)rick1959 Wrote: I've been able to install either Manjaro XFCE or KDE....However, when it comes to running the first update, I get an error message saying that "usr/lib/P11-kit.trust" already exists and then terminates the update.

Being that it occurs regardless of which image, KDE or XCFE, I use (both were checksummed) I get the same issue.

So, it seems there's something going on. Wonder if my PBP has an internal problem....

So I think this is an issue with Arch.  I had to run:
Code:
pamac update --overwrite /usr/lib\*/p11-kit-trust.so

to get the updates to install.

Got the idea from here: https://www.archlinux.org/news/nss3511-1...ervention/
but changed it to use pamac instead of the upstream Arch.

How do I access wifi from the microSD?  iwconfig and netctl aren't installed, so I'm not sure how I can update this library.
You're using the NON-eMMC file (image), right? On the SD card...?
#20
(06-23-2020, 12:35 PM)rick1959 Wrote:
(06-23-2020, 12:31 PM)nathanielwheeler Wrote:
(06-23-2020, 08:08 AM)carlosqueso Wrote:
(06-23-2020, 06:35 AM)rick1959 Wrote: I've been able to install either Manjaro XFCE or KDE....However, when it comes to running the first update, I get an error message saying that "usr/lib/P11-kit.trust" already exists and then terminates the update.

Being that it occurs regardless of which image, KDE or XCFE, I use (both were checksummed) I get the same issue.

So, it seems there's something going on. Wonder if my PBP has an internal problem....

So I think this is an issue with Arch.  I had to run:
Code:
pamac update --overwrite /usr/lib\*/p11-kit-trust.so

to get the updates to install.

Got the idea from here: https://www.archlinux.org/news/nss3511-1...ervention/
but changed it to use pamac instead of the upstream Arch.

How do I access wifi from the microSD?  iwconfig and netctl aren't installed, so I'm not sure how I can update this library.
You're using the NON-eMMC file (image), right? On the SD card...?
Yes, currently logged in as root@manjaro-arm, which is the microSD card.  I suppose I could log into the eMMC as debian, but I don't know how I would make changes from there to the microSD image.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Kernel panic on boot with danielt's Debian installer hjalfi 9 444 Yesterday, 08:35 AM
Last Post: sepp
  PostmarketOS - Why swap file not on at boot? stozi 2 118 Yesterday, 01:59 AM
Last Post: lusk
  postmarketOS/Alpine edge image for the Pinebook Pro MartijnBraam 70 44,372 Yesterday, 01:53 AM
Last Post: lusk
  Pinebook pro nearly unusable after using manjaro-arm-installer TheCounselor 0 80 06-18-2021, 03:34 PM
Last Post: TheCounselor
  Pinebook Pro Manjaro Power Savinng Tips HelpMyBatteryIsDraining 1 145 06-15-2021, 08:42 AM
Last Post: moonwalkers
  [LibreOffice & Gimp] ARM support: no hardware acceleration on [Manjaro] Pinebook Pro regivanx 0 75 06-15-2021, 04:04 AM
Last Post: regivanx
  Official openSUSE: U-Boot, dtb and graphics Jojonintendo 1 216 06-12-2021, 08:38 AM
Last Post: Jojonintendo
  Manjaro and Arch repository with privacy oriented software as400 77 41,979 06-08-2021, 04:54 AM
Last Post: llsf
Question Building custom kernel (5.11.x) for Manjaro? ppafin 4 535 06-02-2021, 04:17 AM
Last Post: ppafin
Lightbulb Hardware video acceleration in Chromium on Manjaro siemsenit 3 358 06-01-2021, 09:51 AM
Last Post: siemsenit

Forum Jump:


Users browsing this thread: 1 Guest(s)