PBP not powering up (anymore)
#12
(06-06-2020, 02:23 PM)Criena Wrote:
(06-06-2020, 02:15 AM)spikerguy Wrote:
(05-31-2020, 05:00 PM)Criena Wrote: Hi there,

after waiting for such a loooong time, I finally got my PBP on Friday.

Over the weekend I played around a little bit with Manjaro and then wanted to try a different OS. After repartitioning the eMMC, I accidentally pressed the false delete key (i.e. the power button) and the system shut down. Since then I can't get the PBP powering up anymore. Neither a USB stick (the one I used for the interrupted installation) nor an SD card with the Manjaro KDE image does the job.

I don't really understand what's wrong since at least the SD card should do the trick. A hardware failure just in that unfortunate moment would be a big coincidence. But what else could it be and most importantly: how can I get it fixed?


Anyone got a lifesaving clue?

Thanks!
Criena
Can you share the OS dsitro image you were trying to flash when you accidentally powered off the device? This is give us a better understanding on what the uboot is trying to do.

Also the last option would be to enable uart and get uart logs, this will need uart cable used for pinebookpro.

As everyone have already advised you about booting from SD card then you might have to try a different sd card. You should try all the major os images like debian from mrfixit should definitely work as it is using bsp uboot. 

Try different sd card and report back.

Good luck.


Hi,

the image I wanted to install was NixOS. I created an image from https://github.com/samueldr/wip-pinebook-pro, put it on a USB stick, booted, repartitioned the eMMC and then accidentally powered off the machine. Nothing from NixOS is on the eMMC yet. I'm pretty sure I dd'ed the eMMC's first few MB, so I guess the eMMC is totally blank.

I tried to boot from the USB stick again (which worked before), I put the official Manjaro on an SD card, I tried mrfixit's Debian image on the same SD card and also a different one. I disabled the eMMC (via switch 24) and now also removed it. Nothing has any positive effect.

What I did recognise is, that using an SD card, the power LED flashes green for a millisecond. Whereas using a USB stick, the power LED stays dark and also the USB stick itself doesn't get any power. My conclusion is, that the USB stick only works indirectly via uboot running from eMMC or SD card. That's good to know, but doesn't help me solve the problem.

Ok, So I think you should try to flash the emmc directly. You will need emmc to us connector.
  • Remove the emmc from the board.
  • Connect Emmc to the USB adaptor.
  • Connect USB Adaptor to your regular pc/laptop.
  • Flash Manjaro SD Card Image to it using Etcher or Debian Mr. Fixits image. (Depends on your choice).
  • Put emmc back to the PBP Board and enable the switch and boot it.

  • It should work fine this way. 
This is the last resort for knowing if the system is fine as you mentioned that you cannot boot from sd card even when the emmc is removed.

Sample image of eMMC to USB adaptor.
[Image: 31T9Y1LIX8L._AC_.jpg]
Manjaro ARM Team.
Devices: Pinebook Pro & PinePhone.


Messages In This Thread
PBP not powering up (anymore) - by Criena - 05-31-2020, 05:00 PM
RE: PBP not powering up (anymore) - by xmixahlx - 05-31-2020, 08:15 PM
RE: PBP not powering up (anymore) - by Criena - 06-01-2020, 05:56 AM
RE: PBP not powering up (anymore) - by Criena - 06-02-2020, 09:59 AM
RE: PBP not powering up (anymore) - by golly - 06-02-2020, 11:33 AM
RE: PBP not powering up (anymore) - by golly - 06-10-2020, 08:57 AM
RE: PBP not powering up (anymore) - by xmixahlx - 06-02-2020, 12:40 PM
RE: PBP not powering up (anymore) - by Criena - 06-05-2020, 03:36 PM
RE: PBP not powering up (anymore) - by xmixahlx - 06-02-2020, 03:11 PM
RE: PBP not powering up (anymore) - by wdt - 06-05-2020, 07:57 PM
RE: PBP not powering up (anymore) - by spikerguy - 06-06-2020, 02:15 AM
RE: PBP not powering up (anymore) - by Criena - 06-06-2020, 02:23 PM
RE: PBP not powering up (anymore) - by spikerguy - 06-07-2020, 07:41 AM
RE: PBP not powering up (anymore) - by xmixahlx - 06-07-2020, 11:12 AM
RE: PBP not powering up (anymore) - by Criena - 06-07-2020, 01:53 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Pinebook Pro not powering on when eMMC hardware switch is off vgrimaldi 2 270 06-29-2021, 05:19 AM
Last Post: KC9UDX
Shocked PineBook Pro Powering Down Instead of sleeping conor.murphy99 3 1,486 07-07-2020, 04:09 PM
Last Post: xmixahlx
  Pinebook Pro not powering on / not booting (tried things listed in wiki/forum) kiefer 16 8,349 02-24-2020, 08:04 PM
Last Post: kiefer

Forum Jump:


Users browsing this thread: 1 Guest(s)