A quick tutorial on having the image work its best
#1
All of these things may, very well, be addressed by the time you receive your phone, but I am just posting this in the even X or Y doesn't work/ is broken:

[edit] For starters, every morning (EU Time) you may wish to:

Code:
sudo apt update && apt upgrade -y


1) Downgrade Mesa (currently newest Mesa brakes the UI) [edit] fixed

2) Enabling sound (speaker routing at this time is also wrong - may be fixed soon)
3) Manually start the the modem (fix / hack soon)
[edit]  4) Change the wallpaper

1) Downgrade Mesa:




2) Enable Sound:


Code:
sudo modprobe snd_soc_simple_amplifier
sudo modprobe snd_soc_simple_card_utils


then:


Code:
amixer -c 0 set 'AIF1 Slot 0 Digital DAC' unmute

[edit] 2 Feb 2020

Then:

Quote:
Code:
amixer -c 0 set 'Line Out' unmute

To set volume on max:

Code:
Code:
amixer sset 'Line Out' 100%


3) Start modem:


Code:
sudo /usr/share/ofono/scripts/enable-modem
sudo /usr/share/ofono/scripts/online-modem
4) Change the wallpaper
In settings, navigate to background, and choose a different wallpaper (like the one with dogs) - there is some odd glitch that makes the OS run slow due to the wallpaper sizes.
You can find me on IRC, Discord and Twitter




Messages In This Thread
A quick tutorial on having the image work its best - by Luke - 01-25-2020, 12:26 PM
re: amixer not working - by curtvaughan - 02-15-2020, 09:03 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Sound won’t work LMalilil 2 1,204 07-28-2020, 09:52 AM
Last Post: Cree
  wifi does not work - authentication problem? pphone-newbie 7 3,013 07-26-2020, 01:30 PM
Last Post: Cree
  dropdown menu doesn't work daniel 3 1,417 07-22-2020, 01:17 PM
Last Post: natasha
  Tutorial for new UBPorts CE users / list of known issues? ThatGeoGuy 2 1,875 07-21-2020, 05:54 PM
Last Post: natasha
  Image #58 Touchscreen Unresponsive BryWilson 3 1,814 06-27-2020, 02:38 AM
Last Post: Zweitaktmotor
  Does Miracast work? mercrapper 1 1,105 06-25-2020, 08:18 AM
Last Post: heng
  Image build guide? Djhg2000 3 1,940 06-18-2020, 02:04 PM
Last Post: bingo600
  Only the top few rows of pixels work on stable OTA 3 NoraCodes 0 735 06-18-2020, 09:18 AM
Last Post: NoraCodes
  Battery issues with latest image ashley123 6 2,733 06-14-2020, 11:06 AM
Last Post: KeithMcN
  Ubports OTA won't work on my braveheart none 12 5,232 06-13-2020, 03:23 AM
Last Post: tsar_chasm

Forum Jump:


Users browsing this thread: 1 Guest(s)