nVME crashes system
#30
(01-19-2020, 10:01 AM)mamboman777 Wrote: AaaaaandI was wrong again.  I checked using "nvme get-feature -f 2" and the drive is running in PS 0 (the most hungry).  I was able to add the script "nvme set-feature -f 2 -v 2" to a cron job at reboot and the drive says it's running in power state 2 now.

Ok. I ran a couple benchmarks to see the difference between power states and performance.  The results are staggering to me. PS 2 write speed is 85.  PS 0 write speed is 850.  PS 2 read 65.  PS 0 read is 1.1gb.  I'm going to keep reading on APST and see if I can get the patch running on my system. I'll keep you all posted.t:
edit:  I have decided to go with PS1 for my default.  Read and write speed benchmarked at just under 750 MiB.  That means I'm paying .8W  for %80 the performance.  I'm saving 1W for a %20 loss.  Seems like the best compromise until APST is up and running.

Well...it seems this has quickly gone over my head.  

Here's the link to the patch:  https://github.com/damige/linux-nvme/blo.../README.md

According to this it says "4.8.x" is the lowest non-ARCH kernel patch available.  Since the current bionic image is at 4.4.190, does that mean this patch is not compatible?   I think t his patch went into the kernel at 4.11.x or something like that, so hopefully in a future update this will not be an issue.  This could mean considerable power savings for NVME'ers.  I'll stop posting about this and wait until someone smarter than me talks about how to get this enabled in the kernel for the PBP.  Thanks!

Well, I messed my system up yesterday, so I decided to start over.  I went with Manjaro to see if the NVME APST is working and I can confirm that APST is working as expected in Manjaro, no patch needed.  I'll keep you posted on the battery life and performance.  I was getting about  6 hours battery life.
  Reply


Messages In This Thread
nVME crashes system - by mamboman777 - 01-15-2020, 05:47 AM
RE: nVME crashes system - by tophneal - 01-15-2020, 07:25 AM
RE: nVME crashes system - by mamboman777 - 01-15-2020, 07:55 AM
RE: nVME crashes system - by Wizzard - 01-15-2020, 08:14 AM
RE: nVME crashes system - by tophneal - 01-15-2020, 08:08 AM
RE: nVME crashes system - by tophneal - 01-15-2020, 08:22 AM
RE: nVME crashes system - by mamboman777 - 01-15-2020, 08:36 AM
RE: nVME crashes system - by Arwen - 01-15-2020, 08:35 AM
RE: nVME crashes system - by tophneal - 01-15-2020, 08:45 AM
RE: nVME crashes system - by mamboman777 - 01-15-2020, 10:14 AM
RE: nVME crashes system - by tophneal - 01-15-2020, 10:24 AM
RE: nVME crashes system - by mamboman777 - 01-15-2020, 11:01 AM
RE: nVME crashes system - by tophneal - 01-15-2020, 11:15 AM
RE: nVME crashes system - by mamboman777 - 01-15-2020, 12:44 PM
RE: nVME crashes system - by tophneal - 01-15-2020, 12:51 PM
RE: nVME crashes system - by mamboman777 - 01-15-2020, 12:55 PM
RE: nVME crashes system - by tophneal - 01-15-2020, 01:24 PM
RE: nVME crashes system - by mamboman777 - 01-15-2020, 05:36 PM
RE: nVME crashes system - by belfastraven - 01-15-2020, 06:40 PM
RE: nVME crashes system - by mamboman777 - 01-15-2020, 07:11 PM
RE: nVME crashes system - by mamboman777 - 01-15-2020, 08:44 PM
RE: nVME crashes system - by mamboman777 - 01-18-2020, 11:37 AM
RE: nVME crashes system - by Arwen - 01-18-2020, 04:32 PM
RE: nVME crashes system - by mamboman777 - 01-18-2020, 04:56 PM
RE: nVME crashes system - by Arwen - 01-18-2020, 05:30 PM
RE: nVME crashes system - by mamboman777 - 01-18-2020, 09:28 PM
RE: nVME crashes system - by Arwen - 01-18-2020, 10:10 PM
RE: nVME crashes system - by mamboman777 - 01-19-2020, 06:45 AM
RE: nVME crashes system - by mamboman777 - 01-19-2020, 10:01 AM
RE: nVME crashes system - by mamboman777 - 01-27-2020, 12:51 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  NVMe SSD and battery life? dieselnutjob 3 423 04-19-2021, 01:55 PM
Last Post: slyecho
  Selling Pinebook Pro 128GB version (w/ NVMe adaptor) due to lack of use VoT 3 872 03-19-2021, 03:11 AM
Last Post: jj282
  [split] U-Boot with NVMe support, keyboard & display working as400 83 30,884 01-27-2021, 12:48 AM
Last Post: as400
  U-Boot with direct NVMe boot support for eMMC/SPI Flash pcm720 115 84,575 01-04-2021, 09:57 AM
Last Post: wdt
  emmc vs NVMe real-world performances Henry 7 2,625 11-15-2020, 02:03 PM
Last Post: rimaille
  NVMe doesn't show up Seferi 19 4,587 10-30-2020, 07:08 AM
Last Post: ReddestDream
  Unable to mount NVME (PineBook Pro) WallStreet 4 2,113 09-13-2020, 11:16 PM
Last Post: Phillip Bell
  NVME problems mamboman777 12 4,501 08-19-2020, 12:01 PM
Last Post: xmixahlx
  NVMe adapter separate order? powerful owl 5 1,688 07-27-2020, 10:02 PM
Last Post: powerful owl
  Procedure for getting replacement NVMe adapter for PBP? joshtemp123org 2 1,310 07-21-2020, 08:31 PM
Last Post: joshtemp123org

Forum Jump:


Users browsing this thread: 1 Guest(s)