Whine when playing video
#19
So I just took some time to mess around with the audio circuitry on my PBP. I desoldered L11 (0 Ohm resistor) and connected some wires so that I can easily try different components. Long wires aren't ideal, especially when troubleshooting EMI issues, but as you'll see from my findings below, my setup shouldn't be a problem here.

Okay, so here's what I tried:

Replace L11 with a resistor.
75 Ohms: Noise goes down noticeably (but not gone), but the audio amp cuts out (audio gone for half a second, then back for half a second) already at low volumes.
23 Ohms: Noise goes down only a bit, and still cuts out at high volumes

Replace L11 with an inductor:
Random one I had lying around: No effect whatsoever

Add a 100 nF in parallel with the PA supply:
No effect.

Power the PA from my external lab power supply:
No noise, full volume achievable. (That also sorta validates my test setup.)

Just because it might be interesting, here's the power draw of both power amps:
disabled: 0 mA
idle: 20 mA
quiet listening: ~30 mA
full volume: up to 300 mA

That's a lot more than I expected, and it explains why the RC filter above caused the amp to cut out, but it's what we have to work with. Also, I was hoping I could maybe run the PA off of 3.3 V, which would've allowed to maybe add a linear regulator, but I tried it with my lab supply and it started to cut out at higher volumes already at 4.5 V.

So, in summary, I don't have a solution yet. At least we know for certain now where the noise is coming from (the 5V supply).

Any ideas on what else I could try? I guess taking a look at the source (the 5V regulator) might help (and that would be the proper way to do it), but it's also the one that's a lot harder to fix now that the boards are finished. Not to mention it's way easier to fry the board by playing around with these components.

Thanks,
Markus

PS: Notebooks with random wires coming out of the side sure look fun^^


Messages In This Thread
Whine when playing video - by phuzy - 11-07-2019, 06:54 PM
RE: Whine when playing video - by diodelass - 11-07-2019, 07:14 PM
RE: Whine when playing video - by phuzy - 11-08-2019, 05:54 AM
RE: Whine when playing video - by VoxUnius - 11-07-2019, 08:33 PM
RE: Whine when playing video - by diodelass - 11-08-2019, 08:57 AM
RE: Whine when playing video - by linusfargo - 11-08-2019, 07:39 PM
RE: Whine when playing video - by tgrauss - 11-09-2019, 02:57 AM
RE: Whine when playing video - by Firestorm - 11-09-2019, 06:35 AM
RE: Whine when playing video - by linusfargo - 11-09-2019, 11:46 AM
RE: Whine when playing video - by LinuxIsNewToMe - 03-20-2020, 01:36 PM
RE: Whine when playing video - by Firestorm - 04-21-2020, 02:43 AM
RE: Whine when playing video - by tgrauss - 11-14-2019, 04:07 PM
RE: Whine when playing video - by linusfargo - 11-15-2019, 12:19 AM
RE: Whine when playing video - by Firestorm - 11-15-2019, 03:21 PM
RE: Whine when playing video - by phuzy - 11-17-2019, 08:45 PM
RE: Whine when playing video - by pfeerick - 11-28-2019, 03:00 AM
RE: Whine when playing video - by Samarium151 - 11-29-2019, 08:47 AM
RE: Whine when playing video - by linusfargo - 12-01-2019, 11:46 AM
RE: Whine when playing video - by m42uko - 12-01-2019, 04:57 AM
RE: Whine when playing video - by zaius - 12-01-2019, 11:37 AM
RE: Whine when playing video - by m42uko - 12-02-2019, 08:52 AM
RE: Whine when playing video - by m42uko - 12-04-2019, 10:32 AM
RE: Whine when playing video - by Samarium151 - 12-04-2019, 10:01 PM
RE: Whine when playing video - by m42uko - 12-05-2019, 02:04 PM
RE: Whine when playing video - by m42uko - 12-06-2019, 01:25 AM
RE: Whine when playing video - by zaius - 12-06-2019, 02:05 PM
RE: Whine when playing video - by m42uko - 12-15-2019, 08:03 AM
RE: Whine when playing video - by Samarium151 - 12-31-2019, 08:41 PM
RE: Whine when playing video - by phuzy - 07-09-2020, 02:33 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Replacement for video cable (EDP to LCD/camera)? pnwkayaker 2 1,204 10-13-2020, 08:42 PM
Last Post: pnwkayaker
  USB C video and hub/net/audio/whatever Corkonian 1 1,204 11-15-2019, 11:36 PM
Last Post: deviantgnome
  USB-C hub/dock/video Corkonian 2 1,903 11-02-2019, 02:29 PM
Last Post: Corkonian

Forum Jump:


Users browsing this thread: 1 Guest(s)