RockPro64 - Armbian no sound from jack
#1
Anyone else problem with Armbian and getting no sound from the jack?
When I open a music stream and have a look in the volume control I see the graphic VU bar moving. Tried different stuff but can't find the solution from the problem.


I'm a total Linux n00b but I did find a command on the internet which I tried and said this:

master@rockpro64:/etc/alsa/conf.d$ aplay -L
default
    Playback/recording through the PulseAudio sound server
null
    Discard all samples (playback) or generate zero samples (capture)
jack
    JACK Audio Connection Kit
pulse
    PulseAudio Sound Server
sysdefault:CARD=rkes8316hpsound
    rk-es8316-hp-sound,
    Default Audio Device
dmix:CARD=rkes8316hpsound,DEV=0
    rk-es8316-hp-sound,
    Direct sample mixing device
dsnoop:CARD=rkes8316hpsound,DEV=0
    rk-es8316-hp-sound,
    Direct sample snooping device
hw:CARD=rkes8316hpsound,DEV=0
    rk-es8316-hp-sound,
    Direct hardware device without any conversions
plughw:CARD=rkes8316hpsound,DEV=0
    rk-es8316-hp-sound,
    Hardware device with all software conversions
usbstream:CARD=rkes8316hpsound
    rk-es8316-hp-sound
    USB Stream Output
sysdefault:CARD=rkspdifsound
    rk-spdif-sound,
    Default Audio Device
dmix:CARD=rkspdifsound,DEV=0
    rk-spdif-sound,
    Direct sample mixing device
dsnoop:CARD=rkspdifsound,DEV=0
    rk-spdif-sound,
    Direct sample snooping device
hw:CARD=rkspdifsound,DEV=0
    rk-spdif-sound,
    Direct hardware device without any conversions
plughw:CARD=rkspdifsound,DEV=0
    rk-spdif-sound,
    Hardware device with all software conversions
usbstream:CARD=rkspdifsound
    rk-spdif-sound
    USB Stream Output
sysdefault:CARD=rkhdmidpsound
    rk-hdmi-dp-sound,
    Default Audio Device
dmix:CARD=rkhdmidpsound,DEV=0
    rk-hdmi-dp-sound,
    Direct sample mixing device
dsnoop:CARD=rkhdmidpsound,DEV=0
    rk-hdmi-dp-sound,
    Direct sample snooping device
hw:CARD=rkhdmidpsound,DEV=0
    rk-hdmi-dp-sound,
    Direct hardware device without any conversions
plughw:CARD=rkhdmidpsound,DEV=0
    rk-hdmi-dp-sound,
    Hardware device with all software conversions
usbstream:CARD=rkhdmidpsound
    rk-hdmi-dp-sound
    USB Stream Output
master@rockpro64:/etc/alsa/conf.d$


Messages In This Thread
RockPro64 - Armbian no sound from jack - by Pineapple - 09-16-2019, 08:27 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  slarm64 (unofficial slackware) ROCKPro64 RK3399 (aarch64) mara 51 51,192 09-11-2022, 10:20 AM
Last Post: mara
  Can RockPRO64 support PCIe Endpoint? andrewg132 2 200 09-09-2022, 12:34 PM
Last Post: andrewg132
  RockPro64 linux console video mode callegar 0 69 09-06-2022, 02:32 PM
Last Post: callegar
  A fix for Bluetooth audio stuttering on the RockPro64 raph 0 110 08-13-2022, 02:38 AM
Last Post: raph
  Armbian images available Luke 60 62,715 08-04-2022, 06:56 AM
Last Post: Rocklobster
  Expose /dev/mali0 in armbian pedromiguel.sanchez 2 280 07-25-2022, 04:52 AM
Last Post: pedromiguel.sanchez
  Enable DSI/TD Ports on Armbian (jammy) dkebler 0 237 06-16-2022, 06:56 PM
Last Post: dkebler
  [OS] SkiffOS and Buildroot for Rockpro64 w/ 5.17 kernel paralin1 1 644 05-08-2022, 03:26 PM
Last Post: paralin1
  Armbian Jammy-Running fairly stable Rocklobster 0 413 05-04-2022, 01:00 PM
Last Post: Rocklobster
  PostmarketOS on RockPro64 publiclewdness 0 370 04-24-2022, 11:53 AM
Last Post: publiclewdness

Forum Jump:


Users browsing this thread: 1 Guest(s)